summaryrefslogtreecommitdiff
path: root/www-apps/phpsysinfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /www-apps/phpsysinfo
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'www-apps/phpsysinfo')
-rw-r--r--www-apps/phpsysinfo/Manifest2
-rw-r--r--www-apps/phpsysinfo/phpsysinfo-3.3.4.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/www-apps/phpsysinfo/Manifest b/www-apps/phpsysinfo/Manifest
index 962c39fd9b7b..5d196ddc3559 100644
--- a/www-apps/phpsysinfo/Manifest
+++ b/www-apps/phpsysinfo/Manifest
@@ -1,3 +1,5 @@
DIST phpsysinfo-3.3.2.tar.gz 891158 BLAKE2B 40428647a502f9861f89a490a10e95bef0fdf306d2ee27507b4f396ee7371ca3d75b7259db53b8501b127fb525dce283cb8c73e50172b5b2a78fc490fc7f658a SHA512 33f76436d6ba1aa76a4c7e7dba84f5d4bf458b505df47d65ff9f1ffecc4db48a853c9cdb8583019e70c4d0b54c184ae6d48968f3ed820a711804095a5fc31b07
+DIST phpsysinfo-3.3.4.tar.gz 946436 BLAKE2B bdfb731ac8e60e436f915b0ac72f3c327b08dfccee0d1cedc4ddc89700c4dc76bdd73d9e37ab82fad25e096a62a9a4d31442939558ab593ba5b97520d428a6c1 SHA512 6bcbf78edfa3af441ee6768cce559635f7aed6ce0e357379a7ad1158dab21b860c82845d746f66074c84cdc92e4a21fb4710f61b69ee8cfa1e457d098d642bf2
EBUILD phpsysinfo-3.3.2.ebuild 1680 BLAKE2B 0b6d1d90d01ceb50736042ee13cf800f577a958ff1326f4918ace512cf8179d158c29e5fe3332f8a3aaf76002f2b27d3ada183648004c48803af6c8ac82e3814 SHA512 e93f3f6affef0bcb7f6eabebd15156b4e5558eec86abbdaff6319a6eda2d03d4be60c9bff5ed495d9d31cee65f8e34972a7519bd2451ee5649231ecb14ea6b0a
+EBUILD phpsysinfo-3.3.4.ebuild 1684 BLAKE2B 0f0feb31ef87d879ad4777013d1c6f1837227119be362ac5d324c11e8ce49cdab8531db4662fe56fb17c97aa3aba35070f2b0e29fbd027eceaa92b976aa78ea9 SHA512 159b7cfd4d61a0bece701f7a527bb1834cd804201bffff3b0713f409fb7e79d72035615f0994fa68b83fd6ddc48d68475b3e7a6abc28237f0d5832a51b9263d0
MISC metadata.xml 511 BLAKE2B 3139dd25eebac631793e015cb1db6e41d64c5a3e9a75f61f340d0f1ba73b99d304716dfca4b0f0f51baf0f46a740312bb198c52aa625f5b838e6ae10f341a8e1 SHA512 59fd8766c9545193c86374e1dd05d0a08e1f5c548f4297ad4fe22acbd4ba36aa4ae46ccf6f497bfae1a7e015cf95a5f51fb417266c21cf5b5201eac31b543d41
diff --git a/www-apps/phpsysinfo/phpsysinfo-3.3.4.ebuild b/www-apps/phpsysinfo/phpsysinfo-3.3.4.ebuild
new file mode 100644
index 000000000000..98bf2ace46fa
--- /dev/null
+++ b/www-apps/phpsysinfo/phpsysinfo-3.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature webapp
+
+DESCRIPTION="A customizable PHP script that displays information about your system nicely"
+HOMEPAGE="https://rk4an.github.com/phpsysinfo/"
+SRC_URI="https://github.com/rk4an/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+RDEPEND="
+ dev-lang/php[simplexml,xml,xsl(+),xslt(+),unicode]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md README*
+ rm CHANGELOG.md COPYING README* .gitignore .travis.yml || die
+
+ mv phpsysinfo.ini{.new,} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/phpsysinfo.ini
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ optfeature "showing disk temperatures." app-admin/hddtemp
+ optfeature "showing system uptime." app-misc/uptimed
+ optfeature "showing snmp statistics." net-analyzer/net-snmp
+ optfeature "showing iptables rules." net-firewall/iptables
+ optfeature "showing ipmi sensors." sys-apps/ipmitool
+ optfeature "showing ipmi sensors." sys-apps/ipmiutil
+ optfeature "showing system sensors." sys-apps/lm-sensors
+ optfeature "showing s.m.a.r.t. health." sys-apps/smartmontools
+ optfeature "showing lsi raid controller health." sys-block/megactl
+ optfeature "showing fake raid statistics." sys-fs/dmraid
+ optfeature "showing software raid statistics." sys-fs/mdadm
+ optfeature "showing quota information." sys-fs/quota
+ optfeature "showing ipmi sensors." sys-libs/freeipmi
+ optfeature "showing apc ups statistics." sys-power/apcupsd
+ optfeature "showing ups statistics." sys-power/nut
+}