summaryrefslogtreecommitdiff
path: root/www-apps/phpsysinfo/phpsysinfo-3.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apps/phpsysinfo/phpsysinfo-3.2.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apps/phpsysinfo/phpsysinfo-3.2.2.ebuild')
-rw-r--r--www-apps/phpsysinfo/phpsysinfo-3.2.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/www-apps/phpsysinfo/phpsysinfo-3.2.2.ebuild b/www-apps/phpsysinfo/phpsysinfo-3.2.2.ebuild
new file mode 100644
index 000000000000..3288fa826894
--- /dev/null
+++ b/www-apps/phpsysinfo/phpsysinfo-3.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit webapp
+
+DESCRIPTION="phpSysInfo is a nice package that will display your system stats via PHP"
+HOMEPAGE="https://rk4an.github.com/phpsysinfo/"
+SRC_URI="https://github.com/rk4an/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 hppa ppc ppc64 x86 ~x86-fbsd"
+
+RDEPEND="
+ virtual/httpd-php
+ dev-lang/php[simplexml,xml,xsl(+),xslt(+),unicode]
+"
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md README*
+ rm CHANGELOG.md COPYING README* .gitignore .travis.yml || die
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ newins phpsysinfo.ini{.new,}
+
+ webapp_configfile "${MY_HTDOCSDIR}"/phpsysinfo.ini
+ webapp_src_install
+}