summaryrefslogtreecommitdiff
path: root/www-apps/nanoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 07:29:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 07:29:14 +0100
commite59b99df9503539c0231e655a17bccf83f8a270d (patch)
treedbd3fc51c710879436a4122898a3653c8c0d4ae8 /www-apps/nanoc
parent9fce2d9787c37a690336f5e345a49d83ee60bc8a (diff)
gentoo auto-resync : 25:06:2023 - 07:29:14
Diffstat (limited to 'www-apps/nanoc')
-rw-r--r--www-apps/nanoc/Manifest2
-rw-r--r--www-apps/nanoc/nanoc-4.12.16.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/www-apps/nanoc/Manifest b/www-apps/nanoc/Manifest
index b40c4cd1a1ff..b4a00b8d58c9 100644
--- a/www-apps/nanoc/Manifest
+++ b/www-apps/nanoc/Manifest
@@ -1,5 +1,7 @@
DIST nanoc-4.12.14.tar.gz 347902 BLAKE2B 325560667b370df0b245523463be8d5e9cda0cbfbe224e790f84c98aab21eee85a87fce962a24fc975cd98b0b68ad8611fe5c42cc4e0001fe4b6b17ab59bbc1a SHA512 bbc54d84f50cb7586467e33db5986ae9c93ba402b102d159864f78cfb2f3102cea736a5b89655345da93b6dfe1576aa188eba143d206a747bbff38dc27a4b2f9
DIST nanoc-4.12.15.tar.gz 348052 BLAKE2B a880b3f5e3f8dc59e0a98d5e957ad6ca64134cc54c2a6e4380e91ce64414c93e8212ee2724b646703ada4ff212576346b9dd3b272cf6adc35d58e1277ab185c8 SHA512 43e37005306b137162786f14c54690888845eeee582cedb9947c7cd6baf0c1cc83a51529af89fef48843960726cb04aba6cd0e41b2b2a92615543a303b864150
+DIST nanoc-4.12.16.tar.gz 350823 BLAKE2B 8196589290b5120b74bd2063e60f1fad14af98f7c8ffcef0a226d28ecb3f129ab04c913ad921e64c9551965c8fe1e26da1e0f41baa64a75caa372d6796c5084b SHA512 e04a562d87250286a9fbdc0381fdc64868f87f67d1ae9ce81f0e21c13496e168cfc4936c02b3cba87e8d647ab070670a208722fd53f4265eb3674b7ba20ccebd
EBUILD nanoc-4.12.14.ebuild 2563 BLAKE2B 9c7b514d74f630a479abdaa9ae5c3df170552ffe6fd2811391f34759ea7681ca19ee289258a896f3312195b9ff57894459a1121d8f3794e31bfe6988f9e3b57e SHA512 519944bb6360f64f7d1f69f97cdae18617bc9295a04c01804eeabf3c55a0e9be9ac03b659f0e129868a2d3d34c862084969bc38f3a843e7529d1da0fa038e079
EBUILD nanoc-4.12.15.ebuild 2567 BLAKE2B 0585e71f7eead36322832f3fe4f58fd8a5cfc5a42dff5cdc63f49fb4ccd6463388507829d0af498c61f5ce2eaaffbfae52aa6175a1def9094c212dcdb8abecb8 SHA512 118dee82de9ae2708d1c4657556cf34333cb30b1640f1291a3429b6add14e7fb5c9e1e668075e0fc2d732e05a2ff44bf8d7c3b6d71286edb3c1ed9c301283e8b
+EBUILD nanoc-4.12.16.ebuild 2756 BLAKE2B eb70d5e1555cdf4e74dfe13a5ff892f0b7a2c9ac0f80de7f09379b595ef7e5a0fda12641c045d214af2fe3cf97d87b28c6f2ed6f3f51e7ac6cc788c0316b8c55 SHA512 52dca5f71ddfb9d6be5fc857870160cbf87fcaa91dc3e5383b04a69bbf6635a3c6aaa0f18bae6c1c9dfb315dfae2ae3de9191fd222ba60250980f68a4fb73287
MISC metadata.xml 394 BLAKE2B 7b8c56a3dc98dbfc894dd1956390b9ea58fad15bd061590e776778af087d281e30fccdca9d5b227aad4b99ec0c370759ae501eafc58bf87cc56811cfb51b4647 SHA512 9e56f1314cf818d30c3153f5ada0ac75c70d460e9137de7146bc9af41ceebcd578de1336bebf141e41ba0969dbca332b8e06269dd61e91b7a33e207b2f6b4997
diff --git a/www-apps/nanoc/nanoc-4.12.16.ebuild b/www-apps/nanoc/nanoc-4.12.16.ebuild
new file mode 100644
index 000000000000..826e15fcb9cf
--- /dev/null
+++ b/www-apps/nanoc/nanoc-4.12.16.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="nanoc.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
+HOMEPAGE="https://nanoc.app/"
+SRC_URI="https://github.com/nanoc/nanoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="${IUSE} minimal"
+
+DEPEND+="test? ( app-text/asciidoc app-text/highlight )"
+
+RUBY_S="${P}/nanoc"
+
+ruby_add_rdepend "!minimal? (
+ dev-ruby/mime-types:*
+ dev-ruby/rack:*
+ www-servers/adsf
+)
+ >=dev-ruby/addressable-2.5
+ >=dev-ruby/colored-1.2:0
+ >=www-apps/nanoc-checking-1.0.2:1
+ ~www-apps/nanoc-cli-${PV}
+ ~www-apps/nanoc-core-${PV}
+ www-apps/nanoc-deploying:1
+ >=dev-ruby/parallel-1.12:1
+ >=dev-ruby/tty-command-0.8:0
+ >=dev-ruby/tty-which-0.4:0
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:3
+ dev-ruby/asciidoctor
+ dev-ruby/fuubar
+ dev-ruby/haml
+ dev-ruby/maruku
+ >=dev-ruby/mocha-0.13
+ dev-ruby/minitest
+ dev-ruby/mustache
+ dev-ruby/pry
+ dev-ruby/rdoc
+ >=dev-ruby/rouge-3.5.1:2
+ dev-ruby/rubypants
+ dev-ruby/systemu
+ dev-ruby/timecop
+ dev-ruby/vcr
+ dev-ruby/webmock
+ dev-ruby/yard
+)
+doc? (
+ dev-ruby/kramdown
+ dev-ruby/rdiscount
+ dev-ruby/yard
+)"
+
+all_ruby_prepare() {
+ # Avoid unneeded development dependencies
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/codecov/I s:^:#:' test/helper.rb ../common/spec/spec_helper_head_core.rb || die
+ sed -i -e '/coverall/I s:^:#:' \
+ -e '/rubocop/ s:^:#:' Rakefile || die
+ sed -i -e '2igem "psych", "~> 4.0"' test/helper.rb || die
+
+ echo "-r ./spec/spec_helper.rb" > .rspec || die
+
+ # Avoid basepath issues when generating gemspec
+ sed -i -e "s:require_relative ':require './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid tests requiring a network connection or make assumptions
+ # about the local network environment.
+ rm -f test/checking/checks/test_{css,html}.rb spec/nanoc/cli/commands/view_spec.rb || die
+
+ # Avoid tests for unpackaged dependencies
+ rm spec/nanoc/filters/less_spec.rb \
+ test/filters/test_{markaby,rainpress}.rb || die
+
+ # Avoid tests that are specific to haml 6.x which is currently not packaged
+ sed -i -e '/test_filter_\(with_proper_indentation\|error\)/askip "haml 6"' test/filters/test_haml.rb || die
+
+ # Avoid non-fatal failing tests due to specifics in the environment
+ sed -e '124askip "ordering issues"' -e '168askip "ordering issues"' \
+ -i spec/nanoc/data_sources/filesystem_spec.rb || die
+ sed -e '/def test_default_encoding/,/^ end/ s:^:#:' \
+ -i test/orig_cli/commands/test_create_site.rb || die
+}
+
+each_ruby_test() {
+ MT_NO_PLUGINS=true RUBYLIB="${S}/lib" ${RUBY} -S rake spec test_all || die
+}