summaryrefslogtreecommitdiff
path: root/www-apps/nanoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 11:51:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 11:51:15 +0100
commit713e25c0c3d1e5434ac60ec0549708ec2f744bb4 (patch)
tree9e9281ff07875c667fb3bf223166de68137f4635 /www-apps/nanoc
parent08b4047e14c989cfb931eff95973837f54ccc9e1 (diff)
gentoo auto-resync : 04:10:2023 - 11:51:15
Diffstat (limited to 'www-apps/nanoc')
-rw-r--r--www-apps/nanoc/Manifest2
-rw-r--r--www-apps/nanoc/nanoc-4.12.17.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/www-apps/nanoc/Manifest b/www-apps/nanoc/Manifest
index d3908c1b2ecc..7675daf46afe 100644
--- a/www-apps/nanoc/Manifest
+++ b/www-apps/nanoc/Manifest
@@ -1,3 +1,5 @@
DIST nanoc-4.12.16.tar.gz 350823 BLAKE2B 8196589290b5120b74bd2063e60f1fad14af98f7c8ffcef0a226d28ecb3f129ab04c913ad921e64c9551965c8fe1e26da1e0f41baa64a75caa372d6796c5084b SHA512 e04a562d87250286a9fbdc0381fdc64868f87f67d1ae9ce81f0e21c13496e168cfc4936c02b3cba87e8d647ab070670a208722fd53f4265eb3674b7ba20ccebd
+DIST nanoc-4.12.17.tar.gz 350964 BLAKE2B ca19c259eac8005f2612f61b902005d43196e3e01e8bb0c7a77f9f68bc27486ad6e6e9860420817a633b9a48973f7d98689046cbdb6fe4c185ae18583168d6d2 SHA512 d5a8d3711642f65078102be9317ac2b7db3635c5ff5616d2c05fd917e5cba76a8a21ceeb0a84565723d334f8d62cb55c8097eac07c9bc30f783916c8d312b8c1
EBUILD nanoc-4.12.16.ebuild 2899 BLAKE2B 8a3868ab6ea631c9668e053cc6b2a21feff9a87169334822a7fc1aeebe7046d82b671d2720531d1d994f1c93efc4dc8ddf281c9c3f1b8b5c15a8879bafa4686e SHA512 1e44edf9e5af7c5cfb83d9986eebf34f30957013f5009e6960c71df8c30a0715ac86245671944631037fe8a5c4c17ca58fc255bc227d5fab1a2c9fe9eca7aae6
+EBUILD nanoc-4.12.17.ebuild 2892 BLAKE2B 7ba0bb2bc726b040dff935971ec816d80e90fd9a870b373e922c81aeda631f2bddecf77b6dbf8c06959ea6019246b322a98d62f9f079e02bd35693771a19579b SHA512 e0a26308c772837fb62d5ea5f853da2d17379cb5ffc06ad9a5430e5e700c0a2b11a70939f231a4979384b5be90653a7c4cf63537c8b971ef4d0a9ae90e76b341
MISC metadata.xml 394 BLAKE2B 7b8c56a3dc98dbfc894dd1956390b9ea58fad15bd061590e776778af087d281e30fccdca9d5b227aad4b99ec0c370759ae501eafc58bf87cc56811cfb51b4647 SHA512 9e56f1314cf818d30c3153f5ada0ac75c70d460e9137de7146bc9af41ceebcd578de1336bebf141e41ba0969dbca332b8e06269dd61e91b7a33e207b2f6b4997
diff --git a/www-apps/nanoc/nanoc-4.12.17.ebuild b/www-apps/nanoc/nanoc-4.12.17.ebuild
new file mode 100644
index 000000000000..a4a5b6c23b41
--- /dev/null
+++ b/www-apps/nanoc/nanoc-4.12.17.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="nanoc.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
+HOMEPAGE="https://nanoc.app/"
+SRC_URI="https://github.com/nanoc/nanoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="${IUSE} minimal"
+
+DEPEND+="test? ( app-text/asciidoc app-text/highlight )"
+
+RUBY_S="${P}/nanoc"
+
+ruby_add_rdepend "!minimal? (
+ dev-ruby/mime-types:*
+ dev-ruby/rack:*
+ www-servers/adsf
+)
+ >=dev-ruby/addressable-2.5
+ >=dev-ruby/colored-1.2:0
+ >=www-apps/nanoc-checking-1.0.2:1
+ ~www-apps/nanoc-cli-${PV}
+ ~www-apps/nanoc-core-${PV}
+ www-apps/nanoc-deploying:1
+ >=dev-ruby/parallel-1.12:1
+ >=dev-ruby/tty-command-0.8:0
+ >=dev-ruby/tty-which-0.4:0
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:3
+ dev-ruby/asciidoctor
+ dev-ruby/fuubar
+ dev-ruby/haml
+ dev-ruby/maruku
+ >=dev-ruby/mocha-0.13
+ dev-ruby/minitest
+ dev-ruby/mustache
+ dev-ruby/pry
+ dev-ruby/rdoc
+ >=dev-ruby/rouge-3.5.1:2
+ dev-ruby/rubypants
+ dev-ruby/systemu
+ dev-ruby/timecop
+ dev-ruby/vcr
+ dev-ruby/webmock
+ dev-ruby/yard
+)
+doc? (
+ dev-ruby/kramdown
+ dev-ruby/rdiscount
+ dev-ruby/yard
+)"
+
+all_ruby_prepare() {
+ # Avoid unneeded development dependencies
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/codecov/I s:^:#:' test/helper.rb ../common/spec/spec_helper_head_core.rb || die
+ sed -i -e '/coverall/I s:^:#:' \
+ -e '/rubocop/ s:^:#:' Rakefile || die
+ sed -i -e '2igem "psych", "~> 4.0"' test/helper.rb || die
+
+ echo "-r ./spec/spec_helper.rb" > .rspec || die
+
+ # Avoid basepath issues when generating gemspec
+ sed -i -e "s:require_relative ':require './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid tests requiring a network connection or make assumptions
+ # about the local network environment.
+ rm -f test/checking/checks/test_{css,html}.rb spec/nanoc/cli/commands/view_spec.rb || die
+
+ # Avoid tests for unpackaged or obsolete dependencies
+ rm spec/nanoc/filters/less_spec.rb \
+ test/filters/test_{erubis,markaby,rainpress}.rb || die
+
+ # Avoid tests that are specific to haml 6.x which is currently not packaged
+ sed -i -e '/test_filter_\(with_proper_indentation\|error\)/askip "haml 6"' test/filters/test_haml.rb || die
+
+ # Avoid non-fatal failing tests due to specifics in the environment
+ sed -e '124askip "ordering issues"' -e '168askip "ordering issues"' \
+ -i spec/nanoc/data_sources/filesystem_spec.rb || die
+ sed -e '/def test_default_encoding/,/^ end/ s:^:#:' \
+ -i test/orig_cli/commands/test_create_site.rb || die
+
+ # Fix deprecated minitest constant
+ sed -i -e 's/MiniTest/Minitest/' test/rule_dsl/test_rules_collection.rb || die
+}
+
+each_ruby_test() {
+ MT_NO_PLUGINS=true RUBYLIB="${S}/lib" ${RUBY} -S rake spec test_all || die
+}