summaryrefslogtreecommitdiff
path: root/www-apps/nanoc-cli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /www-apps/nanoc-cli
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'www-apps/nanoc-cli')
-rw-r--r--www-apps/nanoc-cli/Manifest3
-rw-r--r--www-apps/nanoc-cli/metadata.xml9
-rw-r--r--www-apps/nanoc-cli/nanoc-cli-4.12.2.ebuild70
3 files changed, 82 insertions, 0 deletions
diff --git a/www-apps/nanoc-cli/Manifest b/www-apps/nanoc-cli/Manifest
new file mode 100644
index 000000000000..3cfb7621a2b1
--- /dev/null
+++ b/www-apps/nanoc-cli/Manifest
@@ -0,0 +1,3 @@
+DIST nanoc-4.12.2.tar.gz 331400 BLAKE2B f7a22b05a4805f15a8e93601ae21bffdc19fe17c6550378465d85e63c498c5773c1dcd49d685b7d4367488300394c2f5bf9e6a6dc6aea589617a27fe1bd6ed4a SHA512 3fe574c061d8d0dd034137800c88a34844d246e6ab9a7816aadb03cd2c43b5fe6d614f42e6b41bcd4df98be551edc69e35ca992f2d5ee8158f9c7eb3c7635750
+EBUILD nanoc-cli-4.12.2.ebuild 2029 BLAKE2B fda269aacc8243a30aebe529c8b0d8cadb2db6f06408c47dd9cfe11714cbebf11ba83d646f5d4319776636add2c24dec403864ae4a49b990bc5a82aecd8b6d12 SHA512 ca60a110fa12c27a43ff232785db3a94c9121b6a86b5e6508f06ffcf3f96fffe8db077030b691e0e238099c838acbe1a049042b04ab97e5a81d98fbf2e6fc33c
+MISC metadata.xml 317 BLAKE2B c6af48dcdb56be1e50ef78910bc5150112d2914bbd13b576883eeeecdcc2a47f6360ffcf7a83432266bc737891527f4f1cacaf90b62e7b38d75a0c74c87bb0d8 SHA512 5394c6280515d4728d6b30f6eff872dd1d3dc283fe125aa8b5bc7f1206d967b74864bd144c6b2623ea63db19f78b5a94d13261464b35b4056cf92cccf374db1e
diff --git a/www-apps/nanoc-cli/metadata.xml b/www-apps/nanoc-cli/metadata.xml
new file mode 100644
index 000000000000..9abf9c6b8ec2
--- /dev/null
+++ b/www-apps/nanoc-cli/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person"><email>graaff@gentoo.org</email></maintainer>
+<maintainer type="project">
+<email>ruby@gentoo.org</email>
+<name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/www-apps/nanoc-cli/nanoc-cli-4.12.2.ebuild b/www-apps/nanoc-cli/nanoc-cli-4.12.2.ebuild
new file mode 100644
index 000000000000..77ad8311c5fe
--- /dev/null
+++ b/www-apps/nanoc-cli/nanoc-cli-4.12.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
+HOMEPAGE="https://nanoc.ws/"
+SRC_URI="https://github.com/nanoc/nanoc/archive/${PV}.tar.gz -> nanoc-${PV}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="${IUSE} minimal"
+
+RUBY_S="nanoc-${PV}/nanoc-cli"
+
+ruby_add_rdepend "
+ >=dev-ruby/cri-2.15:0
+ >=dev-ruby/diff-lcs-1.3:0
+ ~www-apps/nanoc-core-${PV}
+ >=dev-ruby/zeitwerk-2.1:2
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/rspec:3
+ dev-ruby/rspec-its
+ dev-ruby/fuubar
+ dev-ruby/minitest
+ dev-ruby/timecop
+ dev-ruby/tty-command
+ dev-ruby/yard
+ www-apps/nanoc-spec
+)
+"
+
+all_ruby_prepare() {
+ # Avoid unneeded development dependencies
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/codecov/I s:^:#:' ../common/spec/spec_helper_head_core.rb || die
+ sed -i -e '/coverall/I s:^:#:' \
+ -e '/rubocop/ s:^:#:' Rakefile || die
+ sed -i -e '2i require "tmpdir"; require "pathname"' spec/spec_helper.rb || die
+
+ echo "-r ./spec/spec_helper.rb" > .rspec || die
+
+ sed -i -e "s:require_relative 'lib:require './lib:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid error handler specs failing due to different (rubygems?)
+ # output, meta_spec is affected by this.
+ rm -f spec/nanoc/cli/error_handler_spec.rb spec/meta_spec.rb || die
+
+ # Avoid test requiring a network interface
+ sed -i -e '/does not listen on non-local interfaces/askip "Needs network"' spec/nanoc/cli/commands/view_spec.rb || die
+
+ # Avoid tests requiring an additional dependency on nanoc-live
+ sed -i -e '/--live-reload is given/askip "Unpackaged nanoc-live"' spec/nanoc/cli/commands/view_spec.rb || die
+ sed -i -e '/watches with --watch/askip "Unpackaged nanoc-live"' spec/nanoc/cli/commands/compile_spec.rb || die
+}
+
+each_ruby_test() {
+ RUBYLIB="${S}/lib" ${RUBY} -S rake spec || die
+}