summaryrefslogtreecommitdiff
path: root/www-apps/nanoc-cli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /www-apps/nanoc-cli
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'www-apps/nanoc-cli')
-rw-r--r--www-apps/nanoc-cli/Manifest2
-rw-r--r--www-apps/nanoc-cli/nanoc-cli-4.12.3.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/nanoc-cli/Manifest b/www-apps/nanoc-cli/Manifest
index 8ec2a04d1c4f..63e48a0d2775 100644
--- a/www-apps/nanoc-cli/Manifest
+++ b/www-apps/nanoc-cli/Manifest
@@ -1,3 +1,5 @@
DIST nanoc-4.12.2.tar.gz 331400 BLAKE2B f7a22b05a4805f15a8e93601ae21bffdc19fe17c6550378465d85e63c498c5773c1dcd49d685b7d4367488300394c2f5bf9e6a6dc6aea589617a27fe1bd6ed4a SHA512 3fe574c061d8d0dd034137800c88a34844d246e6ab9a7816aadb03cd2c43b5fe6d614f42e6b41bcd4df98be551edc69e35ca992f2d5ee8158f9c7eb3c7635750
+DIST nanoc-4.12.3.tar.gz 332692 BLAKE2B 8ae106366c66500ed06be841382bc1cc52c68ebc7ebec47a3f9dab278c7e17f886d0ce18c81ff73a83ec672353503155b447dfff5ba46f16bc2bfe891bb028a5 SHA512 737ce993c529643440d74e5072e2d63c2ce970d4d7637e7f225a79d3ac38907ced84928340d7bf5f11bcd02188b5cb1df0d4b03a8e000878ed924ab943db33a2
EBUILD nanoc-cli-4.12.2.ebuild 2029 BLAKE2B fda269aacc8243a30aebe529c8b0d8cadb2db6f06408c47dd9cfe11714cbebf11ba83d646f5d4319776636add2c24dec403864ae4a49b990bc5a82aecd8b6d12 SHA512 ca60a110fa12c27a43ff232785db3a94c9121b6a86b5e6508f06ffcf3f96fffe8db077030b691e0e238099c838acbe1a049042b04ab97e5a81d98fbf2e6fc33c
+EBUILD nanoc-cli-4.12.3.ebuild 2029 BLAKE2B b3c1989d490cc7e89cc4135de99456275af544914c6b0a8a85ffbea7c51ddd50a3172eb510eeaa8c7385f6b67d8cf2fb011136123a7663b2c6cd3bbf82fc79be SHA512 255ad38897ba6f43e492bab3735ac0e14bd2be29154f30acb43ac6c5dd54041ba6dd5062d72cf596496b97f1e485c3ff0307e0887b7545375ca152ddc62bc16b
MISC metadata.xml 318 BLAKE2B 62f33f86cd5bcb675e9ac02fef339514b88000be788a7037416bf6594e3f27bb07c5f7b49adbc39aa6aae4fdc7f076ebbb7f0fe897807a8e4a0b2252d5238546 SHA512 1098cd34add4d21c0c10aa42a539cec14c56b1835701b73346a57cac7ea3964b776b95d76cdffd6300577682e3a29976d9b65a0e2b8f984ee1bfb7601f2d7ef2
diff --git a/www-apps/nanoc-cli/nanoc-cli-4.12.3.ebuild b/www-apps/nanoc-cli/nanoc-cli-4.12.3.ebuild
new file mode 100644
index 000000000000..ea81772ad9e4
--- /dev/null
+++ b/www-apps/nanoc-cli/nanoc-cli-4.12.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
+HOMEPAGE="https://nanoc.ws/"
+SRC_URI="https://github.com/nanoc/nanoc/archive/${PV}.tar.gz -> nanoc-${PV}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="${IUSE} minimal"
+
+RUBY_S="nanoc-${PV}/nanoc-cli"
+
+ruby_add_rdepend "
+ >=dev-ruby/cri-2.15:0
+ >=dev-ruby/diff-lcs-1.3:0
+ ~www-apps/nanoc-core-${PV}
+ >=dev-ruby/zeitwerk-2.1:2
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/rspec:3
+ dev-ruby/rspec-its
+ dev-ruby/fuubar
+ dev-ruby/minitest
+ dev-ruby/timecop
+ dev-ruby/tty-command
+ dev-ruby/yard
+ www-apps/nanoc-spec
+)
+"
+
+all_ruby_prepare() {
+ # Avoid unneeded development dependencies
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/codecov/I s:^:#:' ../common/spec/spec_helper_head_core.rb || die
+ sed -i -e '/coverall/I s:^:#:' \
+ -e '/rubocop/ s:^:#:' Rakefile || die
+ sed -i -e '2i require "tmpdir"; require "pathname"' spec/spec_helper.rb || die
+
+ echo "-r ./spec/spec_helper.rb" > .rspec || die
+
+ sed -i -e "s:require_relative 'lib:require './lib:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid error handler specs failing due to different (rubygems?)
+ # output, meta_spec is affected by this.
+ rm -f spec/nanoc/cli/error_handler_spec.rb spec/meta_spec.rb || die
+
+ # Avoid test requiring a network interface
+ sed -i -e '/does not listen on non-local interfaces/askip "Needs network"' spec/nanoc/cli/commands/view_spec.rb || die
+
+ # Avoid tests requiring an additional dependency on nanoc-live
+ sed -i -e '/--live-reload is given/askip "Unpackaged nanoc-live"' spec/nanoc/cli/commands/view_spec.rb || die
+ sed -i -e '/watches with --watch/askip "Unpackaged nanoc-live"' spec/nanoc/cli/commands/compile_spec.rb || die
+}
+
+each_ruby_test() {
+ RUBYLIB="${S}/lib" ${RUBY} -S rake spec || die
+}