summaryrefslogtreecommitdiff
path: root/www-apps/nanoc-checking/nanoc-checking-1.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-20 12:05:24 +0100
commitda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (patch)
tree0a7a1b7b3ad60c3b21c697e75908b256fc9ed6b1 /www-apps/nanoc-checking/nanoc-checking-1.0.4.ebuild
parentb6cfc0c19effe2d9f7b8ab303cd00636f16da253 (diff)
gentoo auto-resync : 20:04:2024 - 12:05:23
Diffstat (limited to 'www-apps/nanoc-checking/nanoc-checking-1.0.4.ebuild')
-rw-r--r--www-apps/nanoc-checking/nanoc-checking-1.0.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/www-apps/nanoc-checking/nanoc-checking-1.0.4.ebuild b/www-apps/nanoc-checking/nanoc-checking-1.0.4.ebuild
new file mode 100644
index 000000000000..1c01dd15800d
--- /dev/null
+++ b/www-apps/nanoc-checking/nanoc-checking-1.0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+# Upstream has specs but they are not available in the gem and the
+# repository upstream is not tagged for this.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides checking functionality for Nanoc"
+HOMEPAGE="https://nanoc.app/"
+LICENSE="MIT"
+
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~riscv"
+
+ruby_add_rdepend "
+ >=www-apps/nanoc-cli-4.12.5:0
+ >=www-apps/nanoc-core-4.12.5:0
+"