summaryrefslogtreecommitdiff
path: root/www-apps/mirmon/mirmon-2.11-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /www-apps/mirmon/mirmon-2.11-r2.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'www-apps/mirmon/mirmon-2.11-r2.ebuild')
-rw-r--r--www-apps/mirmon/mirmon-2.11-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/www-apps/mirmon/mirmon-2.11-r2.ebuild b/www-apps/mirmon/mirmon-2.11-r2.ebuild
new file mode 100644
index 000000000000..0d6ce1561b0e
--- /dev/null
+++ b/www-apps/mirmon/mirmon-2.11-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp eutils
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="Simple webapp to monitor the status of mirrors"
+# The author has passed away: https://www.apache.org/memorials/henk_penning.html
+HOMEPAGE="http://www2.projects.science.uu.nl/csg/mirmon/mirmon.html"
+SRC_URI="https://deb.debian.org/debian/pool/main/m/${PN}/${PN}_${PV}.orig.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.8.5-r2:0"
+RDEPEND="${DEPEND}
+ dev-perl/File-Tempdir
+ dev-perl/Socket6"
+
+PATCHES=(
+ "${FILESDIR}/2.11-Add-ipv6-monitor-support-to-mirmon.patch"
+ "${FILESDIR}/2.11-Fix-options.patch"
+)
+
+src_install() {
+ # Don't install empty dirs
+ MY_CGIBINDIR=""
+ MY_ICONSDIR=""
+ MY_ERRORSDIR=""
+
+ webapp_src_preinst
+
+ for file in mirmon.html mirmon.txt; do
+ dodoc ${file}
+ rm -f ${file}
+ done
+ cp -R icons "${D}"/${MY_HTDOCSDIR}
+ rm -rf icons
+ cp -R . "${D}"/${MY_HOSTROOTDIR}
+
+ webapp_src_install
+}