summaryrefslogtreecommitdiff
path: root/www-apps/icingaweb2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /www-apps/icingaweb2
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'www-apps/icingaweb2')
-rw-r--r--www-apps/icingaweb2/Manifest2
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.10.0.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 27bb23593b82..0fa5f55a7778 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,4 +1,6 @@
+DIST icingaweb2-2.10.0.tar.gz 11491028 BLAKE2B bee48e59ec7d0a564e7056986a84fda9639e61ed82ea65d35da310916e7058837fc146ee06f2c044748f72424198dc42f75b32de4b6ab39f673e2a9bbaf46966 SHA512 e26a4382970ece503c18ac9f93bb9e7ac24fd827dd84fd04352aeeff796ab58dac747840c6153cea5711d548603f219ba32aeffe76d87359ea72f2d3a598468b
DIST icingaweb2-2.9.6.tar.gz 12313930 BLAKE2B 696b882fc1bb0fd0452dca9e8b13b336181d953c05ab43c1db38073aa817496ca431dfb0f68adab0a6eae7c2238878dda98a57d8b69b2bc19ed94f1afbd26fe5 SHA512 507ce9ab8e31f0afc19de173c56e9ce2986c9c2e945ff3516e005b49a69993ccb00ec53d4c53bc0beee865cebc533b4b91b0d7707abf9d30d4cb76b7545fb6a4
+EBUILD icingaweb2-2.10.0.ebuild 2531 BLAKE2B 53f83accfd9a604c1c9ca85371379b8d6fda8df18dc0d0459a93549d3504fdd37cba3ca23deaeb7e28165fa56974d126bcc227a4f7459c4b92d885b4d2432dd1 SHA512 7fe3b7cb49979ce01fb96be9d7a887c2c540b521aac120cbc3437e371dedad178d8a9874574885845dce17642aedc1f9a7799164e5495c92aad7e5f29b6a7711
EBUILD icingaweb2-2.9.6.ebuild 2529 BLAKE2B 0bff09ed4258d2674a3e1ec780e6b7aa0d87cbcba5771af2ea2aae5fc10381f73f9b9434f09e3730c07d3ddcfdd2809f5b33273dd169f0c7ce808694d772c2ad SHA512 b9a0b279ac1606370ce0b238638c9a328990ffa977a50a21c61ad25b46d800e689b18c5eb8989e83a94a75a0d5afff3548989565a62bb3b6ab1551a8b17c2171
EBUILD icingaweb2-9999.ebuild 2531 BLAKE2B 3f5f8503d3157d485a7d20ee78f92d6cd1fb8948a7ae314a796e79c0379ab9b96fb7f57589fac9ad653cfad6eae4dfa04b67ec1064cad3e9bdd5915c8bebaaeb SHA512 564852d6c04c14e98870a205a72c1ab5d2c4e712b9a71bd84112fce7d44d5652835213375ef7e684dc752be05869cd91f6f3d32168bcdbf2c37c2b44ccbcdda8
MISC metadata.xml 444 BLAKE2B bf24467286f442770ed78cb298cd0fc1d37786b06e85bbc4b20a8c750764e7a831828ebc9b7872772f0a286b12cb67491cb1f84f189cf00e2ec59a6b921e760f SHA512 55e57997695e09ad9cc8448030e8470a0e39a1cbc610f70e29c2a68a4f287e54cb816b0cd1ceec611112849ba97225a60560b67368fb3a6ed68a73a728d61d83
diff --git a/www-apps/icingaweb2/icingaweb2-2.10.0.ebuild b/www-apps/icingaweb2/icingaweb2-2.10.0.ebuild
new file mode 100644
index 000000000000..1c12f98d4b39
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.10.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit depend.apache multilib
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
+REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2-server? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )
+ || (
+ dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:8.0[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ dev-libs/icinga-php-library
+ dev-libs/icinga-php-thirdparty
+ acct-group/icingacmd
+ acct-group/icingaweb2"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+ fowners root:icingaweb2 "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}