summaryrefslogtreecommitdiff
path: root/www-apps/grafana-bin/grafana-bin-8.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /www-apps/grafana-bin/grafana-bin-8.0.6.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'www-apps/grafana-bin/grafana-bin-8.0.6.ebuild')
-rw-r--r--www-apps/grafana-bin/grafana-bin-8.0.6.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/www-apps/grafana-bin/grafana-bin-8.0.6.ebuild b/www-apps/grafana-bin/grafana-bin-8.0.6.ebuild
deleted file mode 100644
index 937332ec5f09..000000000000
--- a/www-apps/grafana-bin/grafana-bin-8.0.6.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit systemd
-
-MY_PN=${PN/-bin/}
-MY_PV=${PV/_beta/-beta}
-S=${WORKDIR}/${MY_PN}-${MY_PV}
-
-DESCRIPTION="Gorgeous metric viz, dashboards & editors for Graphite, InfluxDB & OpenTSDB"
-HOMEPAGE="https://grafana.org"
-SRC_URI="https://dl.grafana.com/oss/release/grafana-${PV}.linux-amd64.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND="acct-group/grafana
- acct-user/grafana"
-RDEPEND="${DEPEND}
- media-libs/fontconfig"
-
-QA_PREBUILT="usr/bin/grafana-*"
-QA_PRESTRIPPED=${QA_PREBUILT}
-
-src_install() {
- keepdir /etc/grafana
- insinto /etc/grafana
- newins "${S}"/conf/sample.ini grafana.ini
- rm "${S}"/conf/sample.ini || die
-
- # Frontend assets
- insinto /usr/share/${MY_PN}
- doins -r public conf
-
- dobin bin/grafana-cli
- dobin bin/grafana-server
-
- newconfd "${FILESDIR}"/grafana-r1.confd grafana
- newinitd "${FILESDIR}"/grafana.initd grafana
- systemd_newunit "${FILESDIR}"/grafana.service grafana.service
-
- keepdir /var/{lib,log}/grafana
- keepdir /var/lib/grafana/{dashboards,plugins}
- fowners grafana:grafana /var/{lib,log}/grafana
- fowners grafana:grafana /var/lib/grafana/{dashboards,plugins}
- fperms 0750 /var/{lib,log}/grafana
- fperms 0750 /var/lib/grafana/{dashboards,plugins}
-}
-
-postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- # This is a new installation
-
- elog "${PN} has built-in log rotation. Please see [log.file] section of"
- elog "/etc/grafana/grafana.ini for related settings."
- elog
- elog "You may add your own custom configuration for app-admin/logrotate if you"
- elog "wish to use external rotation of logs. In this case, you also need to make"
- elog "sure the built-in rotation is turned off."
- fi
-}