summaryrefslogtreecommitdiff
path: root/www-apps/gitea/gitea-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /www-apps/gitea/gitea-9999.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'www-apps/gitea/gitea-9999.ebuild')
-rw-r--r--www-apps/gitea/gitea-9999.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index 9e8bcf9c6054..0d1559ca4a39 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,7 @@ else
SCM="git-r3"
fi
-inherit golang-base tmpfiles systemd ${SCM}
+inherit fcaps golang-base tmpfiles systemd ${SCM}
unset SCM
EGO_PN="code.gitea.io/gitea"
@@ -18,7 +18,7 @@ DESCRIPTION="A painless self-hosted Git service"
HOMEPAGE="https://gitea.io"
if [[ ${PV} != 9999* ]] ; then
- SRC_URI="https://github.com/go-gitea/gitea/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64"
else
EGIT_REPO_URI="https://github.com/go-gitea/gitea"
@@ -30,7 +30,8 @@ LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
SLOT="0"
IUSE="+acct pam sqlite"
-BDEPEND="dev-lang/go"
+BDEPEND="dev-lang/go
+ >=net-libs/nodejs-10[npm]"
DEPEND="pam? ( sys-libs/pam )"
RDEPEND="${DEPEND}
acct? (
@@ -40,8 +41,11 @@ RDEPEND="${DEPEND}
dev-vcs/git"
DOCS=( custom/conf/app.ini.sample CONTRIBUTING.md README.md )
+FILECAPS=( cap_net_bind_service+ep usr/bin/gitea )
S="${WORKDIR}/${P}/src/${EGO_PN}"
+PATCHES=( "${FILESDIR}/gitea-logflags.patch" )
+
gitea_make() {
local gitea_tags=(
bindata
@@ -60,7 +64,7 @@ gitea_make() {
)
[[ ${PV} != 9999* ]] && makeenv+=("DRONE_TAG=${PV}")
- env "${makeenv[@]}" emake "$@"
+ env "${makeenv[@]}" emake -j1 "$@"
}
src_prepare() {
@@ -85,7 +89,8 @@ src_prepare() {
sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.ini.sample || die
fi
- gitea_make generate
+ # Remove already build assets (like frontend part)
+ gitea_make clean-all
}
src_compile() {