summaryrefslogtreecommitdiff
path: root/www-apps/gitea/gitea-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /www-apps/gitea/gitea-9999.ebuild
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'www-apps/gitea/gitea-9999.ebuild')
-rw-r--r--www-apps/gitea/gitea-9999.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index 672af6461ca6..d6f5cfcf5a8e 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -33,17 +33,19 @@ RDEPEND="${COMMON_DEPEND}
dev-vcs/git"
DOCS=(
- custom/conf/app.ini.sample CONTRIBUTING.md README.md
+ custom/conf/app.example.ini CONTRIBUTING.md README.md
)
FILECAPS=(
cap_net_bind_service+ep usr/bin/gitea
)
+RESTRICT="test"
+QA_PRESTRIPPED="usr/bin/gitea"
+
src_prepare() {
default
local sedcmds=(
- -e "s#^RUN_MODE = dev#RUN_MODE = prod#"
-e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
-e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
-e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
@@ -52,13 +54,11 @@ src_prepare() {
-e "s#^LEVEL = Trace#LEVEL = Info#"
-e "s#^LOG_SQL = true#LOG_SQL = false#"
-e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
- -e "s#^APP_ID =#;APP_ID =#"
- -e "s#^TRUSTED_FACETS =#;TRUSTED_FACETS =#"
)
- sed -i "${sedcmds[@]}" custom/conf/app.ini.sample || die
+ sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
if use sqlite ; then
- sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.ini.sample || die
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
fi
einfo "Remove tests which are known to fail with network-sandbox enabled."
@@ -104,7 +104,7 @@ src_install() {
systemd_newunit "${FILESDIR}"/gitea.service-r2 gitea.service
insinto /etc/gitea
- newins custom/conf/app.ini.sample app.ini
+ newins custom/conf/app.example.ini app.ini
if use acct ; then
fowners root:git /etc/gitea/{,app.ini}
fperms g+w,o-rwx /etc/gitea/{,app.ini}
@@ -114,3 +114,9 @@ src_install() {
keepdir /var/log/gitea
fi
}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ go-module_pkg_postinst
+ tmpfiles_process gitea.conf
+}