summaryrefslogtreecommitdiff
path: root/www-apps/gitea/gitea-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /www-apps/gitea/gitea-9999.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'www-apps/gitea/gitea-9999.ebuild')
-rw-r--r--www-apps/gitea/gitea-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index a5eec77f6034..4da3155a2589 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -2,11 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit fcaps go-module tmpfiles systemd
MY_PV="${PV/_rc/-rc}"
DESCRIPTION="A painless self-hosted Git service"
-HOMEPAGE="https://gitea.io"
+HOMEPAGE="https://gitea.io https://github.com/go-gitea/gitea"
if [[ ${PV} != 9999* ]] ; then
SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${MY_PV}/gitea-src-${MY_PV}.tar.gz -> ${P}.tar.gz"
@@ -22,13 +23,12 @@ LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
SLOT="0"
IUSE="+acct pam sqlite"
-COMMON_DEPEND="
+DEPEND="
acct? (
acct-group/git
acct-user/git[gitea] )
pam? ( sys-libs/pam )"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="${DEPEND}
dev-vcs/git"
DOCS=(