summaryrefslogtreecommitdiff
path: root/www-apps/drupal/drupal-7.80.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /www-apps/drupal/drupal-7.80.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'www-apps/drupal/drupal-7.80.ebuild')
-rw-r--r--www-apps/drupal/drupal-7.80.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/www-apps/drupal/drupal-7.80.ebuild b/www-apps/drupal/drupal-7.80.ebuild
deleted file mode 100644
index 4e6998d1e429..000000000000
--- a/www-apps/drupal/drupal-7.80.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit webapp
-
-MY_PV=${PV:0:3}.0
-
-DESCRIPTION="PHP-based open-source platform and content management system"
-HOMEPAGE="https://www.drupal.org/"
-SRC_URI="https://ftp.drupal.org/files/projects/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="+mysql postgres sqlite +uploadprogress"
-
-RDEPEND="
- dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
- virtual/httpd-php
- uploadprogress? ( dev-php/pecl-uploadprogress )
-"
-
-need_httpd_cgi
-
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-src_install() {
- webapp_src_preinst
-
- local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
- dodoc ${docs}
- rm -f ${docs} INSTALL COPYRIGHT.txt || die
-
- cp sites/default/{default.settings.php,settings.php} || die
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- dodir "${MY_HTDOCSDIR}"/files
- webapp_serverowned "${MY_HTDOCSDIR}"/files
- webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
- webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
-
- webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
- webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-
- webapp_src_install
-}
-
-pkg_postinst() {
- echo
- ewarn "SECURITY NOTICE"
- ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
- ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
- echo
-}