summaryrefslogtreecommitdiff
path: root/www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-08 14:01:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-08 14:01:34 +0100
commit4645b6f17f0da81e9fe84081fb126a37102ba153 (patch)
treee6c48cf3db2213af38cf528a5364fffd5c74c6d6 /www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild
parentebce8994fe3cc4ca9fbc96ca837cb4c4e98adcbd (diff)
gentoo resync : 08.05.2018
Diffstat (limited to 'www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild')
-rw-r--r--www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild b/www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild
index 392f1647e1c7..0dc2dac982cd 100644
--- a/www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild
+++ b/www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild
@@ -3,18 +3,22 @@
EAPI="5"
+inherit autotools
+
if [[ ${PV} = *9999* ]]; then
WANT_AUTOMAKE="1.10"
- inherit autotools mercurial
- EHG_REPO_URI="http://hg.rafaelmartins.eng.br/cgisysinfo/"
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}"
KEYWORDS=""
+ DOCS=( "README.md" "AUTHORS" "NEWS" )
else
- SRC_URI="http://distfiles.rafaelmartins.eng.br/${PN}/${P}.tar.bz2"
+ SRC_URI="https://github.com/rafaelmartins/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
+ DOCS=( "README" "AUTHORS" "NEWS" )
fi
DESCRIPTION="A small cgi utility to show basic system information"
-HOMEPAGE="http://projects.rafaelmartins.eng.br/cgisysinfo"
+HOMEPAGE="https://github.com/rafaelmartins/cgisysinfo"
LICENSE="GPL-2"
SLOT="0"
@@ -23,10 +27,8 @@ IUSE="fastcgi"
DEPEND="fastcgi? ( dev-libs/fcgi )"
RDEPEND="${DEPEND}"
-DOCS="README AUTHORS NEWS"
-
src_prepare() {
- [[ ${PV} = *9999* ]] && eautoreconf
+ eautoreconf
}
src_configure() {