summaryrefslogtreecommitdiff
path: root/www-apps/Apache-Gallery
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apps/Apache-Gallery
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apps/Apache-Gallery')
-rw-r--r--www-apps/Apache-Gallery/Apache-Gallery-1.0_rc3-r1.ebuild60
-rw-r--r--www-apps/Apache-Gallery/Manifest7
-rw-r--r--www-apps/Apache-Gallery/files/76_apache2-gallery.conf40
-rw-r--r--www-apps/Apache-Gallery/files/postinstall-en.txt2
-rw-r--r--www-apps/Apache-Gallery/metadata.xml8
5 files changed, 117 insertions, 0 deletions
diff --git a/www-apps/Apache-Gallery/Apache-Gallery-1.0_rc3-r1.ebuild b/www-apps/Apache-Gallery/Apache-Gallery-1.0_rc3-r1.ebuild
new file mode 100644
index 000000000000..99bffd1ecaf4
--- /dev/null
+++ b/www-apps/Apache-Gallery/Apache-Gallery-1.0_rc3-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit depend.apache perl-module webapp
+
+MY_P=${P/_rc/RC}
+
+DESCRIPTION="Apache gallery for mod_perl"
+SRC_URI="http://apachegallery.dk/download/${MY_P}.tar.gz"
+HOMEPAGE="http://apachegallery.dk/"
+
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+WEBAPP_MANUAL_SLOT="yes"
+SLOT="0"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="${DEPEND}
+ =dev-lang/perl-5*
+ =www-apache/libapreq2-2*[perl]
+ >=media-libs/imlib2-1.0.6-r1
+ dev-perl/URI
+ >=dev-perl/Image-Info-1.40.0
+ >=dev-perl/Image-Size-2.990.0
+ dev-perl/Text-Template
+ >=dev-perl/CGI-3.08
+ dev-perl/Image-Imlib2
+"
+
+need_apache2
+
+src_install() {
+ perl-module_src_install
+ webapp_src_preinst
+
+ dodoc Changes INSTALL README TODO UPGRADE || die
+
+ insinto "${MY_ICONSDIR}"/gallery
+ doins htdocs/*.png
+
+ dodir "${MY_HOSTROOTDIR}"/${PN}/templates/default
+ dodir "${MY_HOSTROOTDIR}"/${PN}/templates/new
+
+ insinto "${MY_HOSTROOTDIR}"/${PN}/templates/default
+ doins templates/default/*
+
+ insinto "${MY_HOSTROOTDIR}"/${PN}/templates/new
+ doins templates/new/*
+
+ insinto "${APACHE_VHOSTS_CONFDIR}"
+ doins "${FILESDIR}"/76_apache2-gallery.conf
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/Apache-Gallery/Manifest b/www-apps/Apache-Gallery/Manifest
new file mode 100644
index 000000000000..a422b884d308
--- /dev/null
+++ b/www-apps/Apache-Gallery/Manifest
@@ -0,0 +1,7 @@
+AUX 76_apache2-gallery.conf 1442 SHA256 f6c0099476bdec5f495e7de4cbdff088ed0ce01ef8993ba657a463cdb365a7ab SHA512 fb9f2c7c8d3fc38501311cdc76141326fa96ff8f9a33e8b9e9efc8ee7208fcb6168981ded323cc7851ea30f1b9ff1db3541cdd1c71a4f2c99ce9cb280efc7900 WHIRLPOOL dd0d7d7c966a56040f6c61e5d2664788c171cf053ce0bf415655c91e56470036d434aa78a0574d5f4f4d12e3840a1ef81dbe5212d6513ed7d52f449ba53769af
+AUX postinstall-en.txt 90 SHA256 d46f8343e97402107390a651ee3e31adfcd9034d9f88d4ae5dcc83061851dfc1 SHA512 3cecb9f07c69b20805a64e3184e3aea8e934d7ac7e42d53884268f7614780f25be524dafb25ae0d4ce1f9b1aed1fe88dfa27d98827182888fc36eb8301be0968 WHIRLPOOL a6cf9c0169db55b59b1654c04002bffb26b8de6547975822513193f9793b13696ac5d75e1f4396837bd840aaa2a08bb6c02215643038980b812c66eee5d599b6
+DIST Apache-Gallery-1.0RC3.tar.gz 83891 SHA256 9a7ab7566d811bb21dd27bc9a27cdcfb2c7a96c01727ad9a04313fc80e68e1f7 SHA512 00b95d3aed844c32a5d2cf8dc736e43a017dacfad5b73c65db4e35c2bb5fa05b7ae29af8ce5bc307e7b3539d94672031e7f1abaf150f15071272b0c1fa442062 WHIRLPOOL a8ec4ab53adc6264dd86d250967702681af8302653b15e284bf64b1a1f4951fdeb46fd5242e6b9599726064543d9dbec5906edb8ed61333faa26cccd104b50e3
+EBUILD Apache-Gallery-1.0_rc3-r1.ebuild 1279 SHA256 0f4f461fb0628424193eb2b89b935f68691ae42f34ac840abf26fd594d4d6fe4 SHA512 f5ac4de17f5dcd36439159fb2b58216b25548ef27c1ede0895e517283441ee38e1bad1d6f1d42746efc6d4c9ea9a41afddd9102cfe66f506885047d6875cfe2b WHIRLPOOL 8bb42b960d11e794586461546db6d80d0fcc8933348e3f46e6d36804c152c64d4e5072f6aaa76f760d9d774c5aac1b2df369740dd73ebb1dfa53fe948b1112ef
+MISC ChangeLog 3377 SHA256 8037633a1011240c49b22df545913f26c4356d0b3797ec278a416feacb352f4b SHA512 a7aad3cbe1afcb96e4d2155d666e9c9c860fc379d6dc1c879b9c75fe97efb92b5ae649491e0fe2d6743a0fae1949b3033e32b2e00cb4068cd418e2d9e8267b98 WHIRLPOOL e0b6aaca8a758ef224df9db15716809db910f9ad0808b8939b7a7c937094a3d52eeed27d60c01d4920c3f8caae07576260584148a44e73532e0cbc671c98145b
+MISC ChangeLog-2015 6783 SHA256 21e1456169d2cafeb97f31eeeb530d6c2efdb678b902c0ca5e75c5f12d752fd3 SHA512 6688cc9c453c4d03123cbae8f97a35f18a2f916a1a0f43bff67851e266ac4a29d7d81b80a681c3477518f2b082e2acc15be1beb22e293d6f6cefda9969463d98 WHIRLPOOL 64b659db8af2ee6423f473cc848cc98beda6bcb1ee5e941c0b450cfa6e9f157cc541e9284cdaf0945acc9ff046bab3eedec1d9aad998efe092834bd3ad6a227e
+MISC metadata.xml 250 SHA256 d9fcac0092614f226b371c1819fe3a264758bfd9fedc2874c35a7b3dd6d77291 SHA512 8a7934e6db1aa1e0aba026a0438fb291819be69c134d54bb3af0638facc3e0a47bc30557c944bfaf5adbdd1dbdcbc96dec88d69ab809b1758e5701ff38fc6282 WHIRLPOOL 113cbaecb7ee19172633b0ee77ecfa10f6742848fd0f5f0797b95865f291e063ce3916719af48a81a72adfdaf40a4b18815e2434f0de91e2baa63822951470f0
diff --git a/www-apps/Apache-Gallery/files/76_apache2-gallery.conf b/www-apps/Apache-Gallery/files/76_apache2-gallery.conf
new file mode 100644
index 000000000000..34dd36dbdbbc
--- /dev/null
+++ b/www-apps/Apache-Gallery/files/76_apache2-gallery.conf
@@ -0,0 +1,40 @@
+##### Apache::Gallery configuration
+#
+# This is actually a virtual host definition with mod_perl directives
+# It might be a very good idea to disable mod_autoindex in apache[2].conf
+#
+
+#<VirtualHost localhost>
+# ServerName localhost
+# DocumentRoot /var/www/localhost/htdocs/data/pictures/
+# ErrorLog /var/log/gallery-error_log
+# TransferLog /var/log/gallery-access_log
+# <IfDefine MODPERL2>
+# PerlSetVar GalleryTemplateDir '/var/www/localhost/Apache-Gallery/templates/default'
+# PerlSetVar GalleryInfo 'Picture Taken => DateTimeOriginal, Flash => Flash'
+# PerlSetVar GallerySizes '640 1024 1600 2272'
+# PerlSetVar GalleryThumbnailSize '100x75'
+## If you have a copyright overlay image set the location of it
+# PerlSetVar GalleryCopyrightImage 'htdocs/c.png'
+## If you use Apache2 set the following "PerlOptions" too
+# PerlOptions +GlobalRequest
+# <Location />
+# SetHandler modperl
+# PerlResponseHandler Apache::Gallery
+# Options -Indexes
+# AllowOverride AuthConfig
+# Order deny,allow
+# Allow from all
+# </Location>
+# </IfDefine>
+## Allow access to cache
+# <Directory /var/tmp/Apache-Gallery>
+# Options -ALL
+# AllowOverride None
+# Order deny,allow
+# Allow from all
+# </Directory>
+## Give Apache an idea of where to find icons and css
+# Alias /icons /var/www/localhost/icons
+# Alias /gallery.css /var/www/localhost/Apache-Gallery/templates/default/gallery.css
+#</VirtualHost>
diff --git a/www-apps/Apache-Gallery/files/postinstall-en.txt b/www-apps/Apache-Gallery/files/postinstall-en.txt
new file mode 100644
index 000000000000..1db19de3c7d3
--- /dev/null
+++ b/www-apps/Apache-Gallery/files/postinstall-en.txt
@@ -0,0 +1,2 @@
+You should now edit the Apache configs that have been installed into your
+Apache confdir.
diff --git a/www-apps/Apache-Gallery/metadata.xml b/www-apps/Apache-Gallery/metadata.xml
new file mode 100644
index 000000000000..2b9b44f73497
--- /dev/null
+++ b/www-apps/Apache-Gallery/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>web-apps@gentoo.org</email>
+ <name>Gentoo Webapps</name>
+ </maintainer>
+</pkgmetadata>