summaryrefslogtreecommitdiff
path: root/www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild')
-rw-r--r--www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild b/www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild
new file mode 100644
index 000000000000..b8557517b9b3
--- /dev/null
+++ b/www-apache/modsec-flameeyes/modsec-flameeyes-99999999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit readme.gentoo git-2
+
+GITHUB_USER=Flameeyes
+GITHUB_PROJECT=${PN}
+
+EGIT_REPO_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}.git"
+
+DESCRIPTION="Flameeyes's Ruleset for ModSecurity"
+HOMEPAGE="http://www.flameeyes.eu/projects/modsec"
+#SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND=">=www-apache/mod_security-2.5.1"
+DEPEND=""
+
+RULESDIR=/etc/modsecurity/flameeyes
+
+DOC_CONTENTS="To enable the ruleset, define MODSEC_FLAMEEYES in
+/etc/conf.d/apache2.
+
+If you do not use www-apache/modsecurity-crs you want also to uncomment
+the init configuration file in /etc/apache2/modules/81_${PN}.conf."
+
+src_install() {
+ insinto "${RULESDIR}"
+ doins -r rules optional
+
+ dodoc README.md
+
+ cat - > "${T}/81_${PN}.conf" <<EOF
+<IfDefine MODSEC_FLAMEEYES>
+
+# Uncomment this if you don't use the CRS
+# Include /etc/modsecurity/flameeyes/optional/flameeyes_init.conf
+
+Include /etc/modsecurity/flameeyes/rules/*.conf
+
+# -*- apache -*-
+# vim: ts=4 filetype=apache
+
+EOF
+
+ insinto /etc/apache2/modules.d/
+ doins "${T}/81_${PN}.conf"
+
+ readme.gentoo_create_doc
+}