summaryrefslogtreecommitdiff
path: root/www-apache/mod_wsgi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-01 20:22:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-01 20:22:33 +0000
commit5b7c114c09d07eecd00e6f7fb829563aae3597b9 (patch)
treedb84e97d92f22634a22ce461f4ca00a294a21b24 /www-apache/mod_wsgi
parentad1d34add08caaf8d68c79e40f0a61c733fd68b8 (diff)
gentoo auto-resync : 01:01:2023 - 20:22:32
Diffstat (limited to 'www-apache/mod_wsgi')
-rw-r--r--www-apache/mod_wsgi/Manifest1
-rw-r--r--www-apache/mod_wsgi/files/mod_wsgi-4.7.1-py310.patch126
2 files changed, 0 insertions, 127 deletions
diff --git a/www-apache/mod_wsgi/Manifest b/www-apache/mod_wsgi/Manifest
index 3498219cc97c..75b703a234cd 100644
--- a/www-apache/mod_wsgi/Manifest
+++ b/www-apache/mod_wsgi/Manifest
@@ -1,5 +1,4 @@
AUX 70_mod_wsgi.conf 100 BLAKE2B e0df283f4b825628cceb7538231afbba10d3dc1eaab64da22d336c1426c4f8f0379e1958b3599811b2efc3cdb16f9543ad3f72d6139da9be01897bf200c06100 SHA512 6e0310d3f5dd8da4653c8502ad297ffe73c04e04c5fdd87721c407e839ba81ba4060394bcd1f06ef26d2d98cf007b585a382eb5f566345817999cd237adfa833
-AUX mod_wsgi-4.7.1-py310.patch 4484 BLAKE2B c58f1dff4ad997e18aa46f96d4dae6a11891e1e7efd7b0ffb3626d115634105c32b90eb697f950cf820145e569c4f2e285a1d36540ec602ee7b0976816e2d975 SHA512 03d535a85d1d44cc48c501e0e35029383ae95ba4cc54c440b50bb4176b48da61fe6dbd71a948fa510f717cae110f221a3abbf1445a139fde46cd68990f544a1e
DIST mod_wsgi-4.9.0.tar.gz 699891 BLAKE2B 7ee6ffc28e86baf8ee92973479a26964f7c183c2b113b49a48af02c622f8d8f698abffcd4f522a1ecca5b89325f94856cbe89db5a81d2ac2e87438ee90be97b0 SHA512 9dc34d431171321094a9713444895d9754eff4e69ad1e86c8d3cd77bc1ca0a4c10b697e7f8cf14902d6bfaf205c8842e62fa944bb38f66f1c54fd36af95a09d6
EBUILD mod_wsgi-4.9.0.ebuild 1108 BLAKE2B 676a71a8cf5ce47688af631f0107a0a969577800fe01a14f2a48f3c5539544e989c7e19f377394965f41774488b02f52ef611427984977fe8195b5cda56bbb57 SHA512 5dcbe0c3c3b345e17008b41c92ec27a5d2c4c235746e5b5528253abeef2932e73e0d5cdebe92ebda52d49c57e8652a0f832081290dab80ab2bc286e471e328b7
MISC metadata.xml 303 BLAKE2B 3b6303fa847f0f5b287faece9a7f0ce422531e0a0a130035cb5a032049daccba08c5460fc58af8a68d2eede0b8f5e76502e9c64109f33f219757ace3b2e82b98 SHA512 d24e5bcec7363bc5bb7f3c5798aa6978aefaee6990f5917ff133362fdcc32927a7b68a939b90cf38ebddbcf04c5b6310a1654a92d0a5eece5ba27245b8df0550
diff --git a/www-apache/mod_wsgi/files/mod_wsgi-4.7.1-py310.patch b/www-apache/mod_wsgi/files/mod_wsgi-4.7.1-py310.patch
deleted file mode 100644
index 274046d99ca0..000000000000
--- a/www-apache/mod_wsgi/files/mod_wsgi-4.7.1-py310.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-From b439f1c411a9479ccc03c16465cdff50fede79d3 Mon Sep 17 00:00:00 2001
-From: Petr Viktorin <encukou@gmail.com>
-Date: Thu, 10 Jun 2021 15:45:03 +0200
-Subject: [PATCH] Use Py_CompileString rather than
- PyParser_SimpleParseFile/PyNode_Compile
-From: https://github.com/GrahamDumpleton/mod_wsgi/commit/b439f1c411a9479ccc03c16465cdff50fede79d3
-
----
- src/server/mod_wsgi.c | 68 +++++++++++++++++++++++++++++++---------
- src/server/wsgi_python.h | 1 -
- 2 files changed, 53 insertions(+), 16 deletions(-)
-
-diff --git a/src/server/mod_wsgi.c b/src/server/mod_wsgi.c
-index b657a748..4f1d8765 100644
---- a/src/server/mod_wsgi.c
-+++ b/src/server/mod_wsgi.c
-@@ -3645,7 +3645,10 @@ static PyObject *wsgi_load_source(apr_pool_t *pool, request_rec *r,
- FILE *fp = NULL;
- PyObject *m = NULL;
- PyObject *co = NULL;
-- struct _node *n = NULL;
-+ char *source;
-+ size_t pos = 0;
-+ size_t allocated = 1024;
-+ size_t nread;
-
- #if defined(WIN32) && defined(APR_HAS_UNICODE_FS)
- apr_wchar_t wfilename[APR_PATH_MAX];
-@@ -3730,36 +3733,71 @@ static PyObject *wsgi_load_source(apr_pool_t *pool, request_rec *r,
- return NULL;
- }
-
-- n = PyParser_SimpleParseFile(fp, filename, Py_file_input);
--
-+ source = malloc(allocated);
-+ if (source != NULL) {
-+ do {
-+ nread = fread(source + pos, 1, allocated - pos, fp);
-+ pos += nread;
-+ if (nread == 0) {
-+ if (ferror(fp)) {
-+ free(source);
-+ source = NULL;
-+ }
-+ break;
-+ }
-+ if (pos == allocated) {
-+ allocated *= 2;
-+ char *reallocated_source = realloc(source, allocated);
-+ if (reallocated_source == NULL) {
-+ free(source);
-+ source = NULL;
-+ break;
-+ }
-+ source = reallocated_source;
-+ }
-+ } while (!feof(fp));
-+ }
- fclose(fp);
--
-- if (!n) {
-+ if (source == NULL) {
- Py_BEGIN_ALLOW_THREADS
- if (r) {
-- ap_log_rerror(APLOG_MARK, APLOG_ERR, 0, r,
-+ ap_log_rerror(APLOG_MARK, APLOG_ERR, errno, r,
- "mod_wsgi (pid=%d, process='%s', application='%s'): "
-- "Failed to parse Python script file '%s'.", getpid(),
-+ "Could not read source file '%s'.", getpid(),
- process_group, application_group, filename);
- }
- else {
-- ap_log_error(APLOG_MARK, APLOG_ERR, 0, wsgi_server,
-+ ap_log_error(APLOG_MARK, APLOG_ERR, errno, wsgi_server,
- "mod_wsgi (pid=%d, process='%s', application='%s'): "
-- "Failed to parse Python script file '%s'.", getpid(),
-+ "Could not read source file '%s'.", getpid(),
- process_group, application_group, filename);
- }
- Py_END_ALLOW_THREADS
-+ return NULL;
-+ }
-
-- wsgi_log_python_error(r, NULL, filename, 0);
-+ co = Py_CompileString(filename, source, 0);
-+ free(source);
-
-+ if (!co) {
-+ Py_BEGIN_ALLOW_THREADS
-+ if (r) {
-+ ap_log_rerror(APLOG_MARK, APLOG_ERR, errno, r,
-+ "mod_wsgi (pid=%d, process='%s', application='%s'): "
-+ "Could not compile source file '%s'.", getpid(),
-+ process_group, application_group, filename);
-+ }
-+ else {
-+ ap_log_error(APLOG_MARK, APLOG_ERR, errno, wsgi_server,
-+ "mod_wsgi (pid=%d, process='%s', application='%s'): "
-+ "Could not compile source file '%s'.", getpid(),
-+ process_group, application_group, filename);
-+ }
-+ Py_END_ALLOW_THREADS
- return NULL;
- }
-
-- co = (PyObject *)PyNode_Compile(n, filename);
-- PyNode_Free(n);
--
-- if (co)
-- m = PyImport_ExecCodeModuleEx((char *)name, co, (char *)filename);
-+ m = PyImport_ExecCodeModuleEx((char *)name, co, (char *)filename);
-
- Py_XDECREF(co);
-
-diff --git a/src/server/wsgi_python.h b/src/server/wsgi_python.h
-index fa06e2cb..3b34b731 100644
---- a/src/server/wsgi_python.h
-+++ b/src/server/wsgi_python.h
-@@ -43,7 +43,6 @@
-
- #include "structmember.h"
- #include "compile.h"
--#include "node.h"
- #include "osdefs.h"
- #include "frameobject.h"
-