summaryrefslogtreecommitdiff
path: root/www-apache/mod_security
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /www-apache/mod_security
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'www-apache/mod_security')
-rw-r--r--www-apache/mod_security/Manifest2
-rw-r--r--www-apache/mod_security/mod_security-2.9.3.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/www-apache/mod_security/Manifest b/www-apache/mod_security/Manifest
index 0addb9264676..bb2996b9036c 100644
--- a/www-apache/mod_security/Manifest
+++ b/www-apache/mod_security/Manifest
@@ -1,5 +1,7 @@
AUX 79_mod_security.conf 729 BLAKE2B 5a415b7890a6d9553ec6e974825adad596a8f6d5c3b9ca0b7b9c4b2c3a788838d272343037d91cf94e8195510e7e395fc07d6a2ef2c6647695470714a79a7875 SHA512 2b99b28b58795dd45a76046609e7a4a6958ebd28c28c288cb7b732ec99191e218e6dd838a3c288220f267ad8c3b6004d1d6c6addac8df8be4c568a9f2fb54a92
AUX modsecurity-2.7.conf 394 BLAKE2B c9d55e8b4419e5b54a364e03dd02e9d0e5609954d1538c77baa33e0abc46110fa8aaf3207490a80a2fedc13d42558632703ee4552ebbaa99d67d929720008dd2 SHA512 ab8c1ee6372249613f853654f115102c7951ea021f47389510bca6c5d1226e7aa9d90bb47649cf4ca62b8d8f926eba9f5c0b02321851ec2e8452de70dd4c1839
DIST modsecurity-2.9.1.tar.gz 4261212 BLAKE2B c47c7934d8da870e629c5733cc8c37452e4d90351269a14b99483188e8e3161891bd63bfd70e0723648c8daf51f1c33d900bd90ab0157332f826eab772f09f62 SHA512 374733cbfc26e53d95b78c8f268a4e465d838163e9893fc24e33a9d272b114f1b287147bab6d0289575074cbbd94f48983e23fa59832cbcb32950046cea59269
+DIST modsecurity-2.9.3.tar.gz 4307670 BLAKE2B 337ea15cc8805af7ab43aed8aecf4c72ccc586d0d7e9d9b91f036a61baa70d1ac8b4ad8045a2bb7a13515912a15fba7d3cdb9670ae6730de43b1e44ee90ded6d SHA512 4e1ea5dd8edadf8f630e4fe92a200d3a8e78963fce3128b5975a1e1ecd0e8bf9ceecd9905c95f8c508932ccd837f1d8ae8bb2ba423307718c3c6a4ae9b783ddd
EBUILD mod_security-2.9.1-r1.ebuild 2768 BLAKE2B a278a8138efb52c23378fc561adcb2e72345bf63d5c628f11e7c2ecf641ce16dcc5d9d018a7fdfd78f95e03783f8700062ab3fc8e78f1ed41ea3a53bb93fbec1 SHA512 09a1dacfa56d0c188976312a0d4786ee712dfba38ca2d280f96945c308d6f2cae54c014edbc6f5c9ea82bb233fba2bca368a3e7c1123bfa9032ca00666f113e8
+EBUILD mod_security-2.9.3.ebuild 2616 BLAKE2B 2bc64259b3cd4ed532812e1b5ceb72a1ea9d16935b6a0f396d14e67a5a0858b1eb1b0829fb9a5892817004bad1a26fcc63a2f4ab46b42bd04e8fad6b3d4bb343 SHA512 38787e38faffbd7c1620bdc777dfdf1e19d3c8c9aca93ef508439266d60c2a05e216ce2be3d8e533d4af4e2dabbdd3c9da58e7f1beea7f102bf4d841c9501056
MISC metadata.xml 982 BLAKE2B f65a4592e166d75885dd1f2c9a9de79a4f3cb44be079c38300f65f3ffad9eccad8f87695ba665a175b3a38cd249aeb7875dc16884218b735e51b13812b7be3ea SHA512 a2a0c01efa1c1bf5193c0d41df0fd03f915bf53ffa51205d32cc76b633d1707a832b0177b0fc09dd88ea7e44b53caa1c03820c2e0934ced2411862674332a293
diff --git a/www-apache/mod_security/mod_security-2.9.3.ebuild b/www-apache/mod_security/mod_security-2.9.3.ebuild
new file mode 100644
index 000000000000..f04a0e597d6d
--- /dev/null
+++ b/www-apache/mod_security/mod_security-2.9.3.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module
+
+MY_PN=modsecurity
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Application firewall and intrusion detection for Apache"
+HOMEPAGE="http://www.modsecurity.org/"
+SRC_URI="http://www.modsecurity.org/tarball/${PV}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fuzzyhash geoip jit json lua mlogc"
+
+COMMON_DEPEND="dev-libs/apr
+ dev-libs/apr-util[openssl]
+ dev-libs/libxml2
+ dev-libs/libpcre[jit?]
+ fuzzyhash? ( app-crypt/ssdeep )
+ json? ( dev-libs/yajl )
+ lua? ( dev-lang/lua:0 )
+ mlogc? ( net-misc/curl )
+ www-servers/apache[apache2_modules_unique_id]"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${COMMON_DEPEND}
+ geoip? ( dev-libs/geoip )
+ mlogc? ( dev-lang/perl )"
+PDEPEND=">=www-apache/modsecurity-crs-2.2.6-r1"
+
+S="${WORKDIR}/${MY_P}"
+
+APACHE2_MOD_FILE="apache2/.libs/${PN}2.so"
+APACHE2_MOD_CONF="79_${PN}"
+APACHE2_MOD_DEFINE="SECURITY"
+
+# Tests require symbols only defined within the Apache binary.
+RESTRICT=test
+
+need_apache2
+
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ --enable-request-early
+ --with-apxs="${APXS}"
+ --with-pic
+ $(use_with fuzzyhash ssdeep)
+ $(use_with json yajl)
+ $(use_enable mlogc)
+ $(use_with lua)
+ $(use_enable lua lua-cache)
+ $(use_enable jit pcre-jit)
+ $(use_enable doc docs) )
+
+ econf ${myconf[@]}
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ apache-module_src_install
+
+ dodoc CHANGES README.md modsecurity.conf-recommended
+
+ if use doc; then
+ dodoc -r doc/apache/html
+ fi
+
+ if use mlogc; then
+ insinto /etc/
+ newins mlogc/mlogc-default.conf mlogc.conf
+ dobin mlogc/mlogc
+ dobin mlogc/mlogc-batch-load.pl
+ newdoc mlogc/INSTALL INSTALL-mlogc
+ fi
+
+ # Use /var/lib instead of /var/cache. This stuff is "persistent,"
+ # and isn't a cached copy of something that we can recreate.
+ # Bug 605496.
+ keepdir /var/lib/modsecurity
+ fowners apache:apache /var/lib/modsecurity
+ fperms 0750 /var/lib/modsecurity
+ for dir in data tmp upload; do
+ keepdir "/var/lib/modsecurity/${dir}"
+ fowners apache:apache "/var/lib/modsecurity/${dir}"
+ fperms 0750 "/var/lib/modsecurity/${dir}"
+ done
+}
+
+pkg_postinst() {
+ elog "The base configuration file has been renamed ${APACHE2_MOD_CONF}"
+ elog "so that you can put your own configuration in (for example)"
+ elog "90_modsecurity_local.conf."
+ elog ""
+ elog "That would be the correct place for site-global security rules."
+ elog "Note: 80_modsecurity_crs.conf is used by www-apache/modsecurity-crs"
+}