summaryrefslogtreecommitdiff
path: root/www-apache/mod_nss/mod_nss-1.0.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /www-apache/mod_nss/mod_nss-1.0.18.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'www-apache/mod_nss/mod_nss-1.0.18.ebuild')
-rw-r--r--www-apache/mod_nss/mod_nss-1.0.18.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/www-apache/mod_nss/mod_nss-1.0.18.ebuild b/www-apache/mod_nss/mod_nss-1.0.18.ebuild
new file mode 100644
index 000000000000..310b5c215080
--- /dev/null
+++ b/www-apache/mod_nss/mod_nss-1.0.18.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools apache-module
+
+DESCRIPTION="SSL/TLS module for the Apache HTTP server"
+HOMEPAGE="https://pagure.io/mod_nss"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ecc"
+
+# https://bugs.gentoo.org/742455
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/nspr
+ dev-libs/nss"
+RDEPEND="${DEPEND}
+ net-dns/bind-tools"
+BDEPEND="virtual/pkgconfig"
+
+APACHE2_MOD_CONF="47_${PN}"
+APACHE2_MOD_DEFINE="NSS"
+
+need_apache2
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
+src_prepare() {
+ default
+
+ # setup proper exec name
+ sed -i -e 's/certutil/nsscertutil/' gencert.in || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable ecc) --with-apxs=${APXS}
+}
+
+src_compile() {
+ # default src_compile fails:
+ # In file included from mod_nss.c:16:0:
+ # mod_nss.h:51:18: fatal error: nspr.h: No such file or directory
+ emake
+}
+
+src_install() {
+ # override broken build system
+ mv .libs/libmodnss.so .libs/"${PN}".so || die "cannot move lib"
+ dosbin gencert nss_pcache
+ dodoc docs/mod_nss.html
+ newbin migrate.pl nss_migrate
+ dodir /etc/apache2/nss
+ einstalldocs
+
+ APACHE_MODULESDIR="/usr/$(get_libdir)/apache2/modules"
+ apache-module_src_install
+}