summaryrefslogtreecommitdiff
path: root/www-apache/mod_backtrace/mod_backtrace-2.01.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /www-apache/mod_backtrace/mod_backtrace-2.01.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'www-apache/mod_backtrace/mod_backtrace-2.01.ebuild')
-rw-r--r--www-apache/mod_backtrace/mod_backtrace-2.01.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/www-apache/mod_backtrace/mod_backtrace-2.01.ebuild b/www-apache/mod_backtrace/mod_backtrace-2.01.ebuild
new file mode 100644
index 000000000000..04115faa8877
--- /dev/null
+++ b/www-apache/mod_backtrace/mod_backtrace-2.01.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit apache-module depend.apache
+
+DESCRIPTION="Debug segmentation faults in Apache threads"
+HOMEPAGE="https://emptyhammock.com/projects/httpd/diag/"
+SRC_URI="https://emptyhammock.com/downloads/wku_bt-${PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unwind"
+
+RDEPEND="=www-servers/apache-2*[debug]
+ unwind? ( sys-libs/libunwind )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="BACKTRACE"
+
+need_apache2
+
+S="${WORKDIR}/wku_bt-${PV}"
+
+src_compile() {
+ APXS2_ARGS="-c ${PN}.c diag.c -ldl"
+ if use unwind; then
+ APXS2_ARGS+=" -lunwind -DDIAG_HAVE_LIBUNWIND_BACKTRACE=1"
+ fi
+ apache-module_src_compile
+}