summaryrefslogtreecommitdiff
path: root/virtual
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-03 22:19:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-03 22:19:54 +0100
commit71f9cc21aab4168093940b3d2e267444d712bff5 (patch)
tree15406e14be0cd3cfbafe191468b8825b3ccc1855 /virtual
parent312456186919deebd1ea3b34b9e26b1e15ebd5b6 (diff)
gentoo auto-resync : 03:09:2022 - 22:19:54
Diffstat (limited to 'virtual')
-rw-r--r--virtual/Manifest.gzbin28622 -> 28623 bytes
-rw-r--r--virtual/wine/Manifest3
-rw-r--r--virtual/wine/metadata.xml1
-rw-r--r--virtual/wine/wine-0-r8.ebuild25
4 files changed, 28 insertions, 1 deletions
diff --git a/virtual/Manifest.gz b/virtual/Manifest.gz
index c3d642a46db3..1ed761b71d51 100644
--- a/virtual/Manifest.gz
+++ b/virtual/Manifest.gz
Binary files differ
diff --git a/virtual/wine/Manifest b/virtual/wine/Manifest
index 45258e96e035..5b459871a5f9 100644
--- a/virtual/wine/Manifest
+++ b/virtual/wine/Manifest
@@ -1,2 +1,3 @@
EBUILD wine-0-r7.ebuild 786 BLAKE2B f001da539be2b56d39d06b825c691f5de07c0d7468e059b3fc1fb54f4580a50f749b82306fe5b696e2e0b7009fbd278a9a4756d19c1d6f9a38e10020e9586500 SHA512 433b8fb67d592384a933b2c5f35f2185a2c3e69e1d77a320d7879071e02f73ca430c3b5f24ea769a43a30f5539b99b61a7b225f0b9abccafd026a66dde26d1d8
-MISC metadata.xml 550 BLAKE2B d9e3001819e1e32757e71b37a248472db3b46cdbe7f1bea58cf032b9bac752c0455cf5ebf5c4a747dee4b9a34bb703200951ebbfdc1f85f564a8a25a26aa6d8c SHA512 d399360ff7ce8ea32fbb0330fc0d14174455a9ca71fce3cfeea12739cf0a4cf57ba4695804fc591d724f9c932c9a657bf4fd1f50290d2e9e149fa729cac9ba74
+EBUILD wine-0-r8.ebuild 876 BLAKE2B bc08d9f18c69a6faaeec3fa7765432cc5c2c5570b6ecf3239d54f3171a1a0bec2b42e6852e17161024a305d1f5f3375dec7aca229658b187d2ff7bb82c98bc64 SHA512 795cca53a677961b8d89b632f3eb4df026a85a89745bc37c09da859a1788f2ea601b1bfe50541a946aaf2b293034d82d5c45adbc094ea79ff621ff9a0bbe6d3d
+MISC metadata.xml 616 BLAKE2B 22b029cdf55e61e52458293426c955ebb59a6a0700da25edc0af97980a8143e01c9db583c5e07df91760fc1e75127ddab557f287cd0bf82c36aaf4a61df49a7b SHA512 30bc536caf5cbef33a24e3b08dc208d67c61f8712bb39325a812afc5577511c5d73250299ae59701eba6f43a201a47669155633e48ec0962e3d1cb9acfb95ce5
diff --git a/virtual/wine/metadata.xml b/virtual/wine/metadata.xml
index a7c476ea196a..a5e53660da5c 100644
--- a/virtual/wine/metadata.xml
+++ b/virtual/wine/metadata.xml
@@ -6,6 +6,7 @@
<name>Wine</name>
</maintainer>
<use>
+ <flag name="proton">Enable Valve Software's fork of Wine</flag>
<flag name="staging">Enable Wine-Staging's Patchset</flag>
</use>
<stabilize-allarches/>
diff --git a/virtual/wine/wine-0-r8.ebuild b/virtual/wine/wine-0-r8.ebuild
new file mode 100644
index 000000000000..af40db7eedf9
--- /dev/null
+++ b/virtual/wine/wine-0-r8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Virtual for Wine that supports multiple variants and slotting"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+abi_x86_32 +abi_x86_64 proton staging"
+REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
+
+# Note, the ordering here is intentional, to take advantage of the short-circuit
+# logic of portage, to enforce wine-vanilla as default for new users. The idea
+# behind this is that some USE flags may pull in 3rd-party patchsets, so default
+# of vanilla prevents that.
+RDEPEND="
+ proton? ( app-emulation/wine-proton )
+ staging? ( app-emulation/wine-staging[staging] )
+ || (
+ app-emulation/wine-vanilla[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-proton[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-staging[abi_x86_32=,abi_x86_64=]
+ )
+ !app-emulation/wine:0"