summaryrefslogtreecommitdiff
path: root/virtual
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-24 08:52:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-24 08:52:43 +0100
commit28267a5e528b273fbd1b0f5f52ecaab4b03016ab (patch)
treef2c2ddc5cf19fcbc848cc9fe427df5abd8ac0339 /virtual
parente19b21c73e5feac42ade97baf3eeb45c58a2f234 (diff)
gentoo auto-resync : 24:07:2022 - 08:52:43
Diffstat (limited to 'virtual')
-rw-r--r--virtual/Manifest.gzbin28623 -> 28625 bytes
-rw-r--r--virtual/opencl/Manifest3
-rw-r--r--virtual/opencl/opencl-3-r1.ebuild4
-rw-r--r--virtual/opencl/opencl-3-r2.ebuild35
4 files changed, 39 insertions, 3 deletions
diff --git a/virtual/Manifest.gz b/virtual/Manifest.gz
index 5759c217d04b..260b58fddf84 100644
--- a/virtual/Manifest.gz
+++ b/virtual/Manifest.gz
Binary files differ
diff --git a/virtual/opencl/Manifest b/virtual/opencl/Manifest
index b0f184d81097..66f9893dfc47 100644
--- a/virtual/opencl/Manifest
+++ b/virtual/opencl/Manifest
@@ -1,2 +1,3 @@
-EBUILD opencl-3-r1.ebuild 1274 BLAKE2B 40b33ca27e0ac503fb62f1d055bc4194e5d1b11955b10082fb3c75743d8a863a3929281e938e600df3af1d6b01f075c205ecd02921d07f3a86e0f9c8ad5f8427 SHA512 92db7614f975c73f007986e06c2daf51e232b1bd13b714bcc8b4ddbbd91368d981effb08e91cc53abbff6cc8dde1cdac623c00194ed32200a146226e0ec3cf5b
+EBUILD opencl-3-r1.ebuild 1281 BLAKE2B 0f4778bbdbbebbf973457c52c3bca1dde5a6be3edaacb32a9f48a499c0a2eea165ea3432d8763d10ab07da319c13e3f600ee252a0f3e30e5a36dd1c0a1d1bcfd SHA512 b6d8a2e8dc93355b05e2a9b6f5dba5304951ae5ee6dfe5e2ad3d04d7b3c4ba988afb9f70e67dd1a16464405c72d9e3f00cc9b9d789a6bc36ede84cdaff880a7b
+EBUILD opencl-3-r2.ebuild 1385 BLAKE2B 292076b57562d8968bd913afadee5195add0eb7735f31db3e5008283f840c420703f71cdaf2329eccdbec9a7c5caa4c9ad962b873068a7eba24a2d342a576462 SHA512 261e91344d2b1579d089739cafd4467107562e8c3823206fc1c905abe5586aee52fc26e235f130f1f6d46b7c74fec761052e8466bb5ee8d53c31dac52f4f8576
MISC metadata.xml 259 BLAKE2B cc7abf54ed4398a2cfb77310c63f5fae3e432488b0c7466f8148c5d009d38aa4ca78eef78712f0b7b6aca6710aab1dfe3c07440f36179fde03f8a97a49b3c080 SHA512 6f50c5d3c735db431156906312a7c1dab3723d8c9e51d15148b92d97a998221c6838eb926f36c6b924c9fc8a6a64ba904e36482ff5164867c482502aa638462f
diff --git a/virtual/opencl/opencl-3-r1.ebuild b/virtual/opencl/opencl-3-r1.ebuild
index 525acb9d011a..e5b93e28bee0 100644
--- a/virtual/opencl/opencl-3-r1.ebuild
+++ b/virtual/opencl/opencl-3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,7 +7,7 @@ inherit multilib-build
DESCRIPTION="Virtual for OpenCL API"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 ~ppc64 x86"
RDEPEND="|| ( dev-libs/opencl-icd-loader[${MULTILIB_USEDEP}]
dev-libs/ocl-icd[khronos-headers,${MULTILIB_USEDEP}] )"
diff --git a/virtual/opencl/opencl-3-r2.ebuild b/virtual/opencl/opencl-3-r2.ebuild
new file mode 100644
index 000000000000..56a9bf8353ab
--- /dev/null
+++ b/virtual/opencl/opencl-3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for OpenCL API"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="|| ( dev-libs/opencl-icd-loader[${MULTILIB_USEDEP}]
+ dev-libs/ocl-icd[khronos-headers,${MULTILIB_USEDEP}] )"
+
+pkg_postinst() {
+ elog
+ elog "In order to take advantage of OpenCL you will need a runtime for your hardware."
+ elog "Currently included in Gentoo are:"
+ elog
+ elog " * open:"
+ elog " - dev-libs/intel-compute-runtime - integrated Intel GPUs from Broadwell onwards. 64-bit only;"
+ elog " - dev-libs/pocl - to run OpenCL programs on your CPU, if you do not have a supported GPU;"
+ elog " - dev-libs/rocm-opencl-runtime - AMD GPUs supported by the amdgpu kernel driver. 64-bit only;"
+ elog " - media-libs/mesa[opencl] - some older AMD GPUs; see [1]. 32-bit support;"
+ elog
+ elog " * proprietary:"
+ elog " - dev-libs/amdgpu-pro-opencl - AMD Polaris GPUs. 32-bit support;"
+ elog " - dev-util/intel-ocl-sdk - Intel CPUs (*not* GPUs). 64-bit only;"
+ elog " - x11-drivers/nvidia-drivers[uvm] - Nvidia GPUs; specific package versions"
+ elog " required for older devices [2]. 32-bit support."
+ elog
+ elog " [1] https://dri.freedesktop.org/wiki/GalliumCompute/"
+ elog " [2] https://www.nvidia.com/en-us/drivers/unix/legacy-gpu/"
+ elog
+}