summaryrefslogtreecommitdiff
path: root/virtual/wine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /virtual/wine
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'virtual/wine')
-rw-r--r--virtual/wine/Manifest1
-rw-r--r--virtual/wine/wine-0-r7.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/virtual/wine/Manifest b/virtual/wine/Manifest
index e69ab655e53e..d5c8cc36c05b 100644
--- a/virtual/wine/Manifest
+++ b/virtual/wine/Manifest
@@ -1,3 +1,4 @@
EBUILD wine-0-r5.ebuild 1011 BLAKE2B f3a67828edf578b1bb9c2f5b6f5ed387123419fd390b6da4f99323dce8c7512d008be77d7270b420c9b3264db097868403f36d58e38876eab851fc977497f622 SHA512 8c86b3059e6d33b971aaef192b4adf9516a1edb3faf60f311b57180720874fbb188133b1a585355507a6c2e5e5e5552a8996a0281acc2d796bcbb85e588b4d5e
EBUILD wine-0-r6.ebuild 923 BLAKE2B 5bfca554416fc7b46b34a4a8ac789af7183177efc03ce52292a97f25b80d83b14d1a70df28facbb36ac87ff1d2b7264e309347d5af010b50890e50a15be32c09 SHA512 579bf05c33864078a04584bbfe4f8ce23ed47297434c7e6f503cd7515a907889704f41751f369a399ee41312cf669a86e545dc170c775856e73910b0d2aeec42
+EBUILD wine-0-r7.ebuild 788 BLAKE2B ea1bdf23acb8d1af4e4caa1cbe096f243e2fbd7336a4ccc2b97d25b08ab48ebfcf9ca0b3af63d0a9ef88c56519ca1873d21944da6b5e514a1f43d6ea7c817fa9 SHA512 6e8dabe31a7f323c20abd028933d54fbaf2e07a5abe87938cdbd8f1df5517d4143006ef36291456a65c46344de3efa04e7200e6959b14bdeddd717d7293316be
MISC metadata.xml 588 BLAKE2B 2aa8c20868c11eda5c3365bd0f5f320d9d13bb9cf2681949bc6853534abf2178bda5d325ba55242ea1b8bfbed4daf9f0e360d29510e4f5d76d62be4aefcb48b3 SHA512 fb7933567b68997f1ca8e78a36a63fb2f956d452c6fbd5376f8a335653fef3bafe722960d5c954fee3d8a061774c8bdf93c39f8c786c3bb9ab7152d8031588a7
diff --git a/virtual/wine/wine-0-r7.ebuild b/virtual/wine/wine-0-r7.ebuild
new file mode 100644
index 000000000000..c169693fcdbb
--- /dev/null
+++ b/virtual/wine/wine-0-r7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Virtual for Wine that supports multiple variants and slotting"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+abi_x86_32 +abi_x86_64 staging"
+
+REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
+
+# Note, the ordering here is intentional, to take advantage of the short-circuit
+# logic of portage, to enforce wine-vanilla as default for new users. The idea
+# behind this is that some USE flags may pull in 3rd-party patchsets, so default
+# of vanilla prevents that.
+RDEPEND="
+ staging? ( || (
+ app-emulation/wine-staging[staging]
+ ) )
+ || (
+ app-emulation/wine-vanilla[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-staging[abi_x86_32=,abi_x86_64=]
+ )
+ !app-emulation/wine:0"