summaryrefslogtreecommitdiff
path: root/virtual/wine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /virtual/wine
reinit the tree, so we can have metadata
Diffstat (limited to 'virtual/wine')
-rw-r--r--virtual/wine/Manifest3
-rw-r--r--virtual/wine/metadata.xml16
-rw-r--r--virtual/wine/wine-0-r5.ebuild33
-rw-r--r--virtual/wine/wine-0-r6.ebuild33
4 files changed, 85 insertions, 0 deletions
diff --git a/virtual/wine/Manifest b/virtual/wine/Manifest
new file mode 100644
index 000000000000..657125166c5a
--- /dev/null
+++ b/virtual/wine/Manifest
@@ -0,0 +1,3 @@
+EBUILD wine-0-r5.ebuild 1021 SHA256 13050b3889463fd7425f4d2eabc4fb81c083099bad981a52cf9c24c98b4256d5 SHA512 1d4f936575aa9985f52acc39cc26ecc1ef2e713a181a953c3684655046a5c10ec0bc8200c4d84741209d043a67bb7a75392575c016ff4be86730f9a49ec38402 WHIRLPOOL 30172ddcad087fa66a6355c1cfb8d4aa7ec8b5ef97cd758b6fdfba10f97ee156bbe2a0fb1498bbd89b6821f7ae96479c7af10ac36e95817e11f71d074ff93408
+EBUILD wine-0-r6.ebuild 1023 SHA256 4f4f934ba4d27f44c66dce69cc7a33e8f0affa300e5a6391c413c0a18c08936b SHA512 788d4dc1fa44d3dbbb44ceebf9718f432f3c96f52835818b5316009ef385cc0eab7ff1bc35bcd687d5fec24bd5bca988ce3462d33d6882393cb39d8f892b4aa5 WHIRLPOOL c8a793e5d2fc754e6ef9bd6528a4723f51c0945695dc50d7a01eaa5134e335a3e3be26d65178404bfc7805c350a8b1f2d813629fd5dfa75fb5143caf7d91e5eb
+MISC metadata.xml 588 SHA256 505f3beaca16adeac767c04d70e76c9cb2351e46fe1c0435103f1e86603c7d51 SHA512 fb7933567b68997f1ca8e78a36a63fb2f956d452c6fbd5376f8a335653fef3bafe722960d5c954fee3d8a061774c8bdf93c39f8c786c3bb9ab7152d8031588a7 WHIRLPOOL a3a8d49faafb3ad139d80fe65c0d9768de693e5746a678956d1be063d4e748cb1b676064a020a0f04c0b16688a041f18c928ef3e91620d4d5716e41baa48e099
diff --git a/virtual/wine/metadata.xml b/virtual/wine/metadata.xml
new file mode 100644
index 000000000000..de062ba7a89a
--- /dev/null
+++ b/virtual/wine/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>wine@gentoo.org</email>
+ <name>Wine</name>
+ </maintainer>
+ <use>
+ <flag name="d3d9">Enable Ixit's Gallium Nine Patchset</flag>
+ <flag name="staging">Enable Wine-Staging's Patchset</flag>
+ </use>
+ <longdescription lang="en">
+ Allows for any variant of Wine, regardless of slotting to fulfill the dependencies
+ traditionally fulfilled by the non-slotted, pre-variant, app-emulation/wine.
+ </longdescription>
+</pkgmetadata>
diff --git a/virtual/wine/wine-0-r5.ebuild b/virtual/wine/wine-0-r5.ebuild
new file mode 100644
index 000000000000..ac3dcae4f7fd
--- /dev/null
+++ b/virtual/wine/wine-0-r5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Virtual for Wine that supports multiple variants and slotting"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE="+abi_x86_32 +abi_x86_64 d3d9 staging"
+
+REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
+
+# Note, the ordering here is intentional, to take advantage of the short-circuit
+# logic of portage, to enforce wine-vanilla as default for new users. The idea
+# behind this is that some USE flags may pull in 3rd-party patchsets, so default
+# of vanilla prevents that.
+RDEPEND="
+ staging? ( || (
+ app-emulation/wine-staging[staging]
+ app-emulation/wine-any[staging]
+ ) )
+ d3d9? ( || (
+ app-emulation/wine-d3d9[d3d9]
+ app-emulation/wine-any[d3d9]
+ ) )
+ || (
+ app-emulation/wine-vanilla[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-staging[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-d3d9[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-any[abi_x86_32=,abi_x86_64=]
+ )
+ !app-emulation/wine:0"
diff --git a/virtual/wine/wine-0-r6.ebuild b/virtual/wine/wine-0-r6.ebuild
new file mode 100644
index 000000000000..5371654fca77
--- /dev/null
+++ b/virtual/wine/wine-0-r6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Virtual for Wine that supports multiple variants and slotting"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="+abi_x86_32 +abi_x86_64 d3d9 staging"
+
+REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
+
+# Note, the ordering here is intentional, to take advantage of the short-circuit
+# logic of portage, to enforce wine-vanilla as default for new users. The idea
+# behind this is that some USE flags may pull in 3rd-party patchsets, so default
+# of vanilla prevents that.
+RDEPEND="
+ staging? ( || (
+ app-emulation/wine-staging[staging]
+ app-emulation/wine-any[staging]
+ ) )
+ d3d9? ( || (
+ app-emulation/wine-d3d9[d3d9]
+ app-emulation/wine-any[d3d9]
+ ) )
+ || (
+ app-emulation/wine-vanilla[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-staging[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-d3d9[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-any[abi_x86_32=,abi_x86_64=]
+ )
+ !app-emulation/wine:0"