summaryrefslogtreecommitdiff
path: root/virtual/rust/rust-1.72.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-02 11:46:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-02 11:46:02 +0100
commitfade240e5eae2521e59569af4ab63e27415f4e5b (patch)
tree18ce5cd3bed52f77d3ff5fbe8b47a025b6892619 /virtual/rust/rust-1.72.0-r1.ebuild
parent16c48ec5caa018c82b1db0f23542c29893f9b919 (diff)
gentoo auto-resync : 02:10:2023 - 11:46:02
Diffstat (limited to 'virtual/rust/rust-1.72.0-r1.ebuild')
-rw-r--r--virtual/rust/rust-1.72.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.72.0-r1.ebuild b/virtual/rust/rust-1.72.0-r1.ebuild
new file mode 100644
index 000000000000..455f215fcecc
--- /dev/null
+++ b/virtual/rust/rust-1.72.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-16"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"