summaryrefslogtreecommitdiff
path: root/virtual/python-singledispatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /virtual/python-singledispatch
reinit the tree, so we can have metadata
Diffstat (limited to 'virtual/python-singledispatch')
-rw-r--r--virtual/python-singledispatch/Manifest4
-rw-r--r--virtual/python-singledispatch/metadata.xml13
-rw-r--r--virtual/python-singledispatch/python-singledispatch-0.ebuild16
3 files changed, 33 insertions, 0 deletions
diff --git a/virtual/python-singledispatch/Manifest b/virtual/python-singledispatch/Manifest
new file mode 100644
index 000000000000..969cbd80032f
--- /dev/null
+++ b/virtual/python-singledispatch/Manifest
@@ -0,0 +1,4 @@
+EBUILD python-singledispatch-0.ebuild 489 SHA256 87fafe3c6042c5427f64b442cc60cea9e5d13e80628665f75a7fc701974031ea SHA512 c9244abea04018b1e708b7a7fc6c11b5090ea22b9cffab0f9144e6e102f73230065bbd24fc3bd91880ab0fa5ad2085c34b78f8e78a07d30f8528437d1a60ff6e WHIRLPOOL 2b02cc6961985e143cbec115540cce563b1f3b8848d4e316922b8efb0f69fbca7324c7f0a64513abaf3782c29ca07ca633f74bd95079de1eaafb65ba13b58ee1
+MISC ChangeLog 5080 SHA256 5b736c44aa1aea7cf88d8d6c1a07273338ce54cd7e66b6ad66b3a156b6f4fb34 SHA512 3553544d2873c5bdbc80bd949fc090a2de402e140c8c565b5eafab0a45a8d01bf9f2b136f16cb461dcb815c88705cd296ed79b48b885ea749e874b8d3750e858 WHIRLPOOL 6b922001768d27fb072380ac4408c9f3932ca8e589df222c366303c8450f09a9d2b2f8486cc905c2aa48dc67f963f0eab9b5bce66d41eff8b46e33042d4e81e6
+MISC ChangeLog-2015 817 SHA256 199a01b0dca05aab91ad5e22d4ae4f36fd4e5dbf03fc1f57235b27f5e67ddd3f SHA512 a0ef474080219b543dc2f46a319f89373a8edc7a1271e2660b1441ca82dabf6c79f2070c64bf68f20adced6e1bdf4934ad74e4c4aaa7c1aa3b5c2499ebccd9b0 WHIRLPOOL 92fdcf78dd9658a63920ed6ad7f80f781f0a6901ef5595c71f99e1f46768b5e4f0527994a3fd3654d1700e97b9ffdd4bb8f663a0bb195a0c731fd5af856f3cc3
+MISC metadata.xml 432 SHA256 5252a195d0160e8078dd38722aa6b4740c839065f36f7de637f8a81782b52210 SHA512 e4956ea9f76a8813b6b14b642f132c56d36d1009b26c2d14f35f379fb481d5987f8b88711bd5c330d087260805ad36c5baf68db9a7cc95db0039fdbbb13a8458 WHIRLPOOL 9d0d7fb9c7d2d1e90213a7569b6777deb1af0bacfe541985c5263921f88b01f48014cc71161dd95c4b43186315bca7e0b1045e186240e9a9b622a96fd96054a3
diff --git a/virtual/python-singledispatch/metadata.xml b/virtual/python-singledispatch/metadata.xml
new file mode 100644
index 000000000000..a7153a96747b
--- /dev/null
+++ b/virtual/python-singledispatch/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>timo@rothenpieler.org</email>
+ <name>Timo Rothenpieler</name>
+ <description>proxy maintainer</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/virtual/python-singledispatch/python-singledispatch-0.ebuild b/virtual/python-singledispatch/python-singledispatch-0.ebuild
new file mode 100644
index 000000000000..019fac952381
--- /dev/null
+++ b/virtual/python-singledispatch/python-singledispatch-0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python functools.singledispatch function"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/singledispatch[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)"