summaryrefslogtreecommitdiff
path: root/virtual/python-pmw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /virtual/python-pmw
reinit the tree, so we can have metadata
Diffstat (limited to 'virtual/python-pmw')
-rw-r--r--virtual/python-pmw/Manifest3
-rw-r--r--virtual/python-pmw/metadata.xml8
-rw-r--r--virtual/python-pmw/python-pmw-1.ebuild17
3 files changed, 28 insertions, 0 deletions
diff --git a/virtual/python-pmw/Manifest b/virtual/python-pmw/Manifest
new file mode 100644
index 000000000000..c00c786c43e2
--- /dev/null
+++ b/virtual/python-pmw/Manifest
@@ -0,0 +1,3 @@
+EBUILD python-pmw-1.ebuild 512 SHA256 3c1d3a92b63661e2e9a08a931140f8258c93d10540f85e2a8656f3e03ec45c24 SHA512 22e1a0c2d0cf707a12559055bfa7a64bef32dddeecfc87f6408b12d21d997f4e25a6d58a6f6cbfb930c672073c8d37b9df0cf3449bdf5298dbd9c17445a1e901 WHIRLPOOL 577ddfbcb89e75aae1ed1b0d782e9a66208ef22543f40d2db09eb0c0841612c34d752bde074195006ac2191160557814feb1c094a00e0803038af75b24cb66fb
+MISC ChangeLog 1046 SHA256 cf10d807fe0c6c226a199d31c9fbe1fef062c9e09de7c95f49036256957aecfc SHA512 177deb10fc9def859b31daaff6c071fccc6bc513e5565a181e4a5f4211082f36091691f8811d11a13830dde3208dc6e0a561e4795dcd336fb10089cdb802a072 WHIRLPOOL 6e7ccd5332e2f171c8d937269e5513398fea48b5f8d2de97a0de737d69a7203dac902c847aea5356c640548f619aa56510c778fd086ab26a6d53373fb78436e4
+MISC metadata.xml 246 SHA256 634432e12556106844e569b7ff16962881c6e70887e6fc9650bdd82deb51a834 SHA512 3245fb694492b2f698fb63aac02e66fb8a94fe35eabda45df4790bec043a1ea552e112315334001902f070093bb73e7b741aa3004757404aed97ebdb86cc9fbc WHIRLPOOL 869ef1c8e23bdae0a11b44ccf38ddec23f0dc0ae2573bc83ccbe2d8a2c6bf5a3f9c3c52149aa2e3690dd66f7fc7ec498f2eb6b9d338440fb54c12d5ac0b9fb7a
diff --git a/virtual/python-pmw/metadata.xml b/virtual/python-pmw/metadata.xml
new file mode 100644
index 000000000000..e24dd86faa2a
--- /dev/null
+++ b/virtual/python-pmw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/virtual/python-pmw/python-pmw-1.ebuild b/virtual/python-pmw/python-pmw-1.ebuild
new file mode 100644
index 000000000000..6339d964df79
--- /dev/null
+++ b/virtual/python-pmw/python-pmw-1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for pmw, for Python 2 & 3"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ~sparc x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pmw:py2[${PYTHON_USEDEP}]' python2*)
+ $(python_gen_cond_dep 'dev-python/pmw:py3[${PYTHON_USEDEP}]' python3*)"