summaryrefslogtreecommitdiff
path: root/virtual/python-dnspython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /virtual/python-dnspython
reinit the tree, so we can have metadata
Diffstat (limited to 'virtual/python-dnspython')
-rw-r--r--virtual/python-dnspython/Manifest4
-rw-r--r--virtual/python-dnspython/metadata.xml8
-rw-r--r--virtual/python-dnspython/python-dnspython-1.ebuild18
-rw-r--r--virtual/python-dnspython/python-dnspython-2.ebuild16
4 files changed, 46 insertions, 0 deletions
diff --git a/virtual/python-dnspython/Manifest b/virtual/python-dnspython/Manifest
new file mode 100644
index 000000000000..c1fa3d0c661b
--- /dev/null
+++ b/virtual/python-dnspython/Manifest
@@ -0,0 +1,4 @@
+EBUILD python-dnspython-1.ebuild 582 SHA256 db2c8281513915ba512df87be0c3b94ce4ee3255aea4cde4cb3333a81234948d SHA512 dfcd360cd7a5367dfe15308c96d0015fe54135095b101df2940281a46fc4845633325c6450e9f558e9f6eb41c7fc291c33020ec20af3da078aa15af13d358465 WHIRLPOOL b24e1df95efaa58f28867fec4841b261bbee70ad52b758194afd7601c8fbb70974d29505ebbfcedbf82249322507fc52920073c3e9d119b080656dc01f3cc164
+EBUILD python-dnspython-2.ebuild 456 SHA256 37b261fe03ae195a1e7362847474fbf55166e1bcfa5570d4dfd7cd2986c7bdd8 SHA512 5ce2c32809bcb242ae11118f20b09acd089b6935cd401577a228141329af709599ddb85c9918a3032d320a2a09e4aa9d9b3e37eccbda1a3861a98f8202b5dc71 WHIRLPOOL 5814a849b7c5c38de34d0de31d6da4a52caa9f2c6d3203c529ffc7b8428034887f79fa795da388115986285eb373ed77b70699d1fda7c4fa5e0128359ec37ff5
+MISC ChangeLog 1783 SHA256 6e15e5d9280b4441d30800e26a300f090a3801b9949ca8915df390fae3df954c SHA512 41a9a5ee8435a6482cb4796293b16ab88f51ba816f1444a7e36dbd5ffbcec6672a79b637e123c01a34bd2cef6fc630c675a6661a0b7ab2837c5857ba8470e50f WHIRLPOOL bae5f7972e8fa1045f706fae36165970f6d7af786502f56e42c5fb76498430168728ad28db8ee6b7e2c3c345ac86561848372a500db0966c27523e746608d089
+MISC metadata.xml 246 SHA256 634432e12556106844e569b7ff16962881c6e70887e6fc9650bdd82deb51a834 SHA512 3245fb694492b2f698fb63aac02e66fb8a94fe35eabda45df4790bec043a1ea552e112315334001902f070093bb73e7b741aa3004757404aed97ebdb86cc9fbc WHIRLPOOL 869ef1c8e23bdae0a11b44ccf38ddec23f0dc0ae2573bc83ccbe2d8a2c6bf5a3f9c3c52149aa2e3690dd66f7fc7ec498f2eb6b9d338440fb54c12d5ac0b9fb7a
diff --git a/virtual/python-dnspython/metadata.xml b/virtual/python-dnspython/metadata.xml
new file mode 100644
index 000000000000..e24dd86faa2a
--- /dev/null
+++ b/virtual/python-dnspython/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/virtual/python-dnspython/python-dnspython-1.ebuild b/virtual/python-dnspython/python-dnspython-1.ebuild
new file mode 100644
index 000000000000..6a16bf1905bf
--- /dev/null
+++ b/virtual/python-dnspython/python-dnspython-1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for dnspython, for Python 2 & 3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !dev-python/dnspython:0
+ $(python_gen_cond_dep 'dev-python/dnspython:py2[${PYTHON_USEDEP}]' python2*)
+ $(python_gen_cond_dep 'dev-python/dnspython:py3[${PYTHON_USEDEP}]' python3*)"
diff --git a/virtual/python-dnspython/python-dnspython-2.ebuild b/virtual/python-dnspython/python-dnspython-2.ebuild
new file mode 100644
index 000000000000..e2f009dc0dda
--- /dev/null
+++ b/virtual/python-dnspython/python-dnspython-2.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for dnspython, for Python 2 & 3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/dnspython-1.15.0:0[${PYTHON_USEDEP}]"