summaryrefslogtreecommitdiff
path: root/sys-process
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-09 18:44:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-09 18:44:29 +0000
commitdc41efad78c64df9b74ed6f94dcf25391b8fc5e1 (patch)
tree0e9943dbba2f7bc3f723f1e68720b1500c61ac94 /sys-process
parent20d4435a7d9459953db77f3256f699f420d3e484 (diff)
gentoo auto-resync : 09:03:2024 - 18:44:28
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/Manifest.gzbin10158 -> 10157 bytes
-rw-r--r--sys-process/fcron/Manifest1
-rw-r--r--sys-process/fcron/fcron-3.3.1-r1.ebuild270
3 files changed, 271 insertions, 0 deletions
diff --git a/sys-process/Manifest.gz b/sys-process/Manifest.gz
index 7ff11174b54f..63b2575c3c2e 100644
--- a/sys-process/Manifest.gz
+++ b/sys-process/Manifest.gz
Binary files differ
diff --git a/sys-process/fcron/Manifest b/sys-process/fcron/Manifest
index 0c5424b0cb0a..1d31653e4a53 100644
--- a/sys-process/fcron/Manifest
+++ b/sys-process/fcron/Manifest
@@ -5,5 +5,6 @@ AUX fcron.confd 134 BLAKE2B 3ab11ae5641f1c2f049da2aec3d1561fa3b10b7fe5d29701e5fb
AUX fcron.init-r5 2633 BLAKE2B 3e3a1991f67f9e9ed2021c8ed0f7442032feb88af89088caad2fd0c090e8c588a8621b45a7b320309065f1a5bef743aa00bf9cb2e531ddb55104ccdba43c9350 SHA512 bf53158d6326a742fc3af0cdf196f76a2930f61e58c8a7f4488d3a17aa18bdbd12a3258034f649ae9998627caec7c55bf4c392265525a8fa7c6614cc38f2d0e0
AUX fcrontab.2 226 BLAKE2B 4fc55d14c44797b1dcc34000de1a9ffa43b1a52037db5dcec76854dfc4c84283dceafdc84f2dec9dfcb95dd5a39d90f31c828b819d29122b2b7b2135f4c65899 SHA512 f0c74c2cd601750f7de8d9926278bd79026b236f2bda4033fe1961c48171b3aa3712bd8d8917f9c784bf0ce54ed09781572cb7e9397d9579a8ba6a114c1e5c2e
DIST fcron-3.3.1.tar.gz 593688 BLAKE2B 5c2f91667c94fc9eae7ae014a7826ab1f26647a192425630dbdb84bbe3c9041be23a2a480eb13844dc18a5ba406fe77a157938af1e0343e5f9b0ce1a1405d66b SHA512 b9c5066bdf8588a6b8d811ccc0d49f1d41a17dabf898a280997a8136dc449c2a505c46868abf732f86184ff0720d51f17442691909acae8fb26edcd180cff281
+EBUILD fcron-3.3.1-r1.ebuild 7107 BLAKE2B 761c47b10b3fd5b7489002801fbf098e06436367769429171a67b860ae05b68b3b20fabcfcc2840594f5cf1ee9e282d2d4df0f570ba7e0c434070574ce46bb6d SHA512 8326af8a9517e8abdc809d591d3f54d513c11d43cc81cb8e9ff560f15d85538683fdfc725fe6b7c272ff5110f73ccefb63ec0dc01308acb1cec103dffde1e175
EBUILD fcron-3.3.1.ebuild 7101 BLAKE2B d2409d9e57c0e72ca07570dc8b2c2a91e3bf96a9c5fbcfa084a6c0869c3ab12ec383ae2dbe22760da10b097094055fdae3ee7683ae5680b68307cf588a78ae93 SHA512 0c10264d08f3cad45862f1127ae0dcc2ce409fa73b8acb38d32c17287d7d74af1d8aa51bb051b5892254c9f547862943c7158079b69d332ecf2bdf6c37a0fbd0
MISC metadata.xml 1320 BLAKE2B 169511184222d072788a2f66e329a149147d91003767e0c2a9a88db1d71a4c809b828563e2296960f132db96d4fe46996dbecdbb5e6badb3ec72d9998e111ad0 SHA512 6becadb18f88e7601111bace913a59e37c9337a4fea7442511872da351a03a7751fe38caa1eb5872a16d67069cba5a04388fe5c872dd2cfa79342fdb9f42ac7c
diff --git a/sys-process/fcron/fcron-3.3.1-r1.ebuild b/sys-process/fcron/fcron-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..ef7b9af05781
--- /dev/null
+++ b/sys-process/fcron/fcron-3.3.1-r1.ebuild
@@ -0,0 +1,270 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WANT_AUTOMAKE="none"
+
+inherit autotools cron flag-o-matic pam systemd user-info
+
+MY_PV="${PV/_beta/}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A command scheduler with extended capabilities over cron and anacron"
+HOMEPAGE="http://fcron.free.fr/"
+SRC_URI="http://fcron.free.fr/archives/${MY_P}.src.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="audit debug pam selinux l10n_fr +mta +system-crontab readline"
+
+DEPEND="
+ acct-group/fcron
+ acct-user/fcron
+ virtual/libcrypt:=
+ audit? ( sys-process/audit )
+ pam? ( sys-libs/pam )
+ readline? ( sys-libs/readline:= )
+ selinux? ( sys-libs/libselinux )
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-misc/editor-wrapper
+ mta? ( virtual/mta )
+ pam? ( sys-auth/pambase )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-noreadline.patch
+ "${FILESDIR}"/${PN}-3.2.1-musl-getopt-order.patch
+)
+
+pkg_setup() {
+ rootuser=$(egetent passwd 0 | cut -d ':' -f 1)
+ [[ ${rootuser} ]] || rootuser=root
+ rootgroup=$(egetent group 0 | cut -d ':' -f 1)
+ [[ ${rootgroup} ]] || rootgroup=root
+}
+
+src_prepare() {
+ default
+
+ # respect LDFLAGS
+ sed "s:\(@LIBS@\):\$(LDFLAGS) \1:" -i Makefile.in || die "sed failed"
+
+ # Adjust fcrontab path
+ sed -e 's:/etc/fcrontab:/etc/fcron/fcrontab:' -i script/check_system_crontabs.sh || die
+
+ mv configure.in configure.ac || die
+
+ cp "${FILESDIR}"/crontab.2 "${WORKDIR}"/crontab || die
+
+ eautoconf
+}
+
+src_configure() {
+ # Don't try to pass --with-debug as it'll play with cflags as
+ # well, and run foreground which is a _very_ nasty idea for
+ # Gentoo.
+ use debug && append-cppflags -DDEBUG
+
+ # bindir is used just for calling fcronsighup
+ local myeconfargs=(
+ --with-cflags="${CFLAGS}"
+ --bindir=/usr/libexec
+ --sbindir=/usr/libexec
+ $(use_with audit)
+ $(use_with mta sendmail)
+ $(use_with pam)
+ $(use_with readline)
+ $(use_with selinux)
+ --sysconfdir=/etc/fcron
+ --with-username=fcron
+ --with-groupname=fcron
+ --with-piddir=/run
+ --with-spooldir=/var/spool/fcron
+ --with-fifodir=/run
+ --with-fcrondyn=yes
+ --disable-checks
+ --with-editor=/usr/libexec/editor
+ --with-shell=/bin/sh
+ --without-db2man
+ --without-dsssl-dir
+ --with-rootname=${rootuser}
+ --with-rootgroup=${rootgroup}
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ # bug #216460
+ sed \
+ -e 's:/usr/local/etc/fcron:/etc/fcron/fcron:g' \
+ -e 's:/usr/local/etc:/etc:g' \
+ -e 's:/usr/local/:/usr/:g' \
+ -i doc/*/*/*.{txt,1,5,8,html} \
+ || die "unable to fix documentation references"
+}
+
+src_install() {
+ keepdir /var/spool/fcron
+
+ exeinto /usr/libexec
+ doexe fcron fcronsighup
+
+ dobin fcrondyn fcrontab
+
+ insinto /etc/fcron
+ doins files/fcron.{allow,deny,conf}
+
+ if use system-crontab; then
+ dosym fcrontab /usr/bin/crontab
+
+ exeinto /usr/libexec
+ newexe script/check_system_crontabs.sh check_system_crontabs
+
+ insinto /etc/fcron
+ newins "${FILESDIR}"/fcrontab.2 fcrontab
+
+ fowners ${rootuser}:fcron /etc/fcron/fcrontab
+ fperms 0640 /etc/fcron/fcrontab
+
+ insinto /etc
+ newins "${FILESDIR}"/crontab.2 crontab
+ fi
+
+ fowners fcron:fcron \
+ /var/spool/fcron \
+ /usr/bin/fcron{dyn,tab}
+
+ # fcronsighup needs to be suid root, because it sends a HUP to the
+ # running fcron daemon, but only has to be called by the fcron group
+ # anyway
+ fowners ${rootuser}:fcron \
+ /usr/libexec/fcronsighup \
+ /etc/fcron/fcron.{allow,deny,conf} \
+ /etc/fcron
+
+ fperms 6770 /var/spool/fcron
+ fperms 6755 /usr/bin/fcron{dyn,tab}
+
+ fperms 4710 /usr/libexec/fcronsighup
+
+ fperms 0750 /etc/fcron
+ fperms 0640 /etc/fcron/fcron.{allow,deny,conf}
+
+ use pam && pamd_mimic system-services fcron auth account session
+ cat > "${T}"/fcrontab.pam <<- EOF
+ # Don't ask for the user's password; fcrontab will only allow to
+ # change user if running as root.
+ auth sufficient pam_permit.so
+
+ # Still use the system-auth stack for account and session as the
+ # sysadmin might have set up stuff properly, and also avoids
+ # sidestepping limits (since fcrontab will run \$EDITOR).
+ account include system-auth
+ session include system-auth
+ EOF
+ use pam && newpamd "${T}"/fcrontab.pam fcrontab
+
+ newinitd "${FILESDIR}"/fcron.init-r5 fcron
+ systemd_newunit "${S}/script/fcron.init.systemd" fcron.service
+
+ newconfd "${FILESDIR}"/fcron.confd fcron
+
+ local DOCS=( MANIFEST VERSION "${WORKDIR}/crontab")
+ DOCS+=( doc/en/txt/{readme,thanks,faq,todo,relnotes,changes}.txt )
+
+ local HTML_DOCS=( doc/en/HTML/. )
+
+ einstalldocs
+
+ newdoc files/fcron.conf fcron.conf.sample
+ doman doc/en/man/*.{1,5,8}
+
+ for lang in fr; do
+ use l10n_${lang} || continue
+
+ doman -i18n=${lang} doc/${lang}/man/*.{1,5,8}
+
+ docinto html/${lang}
+ dodoc -r doc/${lang}/HTML/.
+ done
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "Make sure you execute"
+ elog ""
+ elog " # emerge --config ${CATEGORY}/${PN}"
+ elog ""
+ elog "to install the default systab on this system."
+ else
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "3.2.1" -gt ${v}; then
+ # This is an upgrade
+
+ elog "fcron's default systab was updated since your last installation."
+ elog "You can use"
+ elog ""
+ elog " # emerge --config ${CATEGORY}/${PN}"
+ elog ""
+ elog "to re-install systab (do not call this command before you"
+ elog "have merged your configuration files)."
+
+ # Show this elog only once
+ break
+ fi
+ done
+ fi
+
+ if ! use system-crontab; then
+ echo ""
+ ewarn "Remember that fcron will *not* use /etc/cron.d in this configuration"
+ ewarn "due to USE=-system-crontab!"
+ echo ""
+ fi
+}
+
+pkg_config() {
+ if [[ $(fcrontab -l -u systab 2>/dev/null) ]]; then
+ eerror "We're not going to make any change to your systab as long as"
+ eerror "it contains data; please clear it before proceeding."
+ eerror "You can do that with"
+ eerror ""
+ eerror " # fcrontab -u systab -r"
+ eerror ""
+ eerror "However you are advised to do this by hand to review existing"
+ eerror "systab just in case."
+ return 1
+ fi
+
+ if use system-crontab; then
+ elog "This is going to set up fcron to execute check_system_crontabs."
+ elog "In this configuration, /etc/crontab and /etc/cron.d are respected."
+ elog "Per default fcron will check for modifications every 10 minutes."
+ /usr/libexec/check_system_crontabs -v -i -f
+ else
+ elog "This is going to set up fcron to set up a default systab that"
+ elog "executes /etc/cron.{hourly,daily,weekly,monthly} but will ignore"
+ elog "/etc/crontab and /etc/cron.d."
+ fcrontab -u systab - <<- EOF
+ !serial(true)
+ 00 * * * * /bin/rm -f /var/spool/cron/lastrun/cron.hourly
+ 00 00 * * * /bin/rm -f /var/spool/cron/lastrun/cron.daily
+ 00 00 * * 6 /bin/rm -f /var/spool/cron/lastrun/cron.weekly
+ 00 00 1 * * /bin/rm -f /var/spool/cron/lastrun/cron.monthly
+ */10 * * * * /usr/bin/test -x /usr/sbin/run-crons && /usr/sbin/run-crons
+ !serial(false)
+ EOF
+ fi
+}