summaryrefslogtreecommitdiff
path: root/sys-process
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-10 02:01:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-10 02:01:16 +0000
commit59437d191de3ff33f9bfa37f8656d849184fcaf0 (patch)
tree7d5e645c0aac6d8b71229a0e53d7a93136f83781 /sys-process
parent1a95f960273f276a4fdefb824336b073d83bcb5e (diff)
gentoo auto-resync : 10:12:2024 - 02:01:16
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/Manifest.gzbin10127 -> 10130 bytes
-rw-r--r--sys-process/runit/Manifest2
-rw-r--r--sys-process/runit/runit-2.2.0.ebuild148
3 files changed, 150 insertions, 0 deletions
diff --git a/sys-process/Manifest.gz b/sys-process/Manifest.gz
index 642548652788..5a28aa7b616e 100644
--- a/sys-process/Manifest.gz
+++ b/sys-process/Manifest.gz
Binary files differ
diff --git a/sys-process/runit/Manifest b/sys-process/runit/Manifest
index d58a4077f26e..64983d034345 100644
--- a/sys-process/runit/Manifest
+++ b/sys-process/runit/Manifest
@@ -6,5 +6,7 @@ AUX finish.getty 30 BLAKE2B 97dec53a513713c68febd68177227e165ed3bdee28d3db4f57b6
AUX run.getty-2.1.2 44 BLAKE2B 38b80fc06bb53a06a6dd2ebeb6f5c320c73c9d3e928c5dbfeaad2fa0a19e1bdeaa28cf6fe61fcdd46406c0f1f4a05113b8b2cdb652bcac3d6560e0af0f5d521c SHA512 c23aa0ba79043a5717e5567f39bb714154f68c1e417538013943a65de5584b775c265423dd5d47c52027a1be1621f8fb017b115d75d127a31b2ef7cae3ed9eea
DIST runit-2.1.2-patches-20240905.tar.xz 20104 BLAKE2B ebdc123ea722f223eec3ad5d63a4c3e7c4ef771592796f2d5624f4308c1d08eede7d4fa0c2a9fdd23dbf74be6135c69bae495d89cf582678b9308b1d146ef883 SHA512 15c5acd865ecc7f6c3b9b1fc94dc00bc44ceefd1c0ca6b53963d94338712cd716ad961826cccd065029ee67464dc288428952004ffcec3a1a97a058696f4f233
DIST runit-2.1.2.tar.gz 110916 BLAKE2B 101e514aeed282685ebe636f401ca6f94d157281d08a3ac487340aebe945b82d2ee01d41e9917446f4ebd7b27fe9fd18ba4ad55739ab1b62a0e59e1c438b55e9 SHA512 a18773ebf1aa22305dd89ed67363165b9fcf86c192b2be4e268d08005dd82d51265160c637abe072f2f2e378c4b315a75bd3d3e602c3e75bdd451a3b0190f8cf
+DIST runit-2.2.0.tar.gz 111395 BLAKE2B 46a4b91cf180694a69ade3cabaddb35a89db516ef75e9fc69b8091a5c3570079796b8a4cf227edc74938e182833edcce7af40f01d5cb1b4032993fb094459ede SHA512 cedfe6d3505aca754ff11d791055f023a7be42e2fbdd2e4964b3460692474371a72363cf181ae2dfae5c02df45ebf568cdab72a5000d1b48e26e12217d4e9a3d
EBUILD runit-2.1.2-r6.ebuild 4031 BLAKE2B d586e83e00e5ba847869b56b41115efaaf9bbd7133f63bf821e55a925abdd914298c385aaf806b3c8c4a8df753d98465085bb611b675b91b68db5b5f93b7c6dc SHA512 b37426225e9616c15902824b7a2936993d0a636b6c30c2831707a527f5ba9f486f3720de97274052877ada05fcc17652fb01cf345f51699fc1b74190620d4152
+EBUILD runit-2.2.0.ebuild 3907 BLAKE2B aeae7a3f383ee869acf5ad21b60d675043591bdd7c915902145b24bea4ba409003525e2ebe709539ad80f940f997fe938dd555e16ccf797818af8cb056211543 SHA512 a6f1705fc82cf5bd71a87fe64b549a818672878cdcda93384cf1e29809f802f8d0edcb3c4b80094207d6669504f281ad189ef0bc57b12742f9790bafefb200cd
MISC metadata.xml 480 BLAKE2B 03c67b9377e4dae4a777b363e128fc758cbd92d0ed6060d1036a6209184d518d59d6a98bfc731e0fa95151c0925195a1c512c2cfe46ddba1c964b66510f3bbba SHA512 71d359e43329f0b0561f01b132067c359e70af27868cc586beb96d5b9a0a1661eb122e0afcf90c5fb4f713b1e25d5e8072e4618143702bc1be063f2e194b211a
diff --git a/sys-process/runit/runit-2.2.0.ebuild b/sys-process/runit/runit-2.2.0.ebuild
new file mode 100644
index 000000000000..f4f1af1d4246
--- /dev/null
+++ b/sys-process/runit/runit-2.2.0.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A UNIX init scheme with service supervision"
+HOMEPAGE="https://smarden.org/runit/"
+PATCH_VER=20240905
+SRC_URI="
+ https://smarden.org/runit/${P}.tar.gz
+"
+S=${WORKDIR}/admin/${P}/src
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="split-usr static"
+
+RDEPEND="sys-apps/openrc"
+
+src_prepare() {
+ default
+
+ cd "${S}" || die
+
+ # We either build everything or nothing static
+ sed -i -e 's:-static: :' Makefile || die
+
+ # see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=726008
+ [[ ${COMPILER} == "diet" ]] &&
+ use ppc &&
+ filter-flags "-mpowerpc-gpopt"
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
+ sed -i -e "s:ar cr:$(tc-getAR) cr:" print-ar.sh || die
+ sed -i -e "s:ranlib :$(tc-getRANLIB) :" print-ar.sh || die
+}
+
+src_install() {
+ local ver_runit_cfg="2.1.2" # use files from 2.1.2
+
+ dobin $(<../package/commands)
+ dodir /sbin
+ mv "${ED}"/usr/bin/{runit-init,runit,utmpset} "${ED}"/sbin/ || die "dosbin"
+ if use split-usr ; then
+ dosym ../etc/runit/2 /sbin/runsvdir-start
+ else
+ dosym ../../etc/runit/2 /sbin/runsvdir-start
+ fi
+
+ DOCS=( ../package/{CHANGES,README,THANKS} )
+ HTML_DOCS=( ../doc/*.html )
+ einstalldocs
+ doman ../man/*.[18]
+
+ exeinto /etc/runit
+ doexe "${FILESDIR}"/ctrlaltdel
+ newexe "${FILESDIR}"/1-${ver_runit_cfg} 1
+ newexe "${FILESDIR}"/2-${ver_runit_cfg} 2
+ newexe "${FILESDIR}"/3-${ver_runit_cfg} 3
+
+ dodir /etc/sv
+ for tty in tty1 tty2 tty3 tty4 tty5 tty6; do
+ exeinto /etc/sv/getty-$tty/
+ newexe "${FILESDIR}"/finish.getty finish
+ newexe "${FILESDIR}"/run.getty-${ver_runit_cfg} run
+ for script in finish run; do
+ sed -i -e "s:TTY:${tty}:g" "${ED}"/etc/sv/getty-$tty/$script
+ done
+ done
+
+ # make sv command work
+ newenvd - 20runit <<- EOF
+ #/etc/env.d/20runit
+ SVDIR="/etc/service/"
+ EOF
+}
+
+default_config() {
+ local sv="${EROOT}"/etc/sv
+ local service="${EROOT}"/etc/service
+ mkdir -p "${service}" || die
+ for x in tty1 tty2 tty3 tty4 tty5 tty6; do
+ ln -sf "${sv}"/getty-$x "${service}"/getty-$x || die
+ done
+ einfo "The links to services runit will supervise are installed"
+ einfo "in $service."
+ einfo "If you need multiple runlevels, please see the documentation"
+ einfo "for how to set them up."
+ einfo
+}
+
+migrate_from_211() {
+ # Create /etc/service and /var/service if requested
+ if [[ -e "${T}"/make_var_service ]]; then
+ ln -sf "${EROOT}"/etc/runit/runsvdir/current "${EROOT}"/etc/service || die
+ ln -sf "${EROOT}"/etc/runit/runsvdir/current "${EROOT}"/var/service || die
+ fi
+ if [[ -d "${T}"/runsvdir ]]; then
+ cp -a "${T}"/runsvdir "${EROOT}"/etc/runit || die
+ fi
+ return 0
+}
+
+pkg_preinst() {
+ if has_version '<sys-process/runit-2.1.2'; then
+ pre_212=yes
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ default_config
+ elif [[ -n ${pre_212} ]]; then
+ migrate_from_211
+ fi
+
+ ewarn "To make sure sv works correctly in your currently open"
+ ewarn "shells, please run the following command:"
+ ewarn
+ ewarn "source /etc/profile"
+ ewarn
+
+ if [[ -L "${EROOT}"/var/service ]]; then
+ ewarn "Once this version of runit is active, please remove the"
+ ewarn "compatibility symbolic link at ${EROOT}/var/service"
+ ewarn "The correct path now is ${EROOT}/etc/service"
+ ewarn
+ fi
+
+ if [[ -L "${EROOT}"/etc/runit/runsvdir/all ]]; then
+ ewarn "${EROOT}/etc/runit/runsvdir/all has moved to"
+ ewarn "${EROOT}/etc/sv."
+ ewarn "Any symbolic links under ${EROOT}/etc/runit/runsvdir"
+ ewarn "which point to services through ../all should be updated to"
+ ewarn "point to them through ${EROOT}/etc/sv."
+ ewarn "Once that is done, ${EROOT}/etc/runit/runsvdir/all should be"
+ ewarn "removed."
+ ewarn
+ fi
+}