summaryrefslogtreecommitdiff
path: root/sys-process/uksmd/uksmd-0_pre20190726.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /sys-process/uksmd/uksmd-0_pre20190726.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'sys-process/uksmd/uksmd-0_pre20190726.ebuild')
-rw-r--r--sys-process/uksmd/uksmd-0_pre20190726.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-process/uksmd/uksmd-0_pre20190726.ebuild b/sys-process/uksmd/uksmd-0_pre20190726.ebuild
new file mode 100644
index 000000000000..d0007f9ba410
--- /dev/null
+++ b/sys-process/uksmd/uksmd-0_pre20190726.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+MY_COMMIT="42f4ff8eb09011bf1a199938aa2afe23040d7faf"
+MY_P="${PN}-${MY_COMMIT}"
+
+DESCRIPTION="Userspace KSM helper daemon"
+HOMEPAGE="https://gitlab.com/post-factum/uksmd"
+SRC_URI="https://gitlab.com/post-factum/uksmd/-/archive/${MY_COMMIT}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-kernel/pf-sources:*
+ sys-process/procps"
+
+CONFIG_CHECK="KSM"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/${P}-respect-cflags-ldflags.patch" )
+
+src_install() {
+ default
+ einstalldocs
+
+ newinitd "${FILESDIR}/uksmd.init" uksmd
+ systemd_dounit distro/uksmd.service
+}