summaryrefslogtreecommitdiff
path: root/sys-process/tini/tini-0.18.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /sys-process/tini/tini-0.18.0.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'sys-process/tini/tini-0.18.0.ebuild')
-rw-r--r--sys-process/tini/tini-0.18.0.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/sys-process/tini/tini-0.18.0.ebuild b/sys-process/tini/tini-0.18.0.ebuild
index 6055c7e98a14..9650f2b376b0 100644
--- a/sys-process/tini/tini-0.18.0.ebuild
+++ b/sys-process/tini/tini-0.18.0.ebuild
@@ -17,8 +17,20 @@ IUSE="+args +static"
src_prepare() {
cmake-utils_src_prepare
- # Do not strip binary
- sed -i -e 's/-Wl,-s")$/")/' \
+
+ local sed_args=(
+ # Do not strip binary
+ -e 's/-Wl,-s")$/")/'
+
+ # Remove -Werror and -pedantic-errors in order to allow macro
+ # redefinition, so that CFLAGS="-U_FORTIFY_SOURCE" does not
+ # trigger an error due to add_definitions(-D_FORTIFY_SOURCE=2)
+ # in CMakeLists.txt (bug 626438).
+ -e "s/ -Werror / /"
+ -e "s/ -pedantic-errors / /"
+ )
+
+ sed -i "${sed_args[@]}" \
-e "s/git.*status --porcelain.*/true/" \
-e "s/git.*log -n 1.*/true/" \
-e "s/git.\${tini_VERSION_GIT}/git.${GIT_COMMIT}/" \