summaryrefslogtreecommitdiff
path: root/sys-process/time
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
commit81b8f20732954c4508baf2f77472b5435e3f851f (patch)
tree4180177cb7ba85eab50159ce96218c2419fb24a6 /sys-process/time
parent946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (diff)
gentoo auto-resync : 14:09:2022 - 11:10:10
Diffstat (limited to 'sys-process/time')
-rw-r--r--sys-process/time/Manifest2
-rw-r--r--sys-process/time/files/time-1.9-implicit-func-decl-clang.patch24
-rw-r--r--sys-process/time/time-1.9-r1.ebuild18
3 files changed, 44 insertions, 0 deletions
diff --git a/sys-process/time/Manifest b/sys-process/time/Manifest
index 5dd6bca8399e..ba1d68f70331 100644
--- a/sys-process/time/Manifest
+++ b/sys-process/time/Manifest
@@ -1,3 +1,5 @@
+AUX time-1.9-implicit-func-decl-clang.patch 745 BLAKE2B 1c57ebd35cec042680f9b8e2751793ff93471be80f6773be20b650e6e43c76a1d8f2f7485aa89622398f500e65d2cb5c3702ece3d55c0a6acfce73cbbf63268f SHA512 571ae944f112ca54273f88f6c9e0b932c67944412195dddc6b52c415ba741239413056fe4125f8250a0ebff0bc4fe657653a3a2f4b92228b0d0d1e845b466e49
DIST time-1.9.tar.gz 596779 BLAKE2B b48c2def2f7aaa79ddb8838ed9e103dd7b1b573b6084d1481838cac86eb7930b3a231469936ad23d5096e576ea728e821defb27fc8b3f9187809e3f5c01b7c57 SHA512 5c6dabbbe71e9103a47b892b86bb914c1704122d4fe7dff1e2cbd28503297163118d295077d8e062b035d673a1f91c36f8a45c7383f374fd766942b32bde4406
+EBUILD time-1.9-r1.ebuild 520 BLAKE2B 46b4298a003a94a3f88ed9272f4543bc9ba1742dfa46d4ea2924b6c33221b4beec38ff59cff1cf3af52073b213db47e7638e29790b2215b62936c870aa5181f9 SHA512 c4a6847d262b10058fbfb07167890c108c38185abe1a014872deca3e60351e509b07477ed9a188e2b3b299b07b6a6063064115cc5dc8db1a6a28c2330f9bd16d
EBUILD time-1.9.ebuild 443 BLAKE2B 5b0dd86e6a9d102788dc07aaa993aab1eb72e6ada84aaca2318969e81747bbae9976c4e712571f73bdc3e80150409a1fef86e34301e3f1ae4912b22e14ea09e5 SHA512 9b000d7bb73f3bf656ea243302aed03d36f199cae28779f19b28b180fbf00f730e80c8cf2450559b3473b9492ebdf109ff8147ea1c6c865991908b15423816e3
MISC metadata.xml 258 BLAKE2B b3ebb9691cf2c860b26172c2fc7ead843959a83806b7c06f4eec2ea349a6d2f39afe2f4b08c09bc7f65d18bece520b8b6306c8c7c2075d653f04b09af43db8fd SHA512 02ab38ca1547c68e87cbcad1dd4bb121e90d1fcca941cbfd29583ea803ed50617aa6a29df11915af5e95d63fc817df2250c7b8189157d705ef86e477d6a1685e
diff --git a/sys-process/time/files/time-1.9-implicit-func-decl-clang.patch b/sys-process/time/files/time-1.9-implicit-func-decl-clang.patch
new file mode 100644
index 000000000000..ca76b5a50050
--- /dev/null
+++ b/sys-process/time/files/time-1.9-implicit-func-decl-clang.patch
@@ -0,0 +1,24 @@
+https://lists.gnu.org/archive/html/bug-time/2022-08/msg00001.html
+
+From c8deae54f92d636878097063b411af9fb5262ad3 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 15 Aug 2022 07:24:24 -0700
+Subject: [PATCH] include string.h for memset()
+
+Fixes implicit function declaration warning e.g.
+
+resuse.c:103:3: error: call to undeclared library function 'memset' with type 'void *(void *, int, unsigned long)'
+
+Upstream-Status: Submitted [https://lists.gnu.org/archive/html/bug-time/2022-08/msg00001.html]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/src/resuse.c
++++ b/src/resuse.c
+@@ -22,6 +22,7 @@
+ */
+
+ #include "config.h"
++#include <string.h>
+ #include <sys/time.h>
+ #include <sys/wait.h>
+ #include <sys/resource.h>
+
diff --git a/sys-process/time/time-1.9-r1.ebuild b/sys-process/time/time-1.9-r1.ebuild
new file mode 100644
index 000000000000..30f7e998ff2a
--- /dev/null
+++ b/sys-process/time/time-1.9-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Displays info about resources used by a program"
+HOMEPAGE="https://www.gnu.org/directory/time.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="sys-apps/texinfo"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9-implicit-func-decl-clang.patch
+)