summaryrefslogtreecommitdiff
path: root/sys-process/time/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-process/time/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-process/time/files')
-rw-r--r--sys-process/time/files/1.7-info-dir-entry.patch12
-rw-r--r--sys-process/time/files/time-1.7-build.patch16
-rw-r--r--sys-process/time/files/time-1.7-incorrect_memory_usage.patch26
-rw-r--r--sys-process/time/files/time-1.7.2-incorrect_memory_usage.patch29
4 files changed, 83 insertions, 0 deletions
diff --git a/sys-process/time/files/1.7-info-dir-entry.patch b/sys-process/time/files/1.7-info-dir-entry.patch
new file mode 100644
index 000000000000..eb30029722bb
--- /dev/null
+++ b/sys-process/time/files/1.7-info-dir-entry.patch
@@ -0,0 +1,12 @@
+--- a/time.info
++++ b/time.info
+@@ -19,6 +19,9 @@
+ manual into another language, under the above conditions for modified
+ versions, except that this permission notice may be stated in a
+ translation approved by the Foundation.
++START-INFO-DIR-ENTRY
++* time: (time). summarize system resources used
++END-INFO-DIR-ENTRY
+
+ 
+ File: time.info, Node: Top, Prev: (dir), Up: (dir)
diff --git a/sys-process/time/files/time-1.7-build.patch b/sys-process/time/files/time-1.7-build.patch
new file mode 100644
index 000000000000..504643d768e5
--- /dev/null
+++ b/sys-process/time/files/time-1.7-build.patch
@@ -0,0 +1,16 @@
+--- a/configure.in
++++ b/configure.in
+@@ -1,11 +1,6 @@
+ dnl Process this file with autoconf to produce a configure script.
+-AC_INIT(time.c)
+-VERSION=1.7
+-AC_SUBST(VERSION)
+-PACKAGE=time
+-AC_SUBST(PACKAGE)
+-
+-AC_ARG_PROGRAM
++AC_INIT(time, 1.7)
++AM_INIT_AUTOMAKE
+
+ dnl Checks for programs.
+ AC_PROG_CC
diff --git a/sys-process/time/files/time-1.7-incorrect_memory_usage.patch b/sys-process/time/files/time-1.7-incorrect_memory_usage.patch
new file mode 100644
index 000000000000..ab1f4ddfbd5e
--- /dev/null
+++ b/sys-process/time/files/time-1.7-incorrect_memory_usage.patch
@@ -0,0 +1,26 @@
+https://bugs.launchpad.net/ubuntu/+source/time/+bug/742248
+https://bugs.gentoo.org/332253
+
+--- time-1.7/ChangeLog
++++ time-1.7/ChangeLog
+@@ -1,3 +1,9 @@
++Fri Oct 1 00:00:00 2010 Bob Proulx <bob@proulx.com>
++ The struct rusage reports ru_maxrss in kbytes not pages and
++ should not be converted through pages-to-kbytes again.
++ Reported by Sven Hartrumpf.
++ * time.c (summarize): Do not call ptok on ru_maxrss.
++
+ Thu Jul 11 12:37:17 1996 David J MacKenzie <djm@catapult.va.pubnix.com>
+
+ * Version 1.7.
+--- time-1.7/time.c
++++ time-1.7/time.c
+@@ -398,7 +398,7 @@ summarize (fp, fmt, command, resp)
+ ptok ((UL) resp->ru.ru_ixrss) / MSEC_TO_TICKS (v));
+ break;
+ case 'M': /* Maximum resident set size. */
+- fprintf (fp, "%lu", ptok ((UL) resp->ru.ru_maxrss));
++ fprintf (fp, "%lu", (UL) resp->ru.ru_maxrss);
+ break;
+ case 'O': /* Outputs. */
+ fprintf (fp, "%ld", resp->ru.ru_oublock);
diff --git a/sys-process/time/files/time-1.7.2-incorrect_memory_usage.patch b/sys-process/time/files/time-1.7.2-incorrect_memory_usage.patch
new file mode 100644
index 000000000000..6c83f0bb9264
--- /dev/null
+++ b/sys-process/time/files/time-1.7.2-incorrect_memory_usage.patch
@@ -0,0 +1,29 @@
+https://bugs.launchpad.net/ubuntu/+source/time/+bug/742248
+https://bugs.gentoo.org/332253
+
+--- time-1.7.2/ChangeLog
++++ time-1.7.2/ChangeLog
+@@ -1,6 +1,12 @@
+ Fri Dec 21 23:00:00 2012 David C Niemi <gnutime@dcn.tuxers.net>
+ * Version 1.7.1.
+
++Fri Oct 1 00:00:00 2010 Bob Proulx <bob@proulx.com>
++ * time.c (summarize): Do not call ptok on ru_maxrss.
++ The struct rusage reports ru_maxrss in kbytes not pages and
++ should not be converted through pages-to-kbytes again.
++ Reported by Sven Hartrumpf.
++
+ Thu Jul 11 12:37:17 1996 David J MacKenzie <djm@catapult.va.pubnix.com>
+
+ * Version 1.7.
+--- time-1.7.2/time.c
++++ time-1.7.2/time.c
+@@ -394,7 +394,7 @@
+ ptok ((UL) resp->ru.ru_ixrss) / MSEC_TO_TICKS (v));
+ break;
+ case 'M': /* Maximum resident set size. */
+- fprintf (fp, "%lu", ptok ((UL) resp->ru.ru_maxrss));
++ fprintf (fp, "%lu", (UL) resp->ru.ru_maxrss);
+ break;
+ case 'O': /* Outputs. */
+ fprintf (fp, "%ld", resp->ru.ru_oublock);