summaryrefslogtreecommitdiff
path: root/sys-process/systemd-cron
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-15 21:27:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-15 21:27:56 +0100
commit3648761f2708fcf5662ea1b9585f594c36eefc30 (patch)
tree7b8af3caaff06cdddb5c39ec135ecc908b62a139 /sys-process/systemd-cron
parent4214d835b45f0047c644e43c7fa70f1bbdb2e8b3 (diff)
gentoo auto-resync : 15:08:2023 - 21:27:55
Diffstat (limited to 'sys-process/systemd-cron')
-rw-r--r--sys-process/systemd-cron/Manifest2
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.16.7.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-process/systemd-cron/Manifest b/sys-process/systemd-cron/Manifest
index 1a066a939ddf..c20d53c4e22f 100644
--- a/sys-process/systemd-cron/Manifest
+++ b/sys-process/systemd-cron/Manifest
@@ -1,6 +1,8 @@
AUX systemd-cron-1.15.19-default-mail-user.patch 853 BLAKE2B a6ba1e178995e92dfe9fbc4dfbfdae3a4f5545c97c4da9a0e66976953049ab789fbad57e8b8ce989bff2b1b64f422923b3078eafe68bab506223288462652798 SHA512 7c72ba576249eee46fa29a464059ce345729ae158a5bf5fe08bc04062b321a8dfaaa1bd383c1295382ceca8122c47283685add5027f19bdadfc82b3e1c1faeb5
DIST systemd-cron-1.15.19.tar.gz 33234 BLAKE2B d03c7024f9e4e569086e60908b07255e59259bc90182e34897746e1477e1b59da1934f239ef7c673e5df52c1831f07b2e759aeb7c514ba23dbbbeb780cb08a7b SHA512 90ddb3584550714a21e88a89e804511af434432b95398f325f547ee226499f8b73e153b9cdb611a11389baf434d12bc39414244b0e5e1d4565ceaac5db12b012
DIST systemd-cron-1.15.20.tar.gz 33384 BLAKE2B 1e048009d19eb9e40a96ab7dee509975387f1634805c7c428065e720332d10665b6d5662a961304acf59cc688d99afc514500aa829fa2c71f296fc04503419fd SHA512 814a639bd3a06b1c4aa5dbc449c29812e94ad7ed27bff26618637e305bf03800527c1242eb5343cea89aa1345b203c709fbdcd251905009f19c254ab25244bcf
+DIST systemd-cron-1.16.7.tar.gz 37887 BLAKE2B a900058cef1cd02ac464d3ecdd43ce2f264bdba386f349ef82f0a915104302b1e88d94331d5fbaabe2c54f526900f3e1ac65ea6bdc2f27a6464e6d7514561a19 SHA512 d65d641fd449cdc0e91db3ae6ebe464bc4e24027c501b30a8ab17e7cc40de290cc6141bfb7880a724d97248861587e6f5fea113a6aa6e468d971aff3a13b056f
EBUILD systemd-cron-1.15.19-r1.ebuild 2646 BLAKE2B e42edaa6de87527bdc3e25db680a8d1e236e36e56f755cc27407fe1ca5fdf9040db15c904d6971c50a2219129988c5c1c20c719c3b714ed4969d79d19a4b365c SHA512 c07aa1c2059f2709ae6e10de145714565848a2ff7f75adaa365c00ea90c5105ebaaf5d66aced16f6b267273c5e5e2b95aade1a07d3bacc3d049d0f235309d546
EBUILD systemd-cron-1.15.20.ebuild 2566 BLAKE2B 80dbeb713766dba8ef75d4765beed90a78c48913754b8710c1e1a174cfce7a70b39b2bf1baf71115fd81dba86693a914e85a23809781396f285443f40be11b8c SHA512 1b929cf3912280aa354e013a6dbd080664459f638c945e3bcc1e358c3ffa0cf2cd09b4a113c6911573b1bc2e04b2f2be682b63d3e04ef05febf86e81019bf961
+EBUILD systemd-cron-1.16.7.ebuild 2573 BLAKE2B a3f79dcb0227e9e407e699a7d5a5ae35249652371fca55f92d368c3b0c31ac41aa1e4d85d84ec238191401913690416bce7c5f0942174998b47746b60ebc6ed5 SHA512 c7c66aee2b19a282347e9e47b5f029b2fca0713521dbd90053068f4ad69b382a9986506931885b4cd3cbd1eb6607e052759003854c70245c6877272df7aad22d
MISC metadata.xml 801 BLAKE2B 8ac1580d5dae701d11c893bc7d9990b8a0c023c148b9fb7a945ba7f12429dd4a2abc78331f659831fa26b5f5c570919156848c3ebcd4df7ea050fdc50272f43c SHA512 1c7e77f04d294fc51de86b07f63c9163468dcb321d14c8447c61a4a0a7f99efc438d6ae1ffe315cf148377c2ac5e038afcc93f68516b11ca5eb066f8b186bcef
diff --git a/sys-process/systemd-cron/systemd-cron-1.16.7.ebuild b/sys-process/systemd-cron/systemd-cron-1.16.7.ebuild
new file mode 100644
index 000000000000..2498aab65d88
--- /dev/null
+++ b/sys-process/systemd-cron/systemd-cron-1.16.7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+inherit python-single-r1 systemd
+
+DESCRIPTION="systemd units to create timers for cron directories and crontab"
+HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
+SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cron-boot etc-crontab-systemd minutely +runparts setgid test yearly"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=sys-apps/systemd-217
+ sys-apps/debianutils
+ !sys-process/cronie[anacron]
+ !etc-crontab-systemd? ( !sys-process/dcron )
+ ${PYTHON_DEPS}
+ sys-process/cronbase
+ acct-user/_cron-failure
+ acct-group/_cron-failure"
+
+DEPEND="sys-process/cronbase
+ test? ( sys-apps/man-db dev-python/pyflakes )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ python_fix_shebang --force "${S}/src/bin"
+
+ sed -i \
+ -e 's/^crontab/crontab-systemd/' \
+ -e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
+ -- "${S}/src/man/crontab."{1,5}".in" || die
+
+ sed -i \
+ -e 's!/crontab$!/crontab-systemd!' \
+ -e 's!/crontab\(\.[15]\)$!/crontab-systemd\1!' \
+ -e 's/pyflakes3/pyflakes/' \
+ -- "${S}/Makefile.in" || die
+
+ if use etc-crontab-systemd
+ then sed -i \
+ -e "s!/etc/crontab!/etc/crontab-systemd!" \
+ -- "${S}/src/man/crontab."{1,5}".in" \
+ "${S}/src/bin/systemd-crontab-generator.py" || die
+ fi
+
+ eapply_user
+}
+
+my_use_enable() {
+ if use ${1}; then
+ echo --enable-${2:-${1}}=yes
+ else
+ echo --enable-${2:-${1}}=no
+ fi
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --confdir="${EPREFIX}/etc" \
+ --runparts="${EPREFIX}/bin/run-parts" \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --unitdir="$(systemd_get_systemunitdir)" \
+ --generatordir="$(systemd_get_systemgeneratordir)" \
+ $(my_use_enable cron-boot boot) \
+ $(my_use_enable minutely) \
+ $(my_use_enable runparts) \
+ $(my_use_enable yearly) \
+ $(my_use_enable yearly quarterly) \
+ $(my_use_enable yearly semi_annually) \
+ $(my_use_enable setgid) \
+ --enable-persistent=yes
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/lib/sysusers.d/systemd-cron.conf
+}
+
+pkg_postinst() {
+ elog "This package now supports USE=runparts which is enabled by default."
+ elog "This enables the traditional run-parts behavior."
+ elog "If you disable this flag you will get the new behavior of having"
+ elog "multiple jobs for each cron.* entry run in parallel with"
+ elog "separate services/logs/etc."
+}