summaryrefslogtreecommitdiff
path: root/sys-process/procenv/procenv-0.51-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-15 10:39:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-15 10:39:51 +0100
commit9b6120d8af003bb775da6737dfe42f8f580f59f6 (patch)
tree965a7890c4893d608fd8d3ce04030376ab565a45 /sys-process/procenv/procenv-0.51-r1.ebuild
parent80765b090d10ae3f68b00e3befe5859f7212e536 (diff)
gentoo auto-resync : 15:07:2023 - 10:39:50
Diffstat (limited to 'sys-process/procenv/procenv-0.51-r1.ebuild')
-rw-r--r--sys-process/procenv/procenv-0.51-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-process/procenv/procenv-0.51-r1.ebuild b/sys-process/procenv/procenv-0.51-r1.ebuild
new file mode 100644
index 000000000000..d59d5338b0af
--- /dev/null
+++ b/sys-process/procenv/procenv-0.51-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="command-line utility to show process environment"
+HOMEPAGE="https://github.com/jamesodhunt/procenv"
+SRC_URI="https://github.com/jamesodhunt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-flags.patch
+ "${FILESDIR}"/${PN}-0.51-musl-sysmacros.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}