summaryrefslogtreecommitdiff
path: root/sys-process/prll
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /sys-process/prll
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'sys-process/prll')
-rw-r--r--sys-process/prll/Manifest2
-rw-r--r--sys-process/prll/prll-0.6.4.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-process/prll/Manifest b/sys-process/prll/Manifest
index 16658204bbf2..a4d646d9834a 100644
--- a/sys-process/prll/Manifest
+++ b/sys-process/prll/Manifest
@@ -1,3 +1,5 @@
DIST prll-0.6.2.tar.bz2 37870 BLAKE2B 00adcb56e49dfe6a04235f628fee1aee5a0164ada30e3a2ac624f73f7e613c7bdd411012f01e8278bc95a1e8e96479d9177f48745759feb4681c0f75a6420419 SHA512 6157ab4d69ab21b0995d5e8e788605b9b602fa0268beae2d6b69e6bf32c734869f023d881ecdd0df83c1f45b584c88eef8beb88d2c58f657340697bf48dfd8cd
+DIST prll-0.6.4.tar.gz 49885 BLAKE2B 07a63ddc6260c302070f27488142118286a0312ef807a6eaebbac180dbfb479c78f66cfb96cddbb7a62c3d96a79a9c4962daf1fbd308ec475ae8d03a999fd276 SHA512 df830eae9be91e175444ba14c23efde3f10152b968ca6b1365e0ab57c68df1a00712a0e6d77cd02aae4ed7a23fc7c25f207ba08bc1559b8331c42dec1d38dbfa
EBUILD prll-0.6.2.ebuild 650 BLAKE2B 429bc383fac5dffceb9b06708a55220cb2042798679adeca48ebb3293849f3740d5bed4ffa997e8f020d20c1ae003c87af0f4ac0db39095c9fb4554fee9dc52b SHA512 2a62e8dabd145b856a70d758b44fbc68f204beeceb37a50df7314351893ded41d341bef17bfb823b78e03b1898d338ce9c03c55caa6446ccaff32af931bdc94c
+EBUILD prll-0.6.4.ebuild 907 BLAKE2B e8d5b26d80502f0e86950b3e1a9c4bf2f43531ef458a3aef0ac70af6e88fc1ad60862963e51a08fe95fc8325b608dde0d5615cbfb3472fc8319eb5865b564d71 SHA512 be508e27b1566d04c5582ae398a2a15e5c587bd3b45aabec528ab6bcc5e61d3bc8ba6e5decef7b410bbb717ccbcc9ff8500bd90fb17782fca69d5f76a3e0ddc0
MISC metadata.xml 339 BLAKE2B 5d5aac74be32e919165c7e7dddef200d0b53582ebc72a6399a47f1ab7e43095119a036fdd516813742b1ae503ee2662e035d9bc8f57b62412f11d57671e85919 SHA512 9277474c200a9a9c93d86eeb36dff14c3a2a0defd7c4d4559a4e841f4ab347eb8c99ea32f430153448b6a52d0e1fbe8cccd12d0d3dce556dfbf630e3b51d3871
diff --git a/sys-process/prll/prll-0.6.4.ebuild b/sys-process/prll/prll-0.6.4.ebuild
new file mode 100644
index 000000000000..1d9cfb0e7449
--- /dev/null
+++ b/sys-process/prll/prll-0.6.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs readme.gentoo-r1
+
+DESCRIPTION="A utility for parallelizing execution of shell functions"
+HOMEPAGE="https://github.com/exzombie/prll"
+SRC_URI="https://github.com/exzombie/prll/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="test"
+
+DOC_CONTENTS="
+You must source the prll.sh file located\nin /etc/profile.d to be able to use prll:\n
+ $ source /etc/profile.d/prll.sh
+"
+
+src_prepare() {
+ default
+ sed \
+ -e '/then sh/d' \
+ -e '/then zsh/d' \
+ -e '/then dash/d' \
+ -i tests/Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+ readme.gentoo_create_doc
+ rm -rf "${D}/usr/share/doc/prll" || die
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}