summaryrefslogtreecommitdiff
path: root/sys-process/pkill-darwin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-process/pkill-darwin
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-process/pkill-darwin')
-rw-r--r--sys-process/pkill-darwin/Manifest5
-rw-r--r--sys-process/pkill-darwin/metadata.xml8
-rw-r--r--sys-process/pkill-darwin/pkill-darwin-1.0.ebuild38
3 files changed, 51 insertions, 0 deletions
diff --git a/sys-process/pkill-darwin/Manifest b/sys-process/pkill-darwin/Manifest
new file mode 100644
index 000000000000..9a3dc885d594
--- /dev/null
+++ b/sys-process/pkill-darwin/Manifest
@@ -0,0 +1,5 @@
+DIST pkill-darwin-1.0.tar.xz 8232 SHA256 a1adc263e6685d210397b8fc186b6856730b8a075aef987cee593e8cf7241e4f SHA512 18ced350664b6dcd07acb33e1872726857a6f762311f91ca2d30323153712a436017b232efd34f8cd0055e10f1036d4a84a06f37ef104722701a172a40d3575a WHIRLPOOL ad3feeb03797dacc73156dc8be2c3e0a335242ad0c4664c238e59442329249c1f76334e4af06f2d5c6f031caf8178111d94db8522e1ec1dde1cb65351494d361
+EBUILD pkill-darwin-1.0.ebuild 1085 SHA256 fcaee0ec10c8accbeb5d3ac4ada3892cfb7952b63d229c9a2ef1efdc2311873c SHA512 f222a0c99adee1258d81cb37b7d011f6e31a81d055402d96dc620abec60df6d300e94cf84c2a1c88fa4f9a253b0c3f53db28e9e86adfc3dc5c11d746c84786ec WHIRLPOOL a139acb0f5bf85be2443bb14d8a951d7d49b549e93d43965d8cb765a1e906f977cc2f7f0b69c8cb99c5498f0a03a8943f5ceb8f65ffa7431aa53520ff1da5540
+MISC ChangeLog 2615 SHA256 420517c063d5965651359b053058d79bed156a6da7d9d6cb77d1dd247822656d SHA512 0d656b8c0eea7c48296a2a9a73bd71861ea9c95257e797c076f70858a6671f8e0c743ad581d838379df15a7b59ff418d4b133cd938ff9679f28a231a88b73909 WHIRLPOOL b599997b37d3fb5efcabe7d033caee45378c27d7411a7b182682c66a8bcc5da13fb61bb4ab884d3e35f9db0ad4d66a0aa9ad963d553c7d4b21e135681a912434
+MISC ChangeLog-2015 423 SHA256 30eddf434b7906f18bc0977edd532e1b8f1b51e3598390e361baa35f3710ef4e SHA512 d6f4f5eec69bc29a95c39b75291099882a2248a12d46dae8fda2b34ace1980ccdb6ce5e594976cf0c5c7a21fe68c4ff50e282693ed4583038af9718ad2123b5c WHIRLPOOL 5afa90d27c9f73b3c7bb528eb79ca8db6526daeab2816c110856c3ced6d47280e5157deadf3f0e55dd45a138850b2228513c8b2880a9b32613ec256b438c1afd
+MISC metadata.xml 253 SHA256 9499c0a0b4a789e06676a4d449b0c76c56e3e92a0fc37cc33a810888fc6becbc SHA512 b87265dab4980faf3d32b53ab9ce7d4ebbe5cc9d12300903b1365b337bcd72c337fdec2ef1574615d2d02cf0664023c17c0d30b57ac0237412fd2b401cc0e2f8 WHIRLPOOL 6811616f92b0dbb437634b151ddbb7fbfd95f68a1ff5f2afffc4b8c15effb2ff5de2cbf41f318c36c7f4ba6ae1c4e47ea6713b5451714a2293b312f2d60c4eb0
diff --git a/sys-process/pkill-darwin/metadata.xml b/sys-process/pkill-darwin/metadata.xml
new file mode 100644
index 000000000000..7151af145b05
--- /dev/null
+++ b/sys-process/pkill-darwin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>prefix@gentoo.org</email>
+ <name>Gentoo Prefix</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-process/pkill-darwin/pkill-darwin-1.0.ebuild b/sys-process/pkill-darwin/pkill-darwin-1.0.ebuild
new file mode 100644
index 000000000000..02043e47267d
--- /dev/null
+++ b/sys-process/pkill-darwin/pkill-darwin-1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="pgrep(1) and pkill(1) for Darwin"
+HOMEPAGE="https://sourceforge.net/p/pkilldarwin/code/ci/default/tree/"
+SRC_URI="https://www.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc-macos ~x86-macos ~x64-macos"
+IUSE=""
+
+src_compile() {
+ echo $(tc-getCC) ${CFLAGS} -o pkill ${LDFLAGS} pkill.c
+ $(tc-getCC) ${CFLAGS} -o pkill ${LDFLAGS} pkill.c || die
+ # don't link, such that the suid trick described below won't make people
+ # suid their pkill too
+ cp pkill pgrep || die
+ ln -s pkill.1 pgrep.1 || die
+}
+
+src_install() {
+ into /usr
+ dobin pkill pgrep
+ doman pkill.1 pgrep.1
+}
+
+pkg_postinst() {
+ einfo "If you you want pgrep to be able to show and match on the arguments"
+ einfo "of all processes, you will have to make pgrep suid root. To do so"
+ einfo "you have to perform the following steps:"
+ einfo " % sudo chown root ${EPREFIX}/usr/bin/pgrep"
+ einfo " % sudo chmod u+s ${EPREFIX}/usr/bin/prgep"
+}