summaryrefslogtreecommitdiff
path: root/sys-process/lsof
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-process/lsof
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-process/lsof')
-rw-r--r--sys-process/lsof/Manifest2
-rw-r--r--sys-process/lsof/lsof-4.94.0.ebuild116
2 files changed, 118 insertions, 0 deletions
diff --git a/sys-process/lsof/Manifest b/sys-process/lsof/Manifest
index 5cc4f9b1b9ac..c0e8f48d608d 100644
--- a/sys-process/lsof/Manifest
+++ b/sys-process/lsof/Manifest
@@ -1,4 +1,6 @@
AUX lsof-4.85-cross.patch 1061 BLAKE2B 730a02dfcd433bb6d46d3fecd87aa0913800408d67302bd9a9580ab3fec6e4a88e453890dec348796258eccd4c5185cc8f06ab2029347d632037f24dd0aa066e SHA512 9326a2708910a39ba3b81253c21149f8e4fa44b207e4c2a88f86c9322d2b50e6360760fcb13e00f644aba57ad207106c280db00ebc2d1f3d49405b54681548e8
DIST lsof-4.93.2.tar.gz 1319222 BLAKE2B 3b1756e7b72a0b0a2a11bce82a9b386f6dc5727d7837a4d544e2e33a98be3bfb46af50f0d8cc7b4a4bc419148d13f86d0f34cf806d90ba5d31312f426f81b7e9 SHA512 3c4a4d503391b1a648a08a4947c2e72a9629b169eddf50738b16a16a82f2a26967e4db2902e4a9157de5a73ae638db48e392117ffbd591e9fafd6b1725cd01a0
+DIST lsof-4.94.0.tar.gz 1340224 BLAKE2B b3d3c4707dac22c5431ac37c6a9f28ba5057b9a8dce65038934f1148209ef4615012ed887e263ec648679d0d95a06c78ed83a7d76cc8d97c05c013c563938793 SHA512 852b12e621e1dbf71e5f7fd848a200339ca278fbe8c39dcd33f745d1aea4e61552c0f30a3f6469ad9d4b86a9163e677f8c95298159ebd647357734225aa06c0c
EBUILD lsof-4.93.2-r1.ebuild 3405 BLAKE2B 5226204a056e1d1deb25939c1bd08d3d25e0dfe7e3387238e1b2682d377524aad7b2f66b08cdd2616d8eaa19f5adfb85c33e1921112af6da5037c9263bca8733 SHA512 51c3d5353c7bf013f1f5e637f7345ade253eec187afdadfd45157ea70f623ca241fff8f4ab52c2d8873eebb8e328e530f907969e4996a8f614fef5f8d8dfb583
+EBUILD lsof-4.94.0.ebuild 3452 BLAKE2B 84799fe3b310819914dda0192f64634978a2f2f1f5d2f8a298a1eeedeea3a10b180864579903f2044e8d235cd277503157bcd9d9e23e037e17f6df14c1c972cc SHA512 39d5cc3c303bc102352bcd81c566c0ab3772356ed0be84645de0da6dad6233ee390cc7895a0a331d9928a28f01c709848173f862e429f594447d1e659b4cc22f
MISC metadata.xml 410 BLAKE2B fd0f172a687fe180b6fc367195925576c468612bbb516fe582ed6fb8be19c5de238f9ce3e762f2bedba9802167c55995f5d8319ffeb681cdb4a91e01a9292ab2 SHA512 47b91158e1621c03685f821f3126fbd3c4a6336fedb79c85f7fc245fe0a724b2df46e18abd15f926f5739b70e93072817ccde5862c9712314bf7cd9a4e43a812
diff --git a/sys-process/lsof/lsof-4.94.0.ebuild b/sys-process/lsof/lsof-4.94.0.ebuild
new file mode 100644
index 000000000000..da9d568ab347
--- /dev/null
+++ b/sys-process/lsof/lsof-4.94.0.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P="${P/-/_}"
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="https://github.com/lsof-org/lsof"
+SRC_URI="https://github.com/lsof-org/lsof/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="lsof"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples ipv6 rpc selinux"
+
+RDEPEND="rpc? ( net-libs/libtirpc )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ rpc? ( virtual/pkgconfig )"
+BDEPEND="
+ sys-apps/groff
+"
+
+# needs fixing first
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.85-cross.patch #432120
+)
+
+src_prepare() {
+ default
+ # fix POSIX compliance with `echo`
+ sed -i \
+ -e 's:echo -n:printf:' \
+ AFSConfig Configure Customize Inventory tests/CkTestDB || die
+ # Convert `test -r header.h` into a compile test.
+ # Make sure we convert `test ... -a ...` into two `test` commands
+ # so we can then convert both over into a compile test. #601432
+ sed -i -E \
+ -e '/if test .* -a /s: -a : \&\& test :g' \
+ -e '/test -r/s:test -r \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\1>" | ${LSOF_CC} ${LSOF_CFGF} -E - >/dev/null 2>\&1:g' \
+ -e 's:grep (.*) \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\2>" | ${LSOF_CC} ${LSOF_CFGF} -E -P -dD - 2>/dev/null | grep \1:' \
+ Configure || die
+
+ # "create" man-page (bug #689462)
+ # inspired by shipped "makeman" ksh script
+ soelim < Lsof.8 > lsof.8 || die
+}
+
+target() {
+ case ${CHOST} in
+ *-darwin*) echo darwin ;;
+ *-freebsd*) echo freebsd ;;
+ *-solaris*) echo solaris ;;
+ *-aix*) echo aixgcc ;;
+ *) echo linux ;;
+ esac
+}
+
+src_configure() {
+ append-cppflags $(use rpc && $(tc-getPKG_CONFIG) libtirpc --cflags || echo "-DHASNOTRPC -DHASNORPC_H")
+ append-cppflags $(usex ipv6 -{D,U}HASIPv6)
+ [[ ${CHOST} == *-solaris2.11 ]] && append-cppflags -DHAS_PAD_MUTEX
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # make sys/proc_info.h available in ${T} because of LSOF_INCLUDE
+ # dummy location -- Darwin needs this for a Configure check to
+ # succeed
+ if [[ -e /usr/include/sys/proc_info.h ]] ; then
+ mkdir -p "${T}"/sys || die
+ ( cd "${T}"/sys && ln -s /usr/include/sys/proc_info.h ) || die
+ fi
+ fi
+
+ export LSOF_CFGL="${CFLAGS} ${LDFLAGS} \
+ $(use rpc && $(tc-getPKG_CONFIG) libtirpc --libs)"
+
+ # Set LSOF_INCLUDE to a dummy location so the script doesn't poke
+ # around in it and mix /usr/include paths with cross-compile/etc.
+ touch .neverInv
+ LINUX_HASSELINUX=$(usex selinux y n) \
+ LSOF_INCLUDE=${T} \
+ LSOF_CC=$(tc-getCC) \
+ LSOF_AR="$(tc-getAR) rc" \
+ LSOF_RANLIB=$(tc-getRANLIB) \
+ LSOF_CFGF="${CFLAGS} ${CPPFLAGS}" \
+ ./Configure -n $(target) || die
+}
+
+src_compile() {
+ emake DEBUG="" all
+}
+
+src_install() {
+ dobin lsof
+
+ if use examples ; then
+ insinto /usr/share/lsof/scripts
+ doins scripts/*
+ fi
+
+ doman lsof.8
+ dodoc 00*
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "Note: to use lsof on Solaris you need read permissions on"
+ einfo "/dev/kmem, i.e. you need to be root, or to be in the group sys"
+ elif [[ ${CHOST} == *-aix* ]] ; then
+ einfo "Note: to use lsof on AIX you need read permissions on /dev/mem and"
+ einfo "/dev/kmem, i.e. you need to be root, or to be in the group system"
+ fi
+}