summaryrefslogtreecommitdiff
path: root/sys-process/lsof/lsof-4.97.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /sys-process/lsof/lsof-4.97.0.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'sys-process/lsof/lsof-4.97.0.ebuild')
-rw-r--r--sys-process/lsof/lsof-4.97.0.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/sys-process/lsof/lsof-4.97.0.ebuild b/sys-process/lsof/lsof-4.97.0.ebuild
deleted file mode 100644
index c71f85d7ef29..000000000000
--- a/sys-process/lsof/lsof-4.97.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools flag-o-matic toolchain-funcs
-
-MY_P="${P/-/_}"
-DESCRIPTION="Lists open files for running Unix processes"
-HOMEPAGE="https://github.com/lsof-org/lsof"
-SRC_URI="https://github.com/lsof-org/lsof/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="lsof"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="rpc selinux"
-
-RDEPEND="
- rpc? ( net-libs/libtirpc )
- selinux? ( sys-libs/libselinux )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-apps/groff
- rpc? ( virtual/pkgconfig )
-"
-
-# Needs fixing first
-RESTRICT="test"
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- export ac_cv_header_rpc_rpc_h=$(usex rpc)
- export ac_cv_header_selinux_selinux_h=$(usex selinux)
-
- if use rpc ; then
- append-cppflags $($(tc-getPKG_CONFIG) libtirpc --cflags)
- append-libs $($(tc-getPKG_CONFIG) libtirpc --libs)
- fi
-
- [[ ${CHOST} == *-solaris2.11 ]] && append-cppflags -DHAS_PAD_MUTEX
-
- econf
-}
-
-src_compile() {
- emake DEBUG="" all
-}
-
-pkg_postinst() {
- if [[ ${CHOST} == *-solaris* ]] ; then
- einfo "Note: to use lsof on Solaris you need read permissions on"
- einfo "/dev/kmem, i.e. you need to be root, or to be in the group sys"
- elif [[ ${CHOST} == *-aix* ]] ; then
- einfo "Note: to use lsof on AIX you need read permissions on /dev/mem and"
- einfo "/dev/kmem, i.e. you need to be root, or to be in the group system"
- fi
-}