summaryrefslogtreecommitdiff
path: root/sys-process/iotop/iotop-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-process/iotop/iotop-0.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-process/iotop/iotop-0.6.ebuild')
-rw-r--r--sys-process/iotop/iotop-0.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-process/iotop/iotop-0.6.ebuild b/sys-process/iotop/iotop-0.6.ebuild
new file mode 100644
index 000000000000..8d3f4872da40
--- /dev/null
+++ b/sys-process/iotop/iotop-0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="ncurses(+)"
+
+inherit distutils-r1 linux-info
+
+DESCRIPTION="Top-like UI used to show which process is using the I/O"
+HOMEPAGE="http://guichaz.free.fr/iotop/"
+SRC_URI="http://guichaz.free.fr/iotop/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 hppa ~ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+DOCS=( NEWS README THANKS ChangeLog )
+
+PATCHES=( "${FILESDIR}"/${P}-setup.py3.patch )
+
+pkg_setup() {
+ linux-info_pkg_setup
+}