summaryrefslogtreecommitdiff
path: root/sys-process/htop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-05 03:15:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-05 03:15:29 +0000
commitc75fb751e4fd18ca8d87b0198e91a1976ffb2f2d (patch)
treef5c67b2f37cf625a99a154e470bc5dd76a88dee1 /sys-process/htop
parent2997df5d95cb64694ec91d50c93407e92c68e2a8 (diff)
gentoo auto-resync : 05:02:2023 - 03:15:29
Diffstat (limited to 'sys-process/htop')
-rw-r--r--sys-process/htop/Manifest2
-rw-r--r--sys-process/htop/htop-3.2.2.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/sys-process/htop/Manifest b/sys-process/htop/Manifest
index 5e1983e837fd..e3ce1c2715dc 100644
--- a/sys-process/htop/Manifest
+++ b/sys-process/htop/Manifest
@@ -1,4 +1,6 @@
DIST htop-3.2.1.tar.xz 406048 BLAKE2B 7addefca7de8f0867220e6415f4585f7e6ecf655d6245e4a8e120552ac738544fde1c2d8e24ce1139209caad23994316e8be9611f6ed0253d60547158d17ff24 SHA512 f412c10ebdec4fb026fb93a79a9b0b84612ad5a0d28e37f06713e6c895f70e92cbd09a8737d04f3d51102295d7a419eb2c3ec3907b96f553fda8ff3d1a2142b6
+DIST htop-3.2.2.tar.xz 384820 BLAKE2B da3b4aea4e5d32d4b432e0f45089e7795b59d9a947dc4af76cb6b7f9137e6d45901c8169c8d2c796a3f43162c1e3c8f1e18bd17f20750637e06fe4c3ebe22caa SHA512 59f3f06677076262e25a478552e4438ce37028e2f064d3fb78653d3213b48ae4d78c7e0d62ee785a4ed3c6c99b7faafd9afab94c4350a4e5c5843cef81aaf489
EBUILD htop-3.2.1-r2.ebuild 2565 BLAKE2B 823ca343ccac450f67019718ab558eac8b3e8f9363f041cbb69bf33763488b8fc884f1719e1055cfdb36ab87b1d58c6c620a037c0c800cd37abe46cfc43fdbfa SHA512 1c9a97e27b60bdcd7562bd7026d700f9c91b4d8e851c22aba56f5d4e8aca34e0b767d0cc5b2402a3b116621bf91ee043f5c487346663e29bd3064576ca38c06f
+EBUILD htop-3.2.2.ebuild 2573 BLAKE2B 454d02e6b1cdc7312d4fe1103f034485dd40cfe7526081db977f10eb236d79cce361c5a7da8f222dc29590f9f91e00387265535c98efdcc1b2151db7f7d82e8b SHA512 7d0e860dae4b0d372e42276cbc103cbf0bf861fc5dd770592f5eae873e115ada69d730ac919e680fbc45b258db90e2d575fd2332cce676cdd63a4b2f44baf51c
EBUILD htop-9999.ebuild 2573 BLAKE2B 454d02e6b1cdc7312d4fe1103f034485dd40cfe7526081db977f10eb236d79cce361c5a7da8f222dc29590f9f91e00387265535c98efdcc1b2151db7f7d82e8b SHA512 7d0e860dae4b0d372e42276cbc103cbf0bf861fc5dd770592f5eae873e115ada69d730ac919e680fbc45b258db90e2d575fd2332cce676cdd63a4b2f44baf51c
MISC metadata.xml 908 BLAKE2B ef2166ceae63ee1545ac919278b3c0e2bcbba9612d7ff6e6cac20c3d1b5981b49bb13894b8177caafcc844395ae373415a07726ad89dabc4328274eec39ae90a SHA512 8f13f80bc6bdbfbf23e7172e1872681d7f063094a68a8e773a9258e364bb947d16325cf26e5091b3b75c80b0f3b8444394535bbe409e95d7e97a733e09d5537e
diff --git a/sys-process/htop/htop-3.2.2.ebuild b/sys-process/htop/htop-3.2.2.ebuild
new file mode 100644
index 000000000000..7080f7e4ba08
--- /dev/null
+++ b/sys-process/htop/htop-3.2.2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+# We avoid xdg.eclass here because it'll pull in glib, desktop utils on
+# htop which is often used on headless machines. bug #787470
+inherit linux-info optfeature python-any-r1 xdg-utils
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/htop-dev/htop.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/htop-dev/htop/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+S="${WORKDIR}/${P/_}"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+IUSE="caps debug delayacct hwloc lm-sensors llvm-libunwind openvz unicode unwind vserver"
+
+RDEPEND="
+ sys-libs/ncurses:=[unicode(+)?]
+ hwloc? ( sys-apps/hwloc:= )
+ unwind? (
+ !llvm-libunwind? ( sys-libs/libunwind:= )
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ )
+ kernel_linux? (
+ caps? ( sys-libs/libcap )
+ delayacct? ( dev-libs/libnl:3 )
+ lm-sensors? ( sys-apps/lm-sensors )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog README )
+
+CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ if [[ ${CBUILD} != ${CHOST} ]] ; then
+ # bug #328971
+ export ac_cv_file__proc_{meminfo,stat}=yes
+ fi
+
+ local myeconfargs=(
+ --enable-unicode
+ $(use_enable debug)
+ $(use_enable hwloc)
+ $(use_enable !hwloc affinity)
+ $(use_enable openvz)
+ $(use_enable unicode)
+ $(use_enable unwind)
+ $(use_enable vserver)
+ )
+
+ if use kernel_linux ; then
+ myeconfargs+=(
+ $(use_enable caps capabilities)
+ $(use_enable delayacct)
+ $(use_enable lm-sensors sensors)
+ )
+ else
+ if use kernel_Darwin ; then
+ # Upstream default to checking but --enable-affinity
+ # overrides this. Simplest to just disable on Darwin
+ # given it works on BSD anyway.
+ myeconfargs+=( --disable-affinity )
+ fi
+
+ myeconfargs+=(
+ --disable-capabilities
+ --disable-delayacct
+ --disable-sensors
+ )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ optfeature "Viewing processes accessing certain files" sys-process/lsof
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}