summaryrefslogtreecommitdiff
path: root/sys-process/evisum/evisum-0.2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:56:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:56:30 +0100
commit948d557b4a61dc14722668b6b11a4cf3cee07b01 (patch)
treeb28b6cb077ae6b2457e30d49028fc978d8e2b59b /sys-process/evisum/evisum-0.2.6.ebuild
parente3cf2c86fca1750343c1885311f857f185ee4f2d (diff)
gentoo resync : 13.09.2019
Diffstat (limited to 'sys-process/evisum/evisum-0.2.6.ebuild')
-rw-r--r--sys-process/evisum/evisum-0.2.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-process/evisum/evisum-0.2.6.ebuild b/sys-process/evisum/evisum-0.2.6.ebuild
new file mode 100644
index 000000000000..9ea74684dde2
--- /dev/null
+++ b/sys-process/evisum/evisum-0.2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="System and process monitor written with EFL"
+HOMEPAGE="https://www.enlightenment.org/"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/efl"
+RDEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.2.2-respect-cflags-ldflags.patch" )
+
+src_install() {
+ emake PREFIX="${D}"/usr install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}