summaryrefslogtreecommitdiff
path: root/sys-process/evisum/evisum-0.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /sys-process/evisum/evisum-0.2.3.ebuild
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'sys-process/evisum/evisum-0.2.3.ebuild')
-rw-r--r--sys-process/evisum/evisum-0.2.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-process/evisum/evisum-0.2.3.ebuild b/sys-process/evisum/evisum-0.2.3.ebuild
new file mode 100644
index 000000000000..9ea74684dde2
--- /dev/null
+++ b/sys-process/evisum/evisum-0.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="System and process monitor written with EFL"
+HOMEPAGE="https://www.enlightenment.org/"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/efl"
+RDEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.2.2-respect-cflags-ldflags.patch" )
+
+src_install() {
+ emake PREFIX="${D}"/usr install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}