summaryrefslogtreecommitdiff
path: root/sys-process/dcron
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
commit28e3d252dc8ac8a5635206dfefe1cfe05058d1db (patch)
treee75bce604750fb72e53ed3684059e2e5d2094509 /sys-process/dcron
parentf625b9919a60a30f1bd860f7d1b2eac183ced593 (diff)
gentoo resync : 12.08.2018
Diffstat (limited to 'sys-process/dcron')
-rw-r--r--sys-process/dcron/Manifest3
-rw-r--r--sys-process/dcron/dcron-4.5-r2.ebuild52
-rw-r--r--sys-process/dcron/metadata.xml20
3 files changed, 68 insertions, 7 deletions
diff --git a/sys-process/dcron/Manifest b/sys-process/dcron/Manifest
index a398111053d2..5822d29517b2 100644
--- a/sys-process/dcron/Manifest
+++ b/sys-process/dcron/Manifest
@@ -6,4 +6,5 @@ AUX dcron.init 449 BLAKE2B 2c2ff6e7e39282dd17b9d64705a96aebfda589f7276b0047c5ebb
AUX dcron.service 151 BLAKE2B b8e3fa583592f6a3719356ed4d7b7429ba0cfaec2a6398af398df3a3b959b74659b6b89b7899c1bfb1c9ce048c00be6790aae650a88b5cfb5cc7ea51020e9fce SHA512 7249396786f5fc3b52981d0344c52bd56151d8ead161111a90a5b30c2985a39486aea3e263a6ddbefcb53d88a67277038bd88cc6480ce3d788093bac16835d1c
DIST dcron-4.5.tar.gz 44978 BLAKE2B c77cea026b074eed11200bb335cc2f58f7346410f88ae50685db137583beddab14e50394233b8e0f27ae7e3bf30c7875b539db84c32236f78f52bf91862b3272 SHA512 08521391d16ba5adf80278ec2a734319c26c48841fd94b119c0b27d744c2cfb3562b1a3630135a03d1c43b1668d49262713abb20ff5f7ecd397a2a19a2f6105a
EBUILD dcron-4.5-r1.ebuild 1150 BLAKE2B 95d02f72bece8da3b0b693622e259876c6044a2719c578f9f6687c07711581632aab686b9e8adf6a982223cd16b47e72e11edbfc18b8243e3e89d2d6d4ef0a44 SHA512 b1c9e815fc98048e4a362d39b9165abcf5dbf4c38fc8c5fea91493c024e61af9535cd985176d0d9c1c5a9273ea22d4048d3d2d760023ca04d5f1e7f39713fbfe
-MISC metadata.xml 296 BLAKE2B 2e33d6bbb45f0956736662fd2987814640159b808942aa1c99f481e0995aeac28e986cad45d02bea36a14288948670ead6655bf9795b66e0f4dbeb5846c72df4 SHA512 6c30bed0e7ffbebe5c45ff4fe7b7e5c2d096a18a6622f7b82c3f5f579d3d493bb3e4213c4653428a3d3b56cba9111c4d0881ba05d6760ffa7e6c4e3a355d77fc
+EBUILD dcron-4.5-r2.ebuild 1171 BLAKE2B 4c771b30ba7b458d20c4b712628a56d4017bf69d45430c824181265e3a9d9c569025b834c3fef38e85e8e53eed15a1d209fb4610c8544cd007dcdbcdd0596ac6 SHA512 2806c3a0234763cf9b94923e6c884ff39d4828cd9ce2385545fb9618b366b8beceacca64915fb1f87f9410706ca11f3859e55e86d7c65a368784809e9a4a0a22
+MISC metadata.xml 700 BLAKE2B 3e102bc50c78da694740103bafa81d2fd690896038e9f1eae1cd49a14eb73e79d4865d23c9899583117c283c6c8d0dd2aeafa312ba5deaf61aa065815ca305f1 SHA512 aed73be5f884a101a6445fac9b4bde42f60827a30efab8ba0eb097d7b4369fbcc9c5eb5d637fef7f1de78f066f5984bf76f8659d03d400e711f01d9927554029
diff --git a/sys-process/dcron/dcron-4.5-r2.ebuild b/sys-process/dcron/dcron-4.5-r2.ebuild
new file mode 100644
index 000000000000..e0d83c3e1c1b
--- /dev/null
+++ b/sys-process/dcron/dcron-4.5-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cron toolchain-funcs systemd
+
+DESCRIPTION="A cute little cron from Matt Dillon"
+HOMEPAGE="http://www.jimpryor.net/linux/dcron.html http://apollo.backplane.com/FreeSrc/"
+SRC_URI="http://www.jimpryor.net/linux/releases/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DOCS=( CHANGELOG README extra/run-cron extra/root.crontab "${FILESDIR}"/crontab )
+
+PATCHES=( "${FILESDIR}"/${PN}-4.5-ldflags.patch "${FILESDIR}"/${PN}-4.5-pidfile.patch )
+
+src_prepare() {
+ default
+
+ tc-export CC
+
+ cat <<-EOF > config
+ PREFIX = /usr
+ CRONTAB_GROUP = cron
+ EOF
+}
+
+src_install() {
+ default
+
+ docrondir
+ docron crond -m0700 -o root -g wheel
+ docrontab
+
+ insinto /etc
+ doins "${FILESDIR}"/crontab
+
+ insinto /etc/cron.d
+ doins extra/prune-cronstamps
+
+ insinto /etc/logrotate.d
+ newins extra/crond.logrotate dcron
+
+ keepdir /var/spool/cron/cronstamps
+
+ newinitd "${FILESDIR}"/dcron.init dcron
+ newconfd "${FILESDIR}"/dcron.confd dcron
+ systemd_dounit "${FILESDIR}"/dcron.service
+}
diff --git a/sys-process/dcron/metadata.xml b/sys-process/dcron/metadata.xml
index 4fc1e843e09b..2cfaa1da1d06 100644
--- a/sys-process/dcron/metadata.xml
+++ b/sys-process/dcron/metadata.xml
@@ -1,10 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>cron-bugs@gentoo.org</email>
-</maintainer>
-<upstream>
- <remote-id type="github">dubiousjim/dcron</remote-id>
-</upstream>
+ <maintainer type="project">
+ <email>cron-bugs@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This lightweight cron daemon aims to be simple and secure, with just enough
+ features to stay useful.
+ Unlike other fatter cron daemons, though, this cron doesn't even try to manage
+ environment variables or act as a shell.
+ All jobs are run with `/bin/sh` for conformity and portability.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/dubiousjim/dcron/issues</bugs-to>
+ <remote-id type="github">dubiousjim/dcron</remote-id>
+ </upstream>
</pkgmetadata>