summaryrefslogtreecommitdiff
path: root/sys-process/daemontools-encore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-process/daemontools-encore
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-process/daemontools-encore')
-rw-r--r--sys-process/daemontools-encore/Manifest6
-rw-r--r--sys-process/daemontools-encore/daemontools-encore-1.10.ebuild50
-rw-r--r--sys-process/daemontools-encore/files/svscan.init-228
-rw-r--r--sys-process/daemontools-encore/metadata.xml17
4 files changed, 101 insertions, 0 deletions
diff --git a/sys-process/daemontools-encore/Manifest b/sys-process/daemontools-encore/Manifest
new file mode 100644
index 000000000000..cb3c89ae605e
--- /dev/null
+++ b/sys-process/daemontools-encore/Manifest
@@ -0,0 +1,6 @@
+AUX svscan.init-2 592 SHA256 6e7cf4a170c1a30b22ddd9f1ffd19ece0111a960aed10d5e4223fce9413b9e02 SHA512 cfe2d3ef118262f86d5c91a76ffac2f51564e748c4e9392b42ee9f9e13d90729a795c4dfeba5bc3c5793b988fac62a9ca1fb33e685200bf4fcd354d5872d9d1d WHIRLPOOL 99895e3035a0dcbc43f341628ef82aa54e0868bcefe826f968d4673bbd84851262bfedafe3118f61b49990a00771ad4997afafcf0e4cbd28bcd62bc7f6b592fc
+DIST daemontools-encore-1.10.tar.gz 87096 SHA256 9f48f3c6cdd3f2b0202532e87f9ff46ea86777ca31ebda3a96bed618104bbd31 SHA512 569030fb9941186f167644740d0424987105b7a818d5a3cdb4e90ced5530a16938b7205141ca2f198f83362269f9cc28eb5acafe9cd7f985c8e56d307f706767 WHIRLPOOL d4ad3bebb8467dbfb5b9d8a40020c50822ca14cfb9ebc1ff44b3563a93e3083061f7b16a137a6c7df6898df6349ee380b6453c299ee098286924ba92b6b279ac
+EBUILD daemontools-encore-1.10.ebuild 1129 SHA256 2b6068aad98c6e9eaf2fcf45ad9806d3e77d90fed17ba0e2017e6df6110ad310 SHA512 762fdfbe63843eae27445836de30ec3da1688af1715f4693e707d9aa755b534d234808bf720f3cdfcabb5820d56c10297f8d913d27a9e73a80893bd55fc5cfb9 WHIRLPOOL 706f942feab8f22931ac28b407eb15ce1762b85c2105d245f31fbe3cd903f6d8ef50289d27940877b1c6c472ab21e4d5d498ddbc43d027d43bce8506031d3330
+MISC ChangeLog 3112 SHA256 220e2776ce12500db1d7d93245b34305236fe519ea179698c70247198e1d8e95 SHA512 f8fb9066b950ad248a7ae7364c386bfcb16e83253ee44f994a6bc5f78047524585d322aebf7f273fead1954f6c30b8954ba8cf05f67587b8fb210297739ee914 WHIRLPOOL 8b9d8b42f2c0a2067f60d49d7b4c2c1aec8702d88d23a53830dbe85c2d06b193d452388a588f1b418104a82d17aad7da7039c7b54a6c9cf14c9804fd730c0f53
+MISC ChangeLog-2015 1576 SHA256 32fe32a244c691053a16e2e2e860ccf863758f194b93acb8aab6092cefc235e5 SHA512 0e1153b610797b7f82e2adaea732a563bb5cfc0d4aaf2ecc08057d6d43b9bada09cdb013dfaf7f878ed8c37e3b7ebc169d6108aab154b5a5a7296b020174dcc4 WHIRLPOOL fce705d93eb9cd9e0e1ec70a6254edba3f90fee0be70c291f66fbb63649e332816661bc5d2b599e3a96b3370135096c370a3198099aba35f8acfcf253f64ad70
+MISC metadata.xml 666 SHA256 c8cc00981e1ada9fa5b14c26472f4e6c1e76eb118521834a6c66d13bdbfce5bc SHA512 9c45feddf5f6a53f43aad784abf5f60f129d826a3c24ad3d2921973f8c26fa7ba7470a614da8b0a2d3fec0bb65265d6e917b0cefe972b16f221288977c694188 WHIRLPOOL f6becce02179283b6a97203418efba4ad7d7342d8236c663edbe9b3476315f0585c3b7b4e98ea8295e41fddfb0e887a62a2c466d45da353914cc79ee52b03fb6
diff --git a/sys-process/daemontools-encore/daemontools-encore-1.10.ebuild b/sys-process/daemontools-encore/daemontools-encore-1.10.ebuild
new file mode 100644
index 000000000000..5a8a4fbabf11
--- /dev/null
+++ b/sys-process/daemontools-encore/daemontools-encore-1.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit flag-o-matic qmail
+
+DESCRIPTION="Collection of tools for managing UNIX services"
+HOMEPAGE="http://untroubled.org/daemontools-encore/"
+SRC_URI="http://untroubled.org/daemontools-encore/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="selinux static"
+
+DEPEND=""
+RDEPEND="selinux? ( sec-policy/selinux-daemontools )
+ !sys-process/daemontools
+ !app-doc/daemontools-man"
+
+src_compile() {
+ use static && append-ldflags -static
+ qmail_set_cc
+ emake
+}
+
+src_install() {
+ keepdir /service
+
+ echo ${D}/usr/bin >conf-bin
+ echo ${D}/usr/share/man >conf-man
+ dodir /usr/bin
+ dodir /usr/share/man
+ emake install
+
+ dodoc ChangeLog CHANGES CHANGES.djb README TODO
+
+ newinitd "${FILESDIR}"/svscan.init-2 svscan
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can run daemontools using the svscan init.d script,"
+ einfo "or you could run it through inittab."
+ einfo "To use inittab, emerge supervise-scripts and run:"
+ einfo "svscan-add-to-inittab"
+ einfo "Then you can hup init with the command telinit q"
+ einfo
+}
diff --git a/sys-process/daemontools-encore/files/svscan.init-2 b/sys-process/daemontools-encore/files/svscan.init-2
new file mode 100644
index 000000000000..ec9e0ead33f5
--- /dev/null
+++ b/sys-process/daemontools-encore/files/svscan.init-2
@@ -0,0 +1,28 @@
+#!/sbin/openrc-run
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+pidfile="/var/run/svscan.pid"
+command="/usr/bin/svscan"
+command_args="/service"
+command_background="true"
+
+depend() {
+ use net
+ before ntpd ntp-client spamd apache apache2
+}
+
+stop() {
+ ebegin "Stopping service scan"
+ start-stop-daemon --stop --exec ${command} \
+ --pidfile ${pidfile}
+ eend $?
+
+ ebegin "Stopping service scan services"
+ svc -dx /service/* 2>/dev/null
+ eend $?
+
+ ebegin "Stopping service scan logging"
+ svc -dx /service/*/log 2>/dev/null
+ eend $?
+}
diff --git a/sys-process/daemontools-encore/metadata.xml b/sys-process/daemontools-encore/metadata.xml
new file mode 100644
index 000000000000..4f4a215ac9d7
--- /dev/null
+++ b/sys-process/daemontools-encore/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+</maintainer>
+<longdescription lang="en">
+daemontools-encore is a collection of tools for managing UNIX services.
+It is derived from the public-domain release of daemontools by
+D. J. Bernstein.
+
+daemontools-encore adds numerous enhancements above what daemontools
+could do while maintaining backwards compatibility with daemontools.
+See the CHANGES file for more details on what features have been added.
+</longdescription>
+</pkgmetadata>