summaryrefslogtreecommitdiff
path: root/sys-process/cronutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-19 11:02:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-19 11:02:19 +0000
commit8c58ead574346296889d58006e1bf184da00be3a (patch)
treea7f2072c85179ee02c63febb294a7853dd137de1 /sys-process/cronutils
parentf9a583991092848eb54269744b512063a4d59de0 (diff)
gentoo auto-resync : 19:11:2023 - 11:02:18
Diffstat (limited to 'sys-process/cronutils')
-rw-r--r--sys-process/cronutils/Manifest2
-rw-r--r--sys-process/cronutils/cronutils-1.10.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/sys-process/cronutils/Manifest b/sys-process/cronutils/Manifest
index 90a8c0405848..50a005e2fed8 100644
--- a/sys-process/cronutils/Manifest
+++ b/sys-process/cronutils/Manifest
@@ -1,3 +1,5 @@
+DIST cronutils-1.10.tar.gz 17098 BLAKE2B e450d9547355a6e6c447c533c69837b0e4a0c7f2100d1afe4088951ff988dea38029d3aac7433360ef3952d8ad9b1c0d90d6443546f7730e5bdd001612ed1ca7 SHA512 15f42054d86d7352d1454b3a18d959db3dc73d207fa3304708c002bfbcc86e630e97306ec84a26a904deb080428f5cc8c046aea55adbea2e69de2b4fab7538f4
DIST cronutils-1.9.tar.gz 15997 BLAKE2B 8fbd364dd50db8dc66febbd59eda17437865396fe419e9c967f7a57ea8a8782239b8acc6381fd1a7c5a15b8e5ab308bfc4869f4e696cc9a7221ddacc6786aa59 SHA512 ac9ff2c39090f851a3a581aea7f88bdf9b0eaac54c10f401fb2a54a8970f2103a76ac584e852813b09e75214c7c39d6489c5cd28a151e2c063f3dcb9d6db62b6
+EBUILD cronutils-1.10.ebuild 579 BLAKE2B f862eadc5b231e1ba6b28c67c7d829653f2e7347127078a5a9ba01c39ad104321ca7e80626d7cb591f7270ebe54e6320bf2445e970590ee65cb21a0cd5566f6d SHA512 d0065a8543c3c5dd07ca9226cdfccf2f46ae71669a89d8b0112e6555bfd67eafd72a1d8dcedd54d6875deaa8e583751f15f84e7ce84d5b229ae8c4992c8190ff
EBUILD cronutils-1.9.ebuild 567 BLAKE2B f89ecb1e4f92f90ab111a616a2ea0580486498cebcd9222f58203acb095e229d733ddc88f1e9832119ea223f35c3d859ef6f7671392d3dddcecc5e5e9ccf71e1 SHA512 7de9c0a82ee5f513b922f9d39bfa9e558d6e1d2e079383e2c778a40686c884fde4afc63c66277b42edc30caa9582ac99c17af9d34e0e614ad354975e1cb76437
MISC metadata.xml 510 BLAKE2B 07ae44cef47f71594f43af7f8d0f7669937a4e36ca7182cb0ae5d0ca16740b3eb04f19009f6baa2f4a39e1cfc01ea80d185ab745cf32041ab7ddc8d2a067d1e9 SHA512 5c6b6411bca47f2540b286334d7e0336c086e0a877a2ae82146e8b4247c69daaaa8b44729328d3b596c3823c801c6acc61974705c5e0536eca3d15ceb7809413
diff --git a/sys-process/cronutils/cronutils-1.10.ebuild b/sys-process/cronutils/cronutils-1.10.ebuild
new file mode 100644
index 000000000000..d15e4328cafb
--- /dev/null
+++ b/sys-process/cronutils/cronutils-1.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utilities to assist running batch processing jobs"
+HOMEPAGE="https://github.com/google/cronutils"
+SRC_URI="https://github.com/google/${PN}/archive/version/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-version-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="-D_XOPEN_SOURCE=500 ${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+}