summaryrefslogtreecommitdiff
path: root/sys-process/cronie
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-24 23:32:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-24 23:32:34 +0100
commit83c7eb1835fcfdf7072b953d23ab34f03c7e8ed6 (patch)
treed44aefcc259a6d52e3d3b0c9929f52aedd24d001 /sys-process/cronie
parent7138219e3c9446bf981ff17f5609f42130bec414 (diff)
gentoo auto-resync : 24:09:2022 - 23:32:34
Diffstat (limited to 'sys-process/cronie')
-rw-r--r--sys-process/cronie/Manifest1
-rw-r--r--sys-process/cronie/cronie-1.6.1-r2.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/sys-process/cronie/Manifest b/sys-process/cronie/Manifest
index 119fed55bab9..a80cd7e26655 100644
--- a/sys-process/cronie/Manifest
+++ b/sys-process/cronie/Manifest
@@ -5,4 +5,5 @@ AUX cronie-1.5.3-systemd.patch 980 BLAKE2B dc11e7e1f072270f24e4ae420c2bde63412ec
AUX cronie-crontab 476 BLAKE2B 7e2de210328ad714647b9ec50c611573ba166b63f68643aa001f8ca2d2c6e6a5b1300cbd8e1be2ba4374def366698abe6f990673b427e7db4883a9cb74bd06c0 SHA512 0d42a8e749db5c7f057b980678dbfada3dcf1418000168380097032a69a48ab4bc8fa228fb45c65c9c2a1a8d5290da3ca84816963fb7096fd13e293a68fea0c5
DIST cronie-1.6.1.tar.gz 149913 BLAKE2B 7b563b90f386a8df09398661e2b3ddc1f83d6c0d19290a02c0622be461e1d160218572adf132d634c60ef8fd0a4bb100e830b90e26270c28c75a69591ccc18a6 SHA512 1e095df9670ec25d6629f4cf2cacd82c6c1cb1487a859815a7881a1d130e4f18f9976396f773abae24dadc232166bb6467bbaeac1cb0254209fcadf3530d5e6f
EBUILD cronie-1.6.1-r1.ebuild 2587 BLAKE2B 1942016c49257749e54d0b13c1fa733cd6574cebeed5f89c80f0f9790f4bed5bbe353604bf22a22a0ca099f43b856062d861ef85cbf419b0e40bc3f4b599784f SHA512 4e9bc4893e734250efc61cc22540a6f197bfcfc82e0a736c25bb12999d1a615c9475fa38b7b79ed8539a5e1770b940b811e7330be950fec444c993d33e7eca53
+EBUILD cronie-1.6.1-r2.ebuild 2558 BLAKE2B 296c0c92c9703d75764af9800233abcb0f59581c8a58adeea9aa15892550f13aa9ab5eaf6bb116ba2caae5694dd0bb4c4f0aa92045b5f460a990f19f71eb648b SHA512 12b6f128ea53d80b5628d25dddfff3822cde4947aad33dabef0295be53cf0eef18d2ee4c4a50bfeacbaa8e87c9a35d2ce18b44f27ddf9325bc8c9f93eea46fc7
MISC metadata.xml 821 BLAKE2B cb3c9d002c660aea2d9ebff9c48f32ca42e2dfb74b42dbd814b3acdd4afa71a9f6bf28fcd6df44492246b64f52a0537e5c24238bfd813f5b66c274242d4bc63e SHA512 2016c15fc50cb8766a8e701853f56f2823ee730e6cb0df122ba74526d0c0fa6909a3ed945a3a405d2d1c35933c4b80b44a9158ced8d8e68372954a740413dfe5
diff --git a/sys-process/cronie/cronie-1.6.1-r2.ebuild b/sys-process/cronie/cronie-1.6.1-r2.ebuild
new file mode 100644
index 000000000000..18db278ec2e5
--- /dev/null
+++ b/sys-process/cronie/cronie-1.6.1-r2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools cron flag-o-matic pam systemd
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron"
+HOMEPAGE="https://github.com/cronie-crond/cronie"
+SRC_URI="https://github.com/cronie-crond/cronie/archive/${P}.tar.gz"
+
+LICENSE="ISC BSD BSD-2 GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+anacron +inotify pam selinux"
+
+DEPEND="
+ acct-group/crontab
+ pam? ( sys-libs/pam )
+ anacron? (
+ !sys-process/anacron
+ !sys-process/systemd-cron
+ elibc_musl? ( sys-libs/obstack-standalone )
+ )
+ selinux? ( sys-libs/libselinux )
+"
+RDEPEND="${DEPEND}
+ sys-apps/debianutils
+"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+S="${WORKDIR}/${PN}-${P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.3-systemd.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with inotify)
+ $(use_with pam)
+ $(use_with selinux)
+ $(use_enable anacron)
+ --enable-syscrontab
+ # Required for correct pidfile location #835814
+ --runstatedir="${EPREFIX}/run"
+ --with-daemon_username=cron
+ --with-daemon_groupname=cron
+ )
+
+ if use anacron ; then
+ if use elibc_musl ; then
+ append-cflags "-lobstack"
+ fi
+ fi
+ SPOOL_DIR="/var/spool/cron/crontabs" \
+ ANACRON_SPOOL_DIR="/var/spool/anacron" \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docrondir -m 1730 -o root -g crontab
+ fowners root:crontab /usr/bin/crontab
+ fperms 2751 /usr/bin/crontab
+
+ newconfd "${S}"/crond.sysconfig ${PN}
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-crontab" crontab
+ newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+ insinto /etc/cron.d
+ doins contrib/{0hourly,dailyjobs}
+
+ newinitd "${FILESDIR}/${PN}-1.3-initd" ${PN}
+
+ if use pam ; then
+ newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+ fi
+
+ systemd_newunit contrib/cronie.systemd cronie.service
+
+ if use anacron ; then
+ local anacrondir="/var/spool/anacron"
+ keepdir ${anacrondir}
+ fowners root:cron ${anacrondir}
+ fperms 0750 ${anacrondir}
+
+ insinto /etc
+ doins contrib/anacrontab
+
+ insinto /etc/cron.hourly
+ doins contrib/0anacron
+ fperms 0750 /etc/cron.hourly/0anacron
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+
+ if [[ -n "${REPLACING_VERSIONS}" ]] ; then
+ ewarn "You should restart ${PN} daemon or else you might experience segfaults"
+ ewarn "or ${PN} not working reliably anymore."
+ einfo "(see https://bugs.gentoo.org/557406 for details.)"
+ fi
+}