summaryrefslogtreecommitdiff
path: root/sys-process/cronbase/cronbase-0.3.7-r8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /sys-process/cronbase/cronbase-0.3.7-r8.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'sys-process/cronbase/cronbase-0.3.7-r8.ebuild')
-rw-r--r--sys-process/cronbase/cronbase-0.3.7-r8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-process/cronbase/cronbase-0.3.7-r8.ebuild b/sys-process/cronbase/cronbase-0.3.7-r8.ebuild
new file mode 100644
index 000000000000..ec0f921d2255
--- /dev/null
+++ b/sys-process/cronbase/cronbase-0.3.7-r8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Base for all cron ebuilds"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+DEPEND="acct-group/cron"
+RDEPEND="
+ ${DEPEND}
+ acct-user/cron
+"
+
+src_install() {
+ newsbin "${FILESDIR}"/run-crons-${PV} run-crons
+
+ diropts -m0750
+ keepdir /etc/cron.{hourly,daily,weekly,monthly}
+
+ keepdir /var/spool/cron/lastrun
+ diropts -m0750 -o root -g cron
+ keepdir /var/spool/cron
+}